RuneAudio+R e4

Raspberry Pi related support

Re: RuneAudio+R e4

Postby ceejayemm » 05 Aug 2020, 20:28

@rern

Further update:

I have just updated an existing web radio url (changed hostname to ip address) and then all Library item counts 'magically' appeared. Album/tracks will now play from NAS (in addition to Coverarts) but still not from any other Library item.

Chris
ceejayemm
 
Posts: 86
Joined: 29 Oct 2016, 18:13

Re: RuneAudio+R e4

Postby rern » 05 Aug 2020, 21:02

maxus minimax wrote:...
Existing home automation, crestron. I want to start/stop playing favorites by the push of one button on the existing control panels without opening a browser or additional app. Headless Players, active ceiling speakers. A high WAF is key... ;-)
As mentioned, it´s just about basic commands and not a full blown API. Would do the setup via browser.


SSH command line:
Code: Select all
cat << 'EOF' > /srv/http/mpc.php
<?php
exec( 'mpc '.$_GET[ 'cmd' ] );

EOF
chown http:http /srv/http/mpc.php

Then you can:
http://192.168.10.20/mpc.php?cmd=play

klasssikmann wrote:Missing thumbnails in the coverart library view: Looks much better; first tests show the missing thumbnails during very fast scrolling. If this behaviour confirms I can live with that.
...

It's LazyLoad which load images only visible portion of the page. Otherwise it will continue loading all before ready.

ceejayemm wrote:Further update:

I have just updated an existing web radio url (changed hostname to ip address) and then all Library item counts 'magically' appeared. Album/tracks will now play from NAS (in addition to Coverarts) but still not from any other Library item.

Try: (It'll take a while to finish.)
Code: Select all
/srv/http/bash/cmd.sh mpcupdate


rern
RuneAudio+R @ github.com/rern
Raspberry Pi 4B
Raspberry Pi 3B > SMSL M8 DAC
Raspberry Pi Zero W
User avatar
rern
 
Posts: 630
Joined: 14 Jul 2016, 08:15

Re: RuneAudio+R e4

Postby ceejayemm » 05 Aug 2020, 21:58

@rern

Thanks for this code to try. The result is:

root@RAamp1+R e4:~ # /srv/http/bash/cmd.sh mpcupdate
Updating DB (#5) ...
volume: 28% repeat: off random: off single: off consume: off
root@RAamp1+R e4:~ #

Time to complete - a few seconds

No apparent change to Library items, same access as previously.

Further info:

If I go to NAS | Nas_Music, select anartist then album then click on the album cover then select Tags I CAN access library items via any of the TAG items so it seems the database is being updated but none of the items are currently available via the main Library screen items.

Chris
ceejayemm
 
Posts: 86
Joined: 29 Oct 2016, 18:13

Re: RuneAudio+R e4

Postby ceejayemm » 06 Aug 2020, 08:59

@rern

Saw that you had released a bug update (20200806) today so applied it to see if it fixed any of my problems. Update ran OK and asked me to rebuild the Library at the end. Before doing this I checked the existing Library and all items now seemed to work as expected. I am however doing a complete Library rebuild just in case. I will let you know later, once the Library update completes, if there are any other problems.

Thanks

Chris
ceejayemm
 
Posts: 86
Joined: 29 Oct 2016, 18:13

Re: RuneAudio+R e4

Postby ceejayemm » 06 Aug 2020, 12:20

@rern

Ok, update 20200806 initially seemed to help somewhat. However after completely rebuilding the Library database all items seemed OK except for Albums which only showed a count of one and only listed one (strange) album in its list. It also seemed to take quite a while to complete. Whilst trying to figure out what had happened I saw that you had released update 202008061. I applied this, and again completely rebuilt the Library (which this time seemed to happen very quickly), and now all seems well. I can access all elements of the Library as I would expect.

Throughout these updates the volume level seems to have stabilised and the Merus Amp Hardware Mixer setting seems to have stayed put too.

Thanks for these updates.

Chris
ceejayemm
 
Posts: 86
Joined: 29 Oct 2016, 18:13

Re: RuneAudio+R e4

Postby cycl157 » 06 Aug 2020, 16:45

rern wrote:SSH command line:
Code: Select all
cat << 'EOF' > /srv/http/mpc.php
<?php
exec( 'mpc '.$_GET[ 'cmd' ] );

EOF
chown http:http /srv/http/mpc.php

Then you can:
http://192.168.10.20/mpc.php?cmd=play


Thank you! i have been wanting to find a way to automate some actions through my smarthub and this would work perfect!!!
cycl157
 
Posts: 9
Joined: 02 Jun 2020, 02:37

Re: RuneAudio+R e4

Postby ben569 » 07 Aug 2020, 14:32

Greetings,

I have been using regular runeaudio for a year or 2 but I'm new to runeaudio+R.

I've installed the latest image you provided in your first post.

I've got a raspberry 1 B+, usb wifi and usb bluetooth dongles. I'm trying to get this specific bluetooth dongle to work. It runs fine on my laptop and I had it running perfectly on another distro on the pi.

But the network tab just doesn't have a bluetooth tab the light on the dongle doesn't start, etc.

I've attached a journalctl -xe dump if that helps.

I've tried the DIY method from your github but the generated barebones arch doesn't seem bootable -- no image on the HDMI port.

Kind regards,
Attachments
journalctl.txt.zip
(18.34 KiB) Downloaded 26 times
ben569
 
Posts: 1
Joined: 07 Aug 2020, 14:15

Re: RuneAudio+R e4

Postby rern » 08 Aug 2020, 14:22

@ben569,

Bluetooth audio in RuneAudio+R e4 is not quite there yet. The output is broken into small pulses.
Try:
Code: Select all
modprobe btusb
systemctl start bluetooth bluealsa

rern
RuneAudio+R @ github.com/rern
Raspberry Pi 4B
Raspberry Pi 3B > SMSL M8 DAC
Raspberry Pi Zero W
User avatar
rern
 
Posts: 630
Joined: 14 Jul 2016, 08:15

Re: RuneAudio+R e4

Postby elex » 11 Aug 2020, 20:17

I'm having the issue previously reported where indexing seems to work, I get track, album, artist counts, but the links are all unclickable. I have tried clean installs from the image on the first page as recently as today. I have attempted to restore my previous backups as well, but they break with the newer dated releases. I would be interested in what to look at to troubleshoot this further. I've tried debug logging in mpd and scouring the various system logs to no avail. I've really appreciated all the hard work on this to this point, but no longer have a usable player if I keep up with the current releases. I'm really at a loss as it seems the recent releases have fixed this for others.
Elex
--------------------------
Raspberry Pi 4b
HiFiBerry Digi+ Pro
elex
 
Posts: 3
Joined: 07 Aug 2020, 22:13

Re: RuneAudio+R e4

Postby hermano » 12 Aug 2020, 16:51

using RuneAudio+R e4 but date toggle not working. I get a list of years but when Click on a year it just hangs. Any ideas?
hermano
 
Posts: 3
Joined: 09 Jun 2020, 13:39

support RuneAudio Donate with PayPal

PreviousNext

Return to Raspberry Pi

Who is online

Users browsing this forum: cmh714 and 14 guests