enabling wireless to stay on

Raspberry Pi related support

enabling wireless to stay on

Postby tsawyer » 06 Jan 2021, 01:47

I am running Version e6 20201221 on Raspberry Pi 3 Model B Plus Rev 1.3 (as taken from the system link) and can only setup wireless from the wired connection. once I've turned on wireless, configured what I needed and it's fine. until I reboot. at that point, I have to connect on the wired connection, turn on wireless again. so if I have this in a place where I do not have a wired connection, it's not going to work. how do I have the wireless turned on and stay on? rite now it seems like the config is not being saved so on reboot it goes back to a default where wireless is off
tsawyer
 
Posts: 73
Joined: 05 Jul 2017, 03:02

Re: enabling wireless to stay on

Postby rastus » 06 Jan 2021, 04:17

Hi,

your answer may be in the "Version e6" thread:

runeaudio-r-e6-t7141.html

Regards,

Rastus.
User avatar
rastus
 
Posts: 352
Joined: 21 Aug 2015, 10:29

Re: enabling wireless to stay on

Postby tsawyer » 06 Jan 2021, 19:13

I pulled the post up but there seems still be a problem. from github.com/rern/rAudio-1 I used this part

From existing

Copy an existing profile file from /etc/netctl
Rename it to wifi then copy it to BOOT before power on.

Edit template file - name and password.

Rename wifi0 in BOOT to wifi
Edit SSID and Key.


after doing it, I have found the wifi file does not exist after a reboot. I've tried it via cp, rename, nano => save as to place a file in the boot dir. every time, wifi does not show. this of course means witi is not turned on when I reboot.
tsawyer
 
Posts: 73
Joined: 05 Jul 2017, 03:02

Re: enabling wireless to stay on

Postby R101 » 07 Jan 2021, 18:40

@tsawyer

The wifi file is deleted after the boot, even if connection does not succeed. If the file is found, the Pi seems to make all the changes needed to get wifi working, not just copy the file to /etc/netctl.

Just to be clear, those are different options you listed. If you copy rename and paste a working /netctl file to /boot/wifi, you can ignore the wifi0 file. The wifi0 file is there as a template if you are starting from scratch.

If you have a working connection which does not connect after reboot, try doing systemctl enable netctl-auto@wlan0 or replace wlan0 with the wireless interface shown by ifconfig if it's different. The interface shown in the /netctl file should match that.
(Pi 3B, rAudio-1, JLS I2S over USB)
R101
 
Posts: 343
Joined: 29 Apr 2016, 16:16

Re: enabling wireless to stay on

Postby tsawyer » 08 Jan 2021, 04:24

thanx for the response. yes, I understand the options I listed are all different paths. I was listed various procedures that could be ruled out as already did not work. that being said, I did try systemctl enable netctl-auto@wlan0 and systemctl enable netctl-auto@wlan0.service from the line command. neither command worked as far as turning on the wifi functionality. if I run systemctl --type=service I do not see the service running. in short, I have to log into the pi from eth0 is the only connection. I was planning on moving this to a place where there is not wired connection so any loss of power, it's not coming back. I've tried this on 3 different pis so I really doubt all of them have a hw problem. but when iwconfig says no wireless connection until I click wifi on, something does not seem rite
tsawyer
 
Posts: 73
Joined: 05 Jul 2017, 03:02

Re: enabling wireless to stay on

Postby R101 » 08 Jan 2021, 11:42

I use wifi, but via a USB dongle, so it would be good if someone using the on-board wifi could confirm that it works. I don't think the default setup allocates wlan0 unless predictable naming is disabled, by the way, so do check the interface name if you haven't already.
(Pi 3B, rAudio-1, JLS I2S over USB)
R101
 
Posts: 343
Joined: 29 Apr 2016, 16:16

Re: enabling wireless to stay on

Postby tsawyer » 08 Jan 2021, 15:30

that is one thing I keep failing to explicitly define: I am using the on board wifi of the pi, not a dongle. once I select wifi on the interface, it's up. from that point iwconfig , ip link or ifconfig would see it. prior to turn it on in the interface, all commands would not see it or even allow to do anything/be turned on. I'll have to look into predictable naming
tsawyer
 
Posts: 73
Joined: 05 Jul 2017, 03:02

Re: enabling wireless to stay on

Postby R101 » 08 Jan 2021, 17:14

Predictable naming should not be a problem if you start from scratch. If you already have a working netctl file which contains the interface name and copy it to /boot/wifi, the pi will sometimes allocate a new and different name to the interface, so you have to edit the netctl file to match (or delete it before boot). I had this problem while trying to get the dongle working, so I always disable ifnames, although I probably don't need to.

If it still doesn't work, try a fresh image and set it up from cold, without using restore or copying anything. Just create a wifi file before you touch any settings, and reboot. It will probably work.
(Pi 3B, rAudio-1, JLS I2S over USB)
R101
 
Posts: 343
Joined: 29 Apr 2016, 16:16

Re: enabling wireless to stay on

Postby tsawyer » 08 Jan 2021, 18:39

good idea on the reimage post. I downloaded another copy and see a difference in the kernel during a scan (ping sweep to see what the new address is on the network with some other fields for info) went from 1.19.3 to 1.19.6. I noticed the interface was difference so even though I requested an update, I was not running the latest version. I also can not ssh into the box with the old credentials, root/rune.

I did want to try the wifi and now it's surviving a reboot. I set it up like normal, rebooted and still saw it. after moving it to where I want that box to live (not on my desk and work area so it was powered down to move) I can still see it on the wireless network. I'll be trying the new image on the other box I planned to keep downstairs, hopefully the new update resolves the issue. sad to no longer be allowed to ssh into it but if the graphical allows everything, I'll take it.
tsawyer
 
Posts: 73
Joined: 05 Jul 2017, 03:02

Re: enabling wireless to stay on

Postby R101 » 08 Jan 2021, 19:38

I think the key to getting the wifi working is to use the wifi file method to get it going before doing anything else. Using restore or altering the wifi settings in the UI can be fatal :)

Re. ssh, you did remember the password is now ros?
(Pi 3B, rAudio-1, JLS I2S over USB)
R101
 
Posts: 343
Joined: 29 Apr 2016, 16:16

support RuneAudio Donate with PayPal

Next

Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 1 guest