RuneAudio+R e5

Raspberry Pi related support

RuneAudio+R e5

Postby rern » 24 Aug 2020, 07:50

RuneAudio+R e5

For all Raspberry Pi: Zero, 1, 2, 3 and 4

As of 20201019, this has been upgraded to RuneAudio+R e6

A new e of RuneAudio+R
    - Upgrade kernel and all packages to latest versions
    - Faster

Image


How-to:

- Windows: Download and decompress to RuneAudio+R_e4-RPi*.img with 7-zip, WinRAR or WinZip and write the file to a micro SD card, 4GB or more, with Win32 Disk Imager
- Linux or Windows: Write from URL to a micro SD card directly with Etcher

- Existing users:
    - Keep current setup SD card.
    - Try with a spare one before moving forward.
    - Always use backup.gz created by latest update to restore system.
- Before power on:
    - Wi-Fi pre-configure - 3 alternatives: (Only if no wired LAN available.)
      1. From existing
        - Copy an existing profile file from /etc/netctl .
        - Rename it to wifi then copy it to BOOT before power on.
      2. Edit template file - name and password
        - Rename wifi0 in BOOT to wifi .
        - Edit SSID and Key.
      3. Generate a complex profile - static IP, hidden SSID

- If connected to a screen, IP address and QR code for connecting from remote devices displayed.
- Before setup anything, Settings > Addons > RuneAudio+R e5 > Update (if available)
- Restore settings and database: Settings > System > Backup/Restore Settings (if there is one)
- Music Library database - USB drive automatically run if already plugged in otherwise Settings > update Library (icon next to MPD)
- Coverarts in browse by Album and directory thumbnails - Library > Album > coverart icon (next to ALBUM heading)

Not working?
- Power off and wait a few seconds then power on
- If not connected, temporarily connect wired LAN then remove after Wi-Fi setup successfully.
- Still no - Download the image file and start over again


RuneAudio+R - An improved version of RuneAudio
- Based on features from RuneUI Enhancement
- Complete frontend redesigned
- Complete backend rebuilt with latest Arch Linux Arm
- System-wide upgraded to the latest kernel and packages
- Improved performance and response
- Metadata Tag Editor - *.cue support
- Album mode with coverarts
- File mode with thumbnail icons
- Coverarts and bookmarks - add, replace and remove
- Support WebRadio and UPnP coverarts - online fetched
- Support *.jpg, *.png and animated *.gif
- Support *.cue - virtually as individual tracks in all modes and user playlists
- Support *.wav album artists and sort tracks
- Support USB DAC plug ang play
- Renderers / Clients and Streamers (with metadata and coverarts)
    - AirPlay
    - Spotify Connect (Premium account only)
    - UPnP
    - Snapcast with metadata and coverarts
    - simple HTTP


Tips
- Best sound quality:
    - Settings > MPD > Bit-perfect - Enable
    - Use only amplifier volume (Unless quality of DAC hardware volume is better.)
- Disable features if not use to lower CPU usage:
    Settings > System > Features
- Coverart as large playback control buttons
    - Tap top of coverart to see controls guide.
- Hide top and bottom bars
    - No needs for top and bottom bars
    - Use coverart controls instead of top bar buttons
    - Swipe to switch between pages
    <- Library <-> Playback <-> Playlist ->
- Drag to arrange order
    - Library home blocks
    - Playlist tracks
    - Saved playlist tracks
- Some coverarts missing from album directories
    - Subdirectories listed after partial Library database update from context menu.
    - Subdirectories - context menu > Exclude directory
- Some music files missing from library
    - Settings > MPD > question mark icon -scroll- FFmpeg Decoder
    - Enable if filetypes list contains ones of the missing files.
- CUE sheet
    - *.cue filenames must be identical to each coresponding music file.
    - Can be directly edited by Tag Editor.
- Minimum permission for music files (on Linux ext filesystem)
    - Directories: rwxr-xr-x (755)
    - Files: rw-r--r-- (644)
- RPi to router connection:
    - With wired LAN if possible - Disable Wi-Fi
    - With WiFi if necessary
    - With RPi accesspoint only if there's no router
- Connect to RuneAudio with IP address instead of runeaudio.local
    - Get IP address: Menu > Network > Network Interfaces list
    - Setup static IP address

Static IP address
Always setup at the router unless there is a good reason not to.
    Set at each device:
      - IP addresses have to be in the same range of the router.
      - IP addresses must not be duplicate of existing ones.
      - IP address must be reconfigured on every OS reinstallation.
      - A log is needed to manually update all assigned IP address-device data.
    Set at the router:
      - The router only allows reserved IP addresses in the same range.
      - Reserved IP addresses are verified not to duplicate.
      - The device always get the same IP address on every OS reinstallation without reconfigure.
      - The router always keep the update log of all IP address-device data.


rern
Last edited by rern on 19 Oct 2020, 05:48, edited 24 times in total.
RuneAudio+R @ github.com/rern
Raspberry Pi 4B
Raspberry Pi 3B > SMSL M8 DAC
Raspberry Pi Zero W
User avatar
rern
 
Posts: 668
Joined: 14 Jul 2016, 08:15

Re: RuneAudio+R e5

Postby RobP » 24 Aug 2020, 09:53

OO Thank you. I'll try it right now and get back.

Edit:
Working now. I've got a fairly simple set-up: RPi4 connected to wireless AP via ethernet cable. HDMI cable to AV amplifier. Audio files on hard-drive connected via USB but seems to work ok for me. Finds all the files, plays them etc.
Last edited by RobP on 24 Aug 2020, 11:18, edited 1 time in total.
RobP
 
Posts: 2
Joined: 12 Jul 2020, 22:22

Re: RuneAudio+R e5

Postby hermano » 24 Aug 2020, 10:58

Thanks rern,
Running now, but same for me as +Re4, the date function not working. Click on a year and it just hangs (flashing RuneAudio). using Pi4 and RuneAudio+R e5
hermano
 
Posts: 3
Joined: 09 Jun 2020, 13:39

Re: RuneAudio+R e5

Postby R101 » 24 Aug 2020, 12:09

Hi rern,

I am not getting any embedded cover art from the radio streams.

The Webradio change cover art function converts a png image to a jpg thumbnail, but leaves the playback image as a png, which does not display.

Edit:

Also, NAS does not mount automatically. (Edit:) If the share name has a space in it, so not a problem.
(Pi 4B, RuneAudio+R e6, JLS I2S over USB)
R101
 
Posts: 335
Joined: 29 Apr 2016, 16:16

Re: RuneAudio+R e5

Postby cmh714 » 24 Aug 2020, 15:48

Restored my previous settings and now a bit messed up.....I cannot get to any of the Settings pages, clicking the Gear icon does nothing atm....

****EDIT: OK, so I added a Radio to the playlist and now the Settings menu does Open properly!

***CRAP: now after another reboot I have absolutely no controls on the UI....just the Rune Audio logo....argh
cmh714
 
Posts: 431
Joined: 04 May 2014, 03:06

Re: RuneAudio+R e5

Postby cotriumph » 24 Aug 2020, 17:54

Thanks for the e5 release! Spotify now works for me (would not connect in e4).

I also see you have added Bluetooth back to the system settings, and I've activated this, but I'm not seeing any runeaudio bluetooth device on my phone or computer. Is there a trick to get this initialized and in pairing mode?

Running latest e5 for Pi4.

Update, whenever I go into MPD settings (even when not changing anything), then closing, i get the blank screen with RuneAudio logo. Need to reboot Pi4 to get back to normal.

Cheers!
cotriumph
 
Posts: 4
Joined: 24 Aug 2020, 17:50

Re: RuneAudio+R e5

Postby AndyF » 24 Aug 2020, 19:47

@cmh714
Try to restart mpd and mpdidle service via ssh and systemctl. If you get UI back, try to reconfigure your soundcard.
Disablng i2s + reboot / re-set i2s + reboot worked on my system.

regards, Andy
AndyF
 
Posts: 149
Joined: 02 Aug 2015, 07:36
Location: Germany - Bavaria

Re: RuneAudio+R e5

Postby cmh714 » 24 Aug 2020, 20:52

Thanks Andy! Since my setup is pretty straightforward and I have been at this for so long now I can just start over and be up and running in short order....HOWEVER, starting clean, I am having all sorts of odd issues....First the UI is acting weird, again the Gear icon in the "Circle" is broken but I can use the one at the bottom....I imported my webradios, then created a Playlist and then I had absolutely no control over the UI again....all I have is the Rune Audio logo, cant swipe, nothing to click on.....
cmh714
 
Posts: 431
Joined: 04 May 2014, 03:06

Re: RuneAudio+R e5

Postby cotriumph » 24 Aug 2020, 22:27

I think part of my 'blank screen with rune logo' is related to airplay and/or spotify. I was just air-playing (as i can't get Bluetooth to work) from my phone, and noticed the web interface had changed to the blank+logo view. I paused the airplay stream, and it instantly came back. On starting playing again, it showed the coverart view that allows me to get to configuration etc.

As soon as I go back into configuration though and exit though, back the blank screen.
cotriumph
 
Posts: 4
Joined: 24 Aug 2020, 17:50

Re: RuneAudio+R e5

Postby RolandBlaze » 25 Aug 2020, 12:07

@Rern

Can't mount on NAS on new build, using same credentials/details that have worked previously.

Tried restore config on fresh install
Tried restore config fresh install - and latest update (today)
Tried Fresh install - no restore
Tried fresh install with todays update

After this all fails i then can no longer access settings and sources.. just sits there
Also disable volume control for DAC and noted the volume was "down low" even though setings should be of, swaped sdcard to previous build tha also has volume off and noted the volume went back 100 with volume settings off.

no luck. This appears to be same issue as with early +R e4

Thanks.
RuneAudio+R e6 20201108 
Raspberry Pi 4 Model B Rev 1.
User avatar
RolandBlaze
 
Posts: 29
Joined: 14 Oct 2017, 10:52

support RuneAudio Donate with PayPal

Next

Return to Raspberry Pi

Who is online

Users browsing this forum: cmh714 and 2 guests