Raspberry Pi Zero Support in 0.4

Raspberry Pi related support

Re: Raspberry Pi Zero Support in 0.4

Postby McAllister » 10 Mar 2017, 20:53

just a short supplement to my post from yesterday:

With this entry in the etc/boot/config.txt:
Code: Select all
# JustBoom Digi zero settings
dtparam=audio=off
dtoverlay=justboom-digi


...my pi zero and the "JustBoom Digi Zero pHAT" works fine.

Thanks for the software and these community!
;)
McAllister
 
Posts: 2
Joined: 09 Mar 2017, 20:53
Location: Germany

Re: Raspberry Pi Zero Support in 0.4

Postby rlsten » 10 Mar 2017, 21:50

Hi RawDevice,

Thanks very much for taking to time to set down those detailed instructions. Unfortunately, I don't have a Raspbery Pi B+ (only 2 and 3), so I couldn't force an update of the kernel (Step 4.) However, hpeter's image has the changes to cmdline.txt and config.txt you have in step 5, and the fact that I was able to complete through step 9 makes me think that the problem has something to do with the drivers or the relationship between the kernel and the drivers.

I tried everything again with a fresh hpeter image, and it still failed to recognize the Pi Zero W on board WiFi.

I don't know if this helps in figuring out what is going wrong, but when I tried the new brcmfmac43143-sdio.bin I got the following from dmesg:

Code: Select all
usbcore:registered new interface driver brmcfmac
brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43430-sdio.bin failed with error -2


When I saw the reference to brcmfmac43430-sdio.bin, I decided to try that driver from the brcm repository. This time I got the following:

Code: Select all
usbcore:registered new interface driver brmcfmac
loading /lib/firmware/brcm/brcmfmac43430-sdio.bin failed with error -22
brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43430-sdio.bin failed with error -22


Any ideas?

Thanks again,
Rod
rlsten
 
Posts: 114
Joined: 25 May 2015, 18:06

Re: Raspberry Pi Zero Support in 0.4

Postby rawdevice » 10 Mar 2017, 22:16

Hi Rod,

Sorry, I'm a noob at Arch Linux and have managed to get the Pi Zero W working by hacking together instructions from other, more knowledgeable souls. When I was at the point where I got RuneAudio working on the Pi Zero W but with a USB Wi-Fi adapter, not the on-board one, I found this link which suggested a way forward

Code: Select all
https://archlinuxarm.org/forum/viewtopic.php?f=65&t=9938


Knowing that the Zero W and the Pi 3 use the same Wi-Fi/Bluetooth chip, I tried to follow the hints in the article and ended up copying the following to /lib/firmware/brcm

Code: Select all
https://github.com/RPi-Distro/firmware-nonfree/raw/master/brcm80211/brcm/brcmfmac43430-sdio.bin
https://github.com/RPi-Distro/firmware-nonfree/raw/master/brcm80211/brcm/brcmfmac43430-sdio.txt


However, I couldn't do the suggested next step (chickened out after reading the warnings) which was to run rpi-update so it was unsuccessful. It was only after following the hints on the Pimoroni forum that I got the onboard Wi-Fi working. And yes, I overwrote the contents of the /boot directory instead of replacing it with the cloned one.

Not sure if it will help you but here is the output from dmesg on my Zero W

Code: Select all
[root@runeaudio-zero ~]# dmesg
[    0.000000] Booting Linux on physical CPU 0x0
[    0.000000] Linux version 4.9.13+ (dc4@dc4-XPS13-9333) (gcc version 4.9.3 (crosstool-NG crosstool-ng-1.22.0-88-g8460611) ) #974 Wed Mar 1 20:04:40 GMT 2017
[    0.000000] CPU: ARMv6-compatible processor [410fb767] revision 7 (ARMv7), cr=00c5387d
[    0.000000] CPU: PIPT / VIPT nonaliasing data cache, VIPT nonaliasing instruction cache
[    0.000000] OF: fdt:Machine model: Raspberry Pi Zero W Rev 1.1
[    0.000000] cma: Reserved 8 MiB at 0x1e400000
[    0.000000] Memory policy: Data cache writeback
[    0.000000] On node 0 totalpages: 126976
[    0.000000] free_area_init_node: node 0, pgdat c09147b4, node_mem_map ddfa4000
[    0.000000]   Normal zone: 1116 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 126976 pages, LIFO batch:31
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 125860
[    0.000000] Kernel command line: 8250.nr_uarts=0 bcm2708_fb.fbwidth=656 bcm2708_fb.fbheight=416 bcm2708_fb.fbdepth=16 bcm2708_fb.fbswap=1 smsc95xx.macaddr=B8:27:EB:FD:12:F6 vc_mem.mem_base=0x1fa00000 vc_mem.mem_size=0x20000000  root=/dev/mmcblk0p5 rw rootwait console=ttyS0,115200 console=tty1 selinux=0 plymouth.enable=0 smsc95xx.turbo_mode=N dwc_otg.lpm_enable=0 kgdboc=ttyS0,115200 elevator=noop
[    0.000000] PID hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000000] Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
[    0.000000] Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
[    0.000000] Memory: 484648K/507904K available (5941K kernel code, 489K rwdata, 1948K rodata, 404K init, 734K bss, 15064K reserved, 8192K cma-reserved)
[    0.000000] Virtual kernel memory layout:
    vector  : 0xffff0000 - 0xffff1000   (   4 kB)
    fixmap  : 0xffc00000 - 0xfff00000   (3072 kB)
    vmalloc : 0xdf800000 - 0xff800000   ( 512 MB)
    lowmem  : 0xc0000000 - 0xdf000000   ( 496 MB)
    modules : 0xbf000000 - 0xc0000000   (  16 MB)
      .text : 0xc0008000 - 0xc05d569c   (5942 kB)
      .init : 0xc083f000 - 0xc08a4000   ( 404 kB)
      .data : 0xc08a4000 - 0xc091e680   ( 490 kB)
       .bss : 0xc091e680 - 0xc09d5ee8   ( 735 kB)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:16 nr_irqs:16 16
[    0.000028] sched_clock: 32 bits at 1000kHz, resolution 1000ns, wraps every 2147483647500ns
[    0.000072] clocksource: timer: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 1911260446275 ns
[    0.000172] bcm2835: system timer (irq = 27)
[    0.000726] Console: colour dummy device 80x30
[    0.001544] console [tty1] enabled
[    0.001601] Calibrating delay loop... 697.95 BogoMIPS (lpj=3489792)
[    0.060341] pid_max: default: 32768 minimum: 301
[    0.060798] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.060868] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.061982] Disabling cpuset control group subsystem
[    0.062258] CPU: Testing write buffer coherency: ok
[    0.062368] ftrace: allocating 21710 entries in 64 pages
[    0.176375] Setting up static identity map for 0x8200 - 0x8238
[    0.178475] devtmpfs: initialized
[    0.189968] VFP support v0.3: implementor 41 architecture 1 part 20 variant b rev 5
[    0.190467] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.190568] futex hash table entries: 256 (order: -1, 3072 bytes)
[    0.191883] pinctrl core: initialized pinctrl subsystem
[    0.193438] NET: Registered protocol family 16
[    0.196138] DMA: preallocated 1024 KiB pool for atomic coherent allocations
[    0.206225] hw-breakpoint: found 6 breakpoint and 1 watchpoint registers.
[    0.206318] hw-breakpoint: maximum watchpoint size is 4 bytes.
[    0.206466] Serial: AMBA PL011 UART driver
[    0.211285] bcm2835-mbox 2000b880.mailbox: mailbox enabled
[    0.212089] uart-pl011 20201000.serial: could not find pctldev for node /soc/gpio@7e200000/uart0_pins, deferring probe
[    0.261282] bcm2835-dma 20007000.dma: DMA legacy API manager at df80d000, dmachans=0x1
[    0.263870] SCSI subsystem initialized
[    0.264202] usbcore: registered new interface driver usbfs
[    0.264370] usbcore: registered new interface driver hub
[    0.264607] usbcore: registered new device driver usb
[    0.266412] raspberrypi-firmware soc:firmware: Attached to firmware from 2017-03-02 15:33
[    0.268459] clocksource: Switched to clocksource timer
[    0.325317] VFS: Disk quotas dquot_6.6.0
[    0.325513] VFS: Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
[    0.325844] FS-Cache: Loaded
[    0.326252] CacheFiles: Loaded
[    0.345991] NET: Registered protocol family 2
[    0.347446] TCP established hash table entries: 4096 (order: 2, 16384 bytes)
[    0.347605] TCP bind hash table entries: 4096 (order: 2, 16384 bytes)
[    0.347739] TCP: Hash tables configured (established 4096 bind 4096)
[    0.347870] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.347938] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.348298] NET: Registered protocol family 1
[    0.349201] RPC: Registered named UNIX socket transport module.
[    0.349282] RPC: Registered udp transport module.
[    0.349323] RPC: Registered tcp transport module.
[    0.349362] RPC: Registered tcp NFSv4.1 backchannel transport module.
[    0.350628] hw perfevents: enabled with armv6_1176 PMU driver, 3 counters available
[    0.353155] workingset: timestamp_bits=14 max_order=17 bucket_order=3
[    0.373237] FS-Cache: Netfs 'nfs' registered for caching
[    0.375092] NFS: Registering the id_resolver key type
[    0.375199] Key type id_resolver registered
[    0.375243] Key type id_legacy registered
[    0.379832] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 251)
[    0.380303] io scheduler noop registered (default)
[    0.380372] io scheduler deadline registered
[    0.380841] io scheduler cfq registered
[    0.386916] BCM2708FB: allocated DMA memory 5e500000
[    0.387046] BCM2708FB: allocated DMA channel 0 @ df80d000
[    0.392492] Console: switching to colour frame buffer device 82x26
[    0.400498] bcm2835-rng 20104000.rng: hwrng registered
[    0.402338] vc-cma: Videocore CMA driver
[    0.403899] vc-cma: vc_cma_base      = 0x00000000
[    0.405432] vc-cma: vc_cma_size      = 0x00000000 (0 MiB)
[    0.406988] vc-cma: vc_cma_initial   = 0x00000000 (0 MiB)
[    0.409113] vc-mem: phys_addr:0x00000000 mem_base=0x1fa00000 mem_size:0x20000000(512 MiB)
[    0.437610] brd: module loaded
[    0.451639] loop: module loaded
[    0.453170] Loading iSCSI transport class v2.0-870.
[    0.455596] usbcore: registered new interface driver smsc95xx
[    0.457133] dwc_otg: version 3.00a 10-AUG-2012 (platform bus)
[    0.684978] Core Release: 2.80a
[    0.686502] Setting default values for core params
[    0.687930] Finished setting default values for core params
[    0.889770] Using Buffer DMA mode
[    0.891239] Periodic Transfer Interrupt Enhancement - disabled
[    0.892717] Multiprocessor Interrupt Enhancement - disabled
[    0.894198] OTG VER PARAM: 0, OTG VER FLAG: 0
[    0.895746] Dedicated Tx FIFOs mode
[    0.897795] WARN::dwc_otg_hcd_init:1053: FIQ DMA bounce buffers: virt = 0xde514000 dma = 0x5e514000 len=9024
[    0.900953] FIQ FSM acceleration enabled for :
Non-periodic Split Transactions
Periodic Split Transactions
High-Speed Isochronous Endpoints
Interrupt/Control Split Transaction hack enabled
[    0.908669] dwc_otg: Microframe scheduler enabled
[    0.908802] WARN::hcd_init_fiq:459: FIQ on core 0 at 0xc04503a0
[    0.910424] WARN::hcd_init_fiq:460: FIQ ASM at 0xc045067c length 36
[    0.912024] WARN::hcd_init_fiq:486: MPHI regs_base at 0xdf8a7000
[    0.913672] dwc_otg 20980000.usb: DWC OTG Controller
[    0.915298] dwc_otg 20980000.usb: new USB bus registered, assigned bus number 1
[    0.916996] dwc_otg 20980000.usb: irq 56, io mem 0x00000000
[    0.918705] Init: Port Power? op_state=1
[    0.920281] Init: Power Port (0)
[    0.922148] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[    0.923768] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    0.925339] usb usb1: Product: DWC OTG Controller
[    0.926878] usb usb1: Manufacturer: Linux 4.9.13+ dwc_otg_hcd
[    0.928421] usb usb1: SerialNumber: 20980000.usb
[    0.931229] hub 1-0:1.0: USB hub found
[    0.932890] hub 1-0:1.0: 1 port detected
[    0.935279] dwc_otg: FIQ enabled
[    0.935290] dwc_otg: NAK holdoff enabled
[    0.935296] dwc_otg: FIQ split-transaction FSM enabled
[    0.935315] Module dwc_common_port init
[    0.935823] usbcore: registered new interface driver usb-storage
[    0.937873] mousedev: PS/2 mouse device common for all mice
[    0.941149] bcm2835-wdt 20100000.watchdog: Broadcom BCM2835 watchdog timer
[    0.943351] bcm2835-cpufreq: min=700000 max=1000000
[    0.945600] sdhci: Secure Digital Host Controller Interface driver
[    0.947229] sdhci: Copyright(c) Pierre Ossman
[    0.949521] sdhost: log_buf @ de513000 (5e513000)
[    1.028528] mmc0: sdhost-bcm2835 loaded - DMA enabled (>1)
[    1.052983] mmc-bcm2835 20300000.mmc: mmc_debug:0 mmc_debug2:0
[    1.054665] mmc-bcm2835 20300000.mmc: DMA channel allocated
[    1.067000] random: fast init done
[    1.108659] sdhci-pltfm: SDHCI platform and OF driver helper
[    1.110870] ledtrig-cpu: registered to indicate activity on CPUs
[    1.112672] hidraw: raw HID events driver (C) Jiri Kosina
[    1.114547] usbcore: registered new interface driver usbhid
[    1.116155] usbhid: USB HID core driver
[    1.120141] vchiq: vchiq_init_state: slot_zero = 0xde580000, is_master = 0
[    1.131427] Initializing XFRM netlink socket
[    1.133404] NET: Registered protocol family 17
[    1.135353] Key type dns_resolver registered
[    1.139629] registered taskstats version 1
[    1.147240] vc-sm: Videocore shared memory driver
[    1.149155] [vc_sm_connected_init]: start
[    1.151354] vc_vchi_sm_init: failed to open VCHI service (-1)
[    1.151554] [vc_sm_connected_init]: failed to initialize shared memory service
[    1.154740] [vc_sm_connected_init]: end - returning -1
[    1.156387] mmc1: queuing unknown CIS tuple 0x80 (2 bytes)
[    1.160706] 20201000.serial: ttyAMA0 at MMIO 0x20201000 (irq = 81, base_baud = 0) is a PL011 rev2
[    1.165376] of_cfs_init
[    1.167284] of_cfs_init: OK
[    1.169755] mmc1: queuing unknown CIS tuple 0x80 (3 bytes)
[    1.173503] mmc1: queuing unknown CIS tuple 0x80 (3 bytes)
[    1.176272] Waiting for root device /dev/mmcblk0p5...
[    1.180483] mmc0: host does not support reading read-only switch, assuming write-enable
[    1.184471] mmc1: queuing unknown CIS tuple 0x80 (7 bytes)
[    1.187155] mmc0: new high speed SDHC card at address aaaa
[    1.190297] mmcblk0: mmc0:aaaa SL08G 7.40 GiB
[    1.195974]  mmcblk0: p1 p2 < p5 >
[    1.291706] mmc1: new high speed SDIO card at address 0001
[    1.293668] EXT4-fs (mmcblk0p5): couldn't mount as ext3 due to feature incompatibilities
[    1.298623] EXT4-fs (mmcblk0p5): couldn't mount as ext2 due to feature incompatibilities
[    1.319742] EXT4-fs (mmcblk0p5): mounted filesystem with ordered data mode. Opts: (null)
[    1.323469] VFS: Mounted root (ext4 filesystem) on device 179:5.
[    1.334107] devtmpfs: mounted
[    1.337201] Freeing unused kernel memory: 404K (c083f000 - c08a4000)
[    1.339149] This architecture does not have kernel memory protection.
[    1.655080] systemd[1]: systemd 216 running in system mode. (+PAM -AUDIT -SELINUX -IMA -APPARMOR +SMACK -SYSVINIT +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ -LZ4 +SECCOMP +BLKID -ELFUTILS +KMOD -IDN )
[    1.661976] systemd[1]: Detected architecture 'arm'.
[    1.820872] NET: Registered protocol family 10
[    1.824840] systemd[1]: Inserted module 'ipv6'
[    1.829826] systemd[1]: Set hostname to <runeaudio-zero>.
[    2.508875] systemd[1]: Cannot add dependency job for unit display-manager.service, ignoring: Unit display-manager.service failed to load: No such file or directory.
[    2.525460] systemd[1]: Starting Forward Password Requests to Wall Directory Watch.
[    2.530329] systemd[1]: Started Forward Password Requests to Wall Directory Watch.
[    2.534472] systemd[1]: Starting Remote File Systems.
[    2.539347] systemd[1]: Reached target Remote File Systems.
[    2.541665] systemd[1]: Expecting device sys-subsystem-net-devices-wlan0.device...
[    2.960226] systemd-modules-load[84]: Module 'nfs' is builtin
[    2.963598] systemd-modules-load[84]: Failed to find module 'bcm2708-rng'
[    3.055221] systemd-modules-load[84]: Inserted module 'snd_bcm2835'
[    3.202504] EXT4-fs (mmcblk0p5): Mount option "nouser_xattr" will be removed by 3.5
Contact linux-ext4@vger.kernel.org if you think we should keep it.

[    3.228688] EXT4-fs (mmcblk0p5): re-mounted. Opts: nouser_xattr,errors=remount-ro
[    4.539027] systemd-udevd[108]: starting version 216
[    5.322423] gpiomem-bcm2835 20200000.gpiomem: Initialised: Registers at 0x20200000
[    5.624984] snd-rpi-iqaudio-dac soc:sound: ASoC: CPU DAI (null) not registered - will retry
[    5.629911] snd-rpi-iqaudio-dac soc:sound: ASoC: CODEC DAI pcm512x-hifi not registered - will retry
[    5.864798] FAT-fs (mmcblk0p1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.
[    6.012551] snd-rpi-iqaudio-dac soc:sound: ASoC: CODEC DAI pcm512x-hifi not registered - will retry
[    6.039149] usbcore: registered new interface driver brcmfmac
[    6.040865] snd-rpi-iqaudio-dac soc:sound: ASoC: CODEC DAI pcm512x-hifi not registered - will retry
[    6.242904] brcmfmac: Firmware version = wl0: May 27 2016 00:13:38 version 7.45.41.26 (r640327) FWID 01-df77e4a7
[    6.676688] systemd[1]: Starting System Initialization.
[    6.684776] systemd[1]: Reached target System Initialization.
[    6.685218] systemd[1]: Starting Daily verification of password and group files.
[    6.699145] systemd[1]: Started Daily verification of password and group files.
[    6.699528] systemd[1]: Starting Daily rotation of log files.
[    6.700676] systemd[1]: Started Daily rotation of log files.
[    6.701021] systemd[1]: Starting Avahi mDNS/DNS-SD Stack Activation Socket.
[    6.708803] systemd[1]: Listening on Avahi mDNS/DNS-SD Stack Activation Socket.
[    6.709230] systemd[1]: Starting D-Bus System Message Bus Socket.
[    6.716577] systemd[1]: Listening on D-Bus System Message Bus Socket.
[    7.499302] snd-rpi-iqaudio-dac soc:sound: pcm512x-hifi <-> 20203000.i2s mapping ok
[    9.594635] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[    9.594654] brcmfmac: power management disabled
[   10.600426] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   11.805415] systemd[1]: Starting Multi-User System.
[   11.816179] systemd[1]: Reached target Multi-User System.
[   11.816542] systemd[1]: Starting RuneAudio System Worker...
[   11.887785] systemd[1]: Started RuneAudio System Worker.
[   11.888433] systemd[1]: Starting Graphical Interface.
[   11.899111] systemd[1]: Reached target Graphical Interface.
[   11.907789] systemd[1]: Startup finished in 1.513s (kernel) + 10.316s (userspace) = 11.829s.
[   13.740727] systemd[1]: Stopping The PHP FastCGI Process Manager...
[   13.791418] systemd[1]: Stopped The PHP FastCGI Process Manager.
[   14.122038] systemd[1]: Starting Music Player Daemon...
[   17.052313] systemd[1]: Starting Upmpdcli UPnP/DLNA receiver...
[   17.060244] systemd[1]: Started Upmpdcli UPnP/DLNA receiver.
[   17.954480] systemd[1]: rune_PL_wrk.service: main process exited, code=exited, status=255/n/a
[   17.972854] systemd[1]: Unit rune_PL_wrk.service entered failed state.
[   18.334890] systemd[1]: mpd.service holdoff time over, scheduling restart.
[   18.341345] systemd[1]: Stopping Upmpdcli UPnP/DLNA receiver...
[   18.438173] systemd[1]: Stopping Music Player Daemon...
[   18.438803] systemd[1]: Starting Music Player Daemon...
[   18.446673] systemd[1]: Started Music Player Daemon.
[   18.447280] systemd[1]: Starting Upmpdcli UPnP/DLNA receiver...
[   22.327459] systemd[1]: Starting Usb Automount (udevil)...
[   22.365416] systemd[1]: Started Usb Automount (udevil).
[   27.001716] systemd[1]: Starting The PHP FastCGI Process Manager...
[   27.658103] systemd[1]: Started The PHP FastCGI Process Manager.
[   28.873814] brcmfmac: power management disabled
[   30.699637] FS-Cache: Netfs 'cifs' registered for caching
[   30.703376] Key type cifs.spnego registered
[   30.703415] Key type cifs.idmap registered
[   35.600522] systemd[1]: Reloading.
[   41.851201] random: crng init done
[  173.931450] systemd[1]: rune_PL_wrk.service: main process exited, code=exited, status=255/n/a
[  173.937231] systemd[1]: Unit rune_PL_wrk.service entered failed state.
[  174.308783] pcm512x 1-004c: No SCLK, using BCLK: -2
[  175.084450] systemd[1]: rune_PL_wrk.service holdoff time over, scheduling restart.
[  175.090915] systemd[1]: Stopping RuneAudio Playback Worker...
[  175.091355] systemd[1]: Starting RuneAudio Playback Worker...
[  176.290343] systemd[1]: Failed to reset devices.list on /system.slice: Invalid argument
[  176.297649] systemd[1]: Started RuneAudio Playback Worker.
[  556.619634] systemd[1]: rune_PL_wrk.service: main process exited, code=exited, status=255/n/a
[  556.625494] systemd[1]: Unit rune_PL_wrk.service entered failed state.
[  557.767076] systemd[1]: rune_PL_wrk.service holdoff time over, scheduling restart.
[  557.772540] systemd[1]: Stopping RuneAudio Playback Worker...
[  557.772974] systemd[1]: Starting RuneAudio Playback Worker...
[  557.781519] systemd[1]: Started RuneAudio Playback Worker.
[  907.803569] systemd[1]: Starting Cleanup of Temporary Directories...
[  907.874271] systemd[1]: Started Cleanup of Temporary Directories.
[ 7348.612237] systemd[1]: Starting Rotate log files...
[ 7348.619902] systemd[1]: Starting Verify integrity of password and group files...
[ 7348.785718] systemd[1]: Started Rotate log files.
[ 7349.008809] systemd[1]: Started Verify integrity of password and group files.
[72133.455762] pcm512x 1-004c: No SCLK, using BCLK: -2
[72422.272496] systemd[1]: rune_PL_wrk.service: main process exited, code=exited, status=255/n/a
[72422.278611] systemd[1]: Unit rune_PL_wrk.service entered failed state.
[72423.415598] systemd[1]: rune_PL_wrk.service holdoff time over, scheduling restart.
[72423.425944] systemd[1]: Stopping RuneAudio Playback Worker...
[72423.430048] systemd[1]: Starting RuneAudio Playback Worker...
[72423.451462] systemd[1]: Started RuneAudio Playback Worker.
[72819.556980] systemd[1]: rune_PL_wrk.service: main process exited, code=exited, status=255/n/a
[72819.562964] systemd[1]: Unit rune_PL_wrk.service entered failed state.
[72820.670185] systemd[1]: rune_PL_wrk.service holdoff time over, scheduling restart.
[72820.676029] systemd[1]: Stopping RuneAudio Playback Worker...
[72820.676467] systemd[1]: Starting RuneAudio Playback Worker...
[72820.684584] systemd[1]: Started RuneAudio Playback Worker.
[73108.408354] systemd[1]: rune_PL_wrk.service: main process exited, code=exited, status=255/n/a
[73108.414242] systemd[1]: Unit rune_PL_wrk.service entered failed state.
[73109.423718] systemd[1]: rune_PL_wrk.service holdoff time over, scheduling restart.
[73109.432399] systemd[1]: Stopping RuneAudio Playback Worker...
[73109.432840] systemd[1]: Starting RuneAudio Playback Worker...
[73109.444416] systemd[1]: Started RuneAudio Playback Worker.
[73419.061797] systemd[1]: rune_PL_wrk.service: main process exited, code=exited, status=255/n/a
[73419.067846] systemd[1]: Unit rune_PL_wrk.service entered failed state.
[73420.177310] systemd[1]: rune_PL_wrk.service holdoff time over, scheduling restart.
[73420.183009] systemd[1]: Stopping RuneAudio Playback Worker...
[73420.183444] systemd[1]: Starting RuneAudio Playback Worker...
[73420.191780] systemd[1]: Started RuneAudio Playback Worker.
[73784.955897] systemd[1]: rune_PL_wrk.service: main process exited, code=exited, status=255/n/a
[73784.961759] systemd[1]: Unit rune_PL_wrk.service entered failed state.
[73786.181692] systemd[1]: rune_PL_wrk.service holdoff time over, scheduling restart.
[73786.187307] systemd[1]: Stopping RuneAudio Playback Worker...
[73786.187744] systemd[1]: Starting RuneAudio Playback Worker...
[73786.195762] systemd[1]: Started RuneAudio Playback Worker.
[74081.887103] systemd[1]: rune_PL_wrk.service: main process exited, code=exited, status=255/n/a
[74081.893576] systemd[1]: Unit rune_PL_wrk.service entered failed state.
[74082.935423] systemd[1]: rune_PL_wrk.service holdoff time over, scheduling restart.
[74082.942749] systemd[1]: Stopping RuneAudio Playback Worker...
[74082.943189] systemd[1]: Starting RuneAudio Playback Worker...
[74082.954280] systemd[1]: Started RuneAudio Playback Worker.
[74334.132221] systemd[1]: rune_PL_wrk.service: main process exited, code=exited, status=255/n/a
[74334.138118] systemd[1]: Unit rune_PL_wrk.service entered failed state.
[74335.188268] systemd[1]: rune_PL_wrk.service holdoff time over, scheduling restart.
[74335.193949] systemd[1]: Stopping RuneAudio Playback Worker...
[74335.194385] systemd[1]: Starting RuneAudio Playback Worker...
[74335.202505] systemd[1]: Started RuneAudio Playback Worker.
[74568.375662] systemd[1]: rune_PL_wrk.service: main process exited, code=exited, status=255/n/a
[74568.381638] systemd[1]: Unit rune_PL_wrk.service entered failed state.
[74569.441043] systemd[1]: rune_PL_wrk.service holdoff time over, scheduling restart.
[74569.446674] systemd[1]: Stopping RuneAudio Playback Worker...
[74569.447109] systemd[1]: Starting RuneAudio Playback Worker...
[74569.455235] systemd[1]: Started RuneAudio Playback Worker.
[74594.815839] systemd[1]: rune_PL_wrk.service: main process exited, code=exited, status=255/n/a
[74594.837265] systemd[1]: Unit rune_PL_wrk.service entered failed state.
[74595.058470] pcm512x 1-004c: No SCLK, using BCLK: -2
[74595.941553] systemd[1]: rune_PL_wrk.service holdoff time over, scheduling restart.
[74595.951839] systemd[1]: Stopping RuneAudio Playback Worker...
[74595.952279] systemd[1]: Starting RuneAudio Playback Worker...
[74595.993972] systemd[1]: Started RuneAudio Playback Worker.
[74935.921904] systemd[1]: rune_PL_wrk.service: main process exited, code=exited, status=255/n/a
[74935.927885] systemd[1]: Unit rune_PL_wrk.service entered failed state.
[74936.945619] systemd[1]: rune_PL_wrk.service holdoff time over, scheduling restart.
[74936.953591] systemd[1]: Stopping RuneAudio Playback Worker...
[74936.954028] systemd[1]: Starting RuneAudio Playback Worker...
[74936.985369] systemd[1]: Started RuneAudio Playback Worker.
[75240.136810] systemd[1]: rune_PL_wrk.service: main process exited, code=exited, status=255/n/a
[75240.142690] systemd[1]: Unit rune_PL_wrk.service entered failed state.
[75241.199056] systemd[1]: rune_PL_wrk.service holdoff time over, scheduling restart.
[75241.208459] systemd[1]: Stopping RuneAudio Playback Worker...
[75241.209703] systemd[1]: Starting RuneAudio Playback Worker...
[75241.231059] systemd[1]: Started RuneAudio Playback Worker.
[81463.208962] systemd[1]: rune_PL_wrk.service: main process exited, code=exited, status=255/n/a
[81463.216543] systemd[1]: Unit rune_PL_wrk.service entered failed state.
[81463.518370] pcm512x 1-004c: No SCLK, using BCLK: -2
[81464.238437] systemd[1]: rune_PL_wrk.service holdoff time over, scheduling restart.
[81464.244431] systemd[1]: Stopping RuneAudio Playback Worker...
[81464.244868] systemd[1]: Starting RuneAudio Playback Worker...
[81464.259003] systemd[1]: Started RuneAudio Playback Worker.
[81547.175308] systemd[1]: rune_PL_wrk.service: main process exited, code=exited, status=255/n/a
[81547.194242] systemd[1]: Unit rune_PL_wrk.service entered failed state.
[81547.740525] pcm512x 1-004c: No SCLK, using BCLK: -2
[81548.239396] systemd[1]: rune_PL_wrk.service holdoff time over, scheduling restart.
[81548.246598] systemd[1]: Stopping RuneAudio Playback Worker...
[81548.247036] systemd[1]: Starting RuneAudio Playback Worker...
[81548.258217] systemd[1]: Started RuneAudio Playback Worker.
[81566.906129] systemd[1]: rune_PL_wrk.service: main process exited, code=exited, status=255/n/a
[81566.938193] systemd[1]: Unit rune_PL_wrk.service entered failed state.
[81567.455784] pcm512x 1-004c: No SCLK, using BCLK: -2
[81567.989575] systemd[1]: rune_PL_wrk.service holdoff time over, scheduling restart.
[81568.009275] systemd[1]: Stopping RuneAudio Playback Worker...
[81568.009780] systemd[1]: Starting RuneAudio Playback Worker...
[81568.031689] systemd[1]: Started RuneAudio Playback Worker.
[81593.780020] pcm512x 1-004c: No SCLK, using BCLK: -2
[root@runeaudio-zero ~]#


About the dmesg errors you are getting, I found this advice here

Code: Select all
https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=138629


by garlicbready » Mon Mar 07, 2016 2:28 pm
First try the following

# Remove the Driver
modprobe -r brcmfmac
# Load in the Driver
modprobe brcmfmac
# Check Dmesg for any errors
dmesg
# List all network ports
ifconfig -a

If you see an error in the dmesg log like this, then your likley missing the needed firmware files
brcmfmac_sdio mmc1:0001:1: Direct firmware load for brcm/brcmfmac43430-sdio.bin failed with error -2

In that case go to
Code: Select all
https://github.com/RPi-Distro/firmware- ... 80211/brcm

and download the brcmfmac43430-sdio.bin and brcmfmac43430-sdio.txt files into the directory
/lib/firmware/brcm/ then try again


RawDevice
rawdevice
 
Posts: 15
Joined: 26 Sep 2014, 10:56

Re: Raspberry Pi Zero Support in 0.4

Postby rlsten » 11 Mar 2017, 15:03

Hi RawDevice,

I really appreciate your efforts to try to get my Pi Zero W Wifi going. I also get along by cobbling together things from those who know this stuff far better than me.

Your dmesg was very helpful--everything was pretty much identical with mine until it was time to load the brcm driver:
Yours was:
Code: Select all
[    6.242904] brcmfmac: Firmware version = wl0: May 27 2016 00:13:38 version 7.45.41.26 (r640327) FWID 01-df77e4a7


Mine was:
Code: Select all
brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43430-sdio.bin failed with error -2


I sure don't know what is going on.

But anyway, thanks again,
Rod
rlsten
 
Posts: 114
Joined: 25 May 2015, 18:06

Re: Raspberry Pi Zero Support in 0.4

Postby janui » 31 Mar 2017, 17:52

EDIT7: 05-02-2018 - A new image with Access Point functionality and some more problems solved, for change details see here: post24463.html#p24463
Special thanks to porcupiney and gearhead.
For details of the previous bugfix and functional updates see here: raspberry-pi-zero-support-in-0-4-t3711-100.html#p23880 and here: raspberry-pi-zero-support-in-0-4-t3711-80.html#p23506

Updated Rune arch6h Pi1 image for Pi Zero and legacy Pi models

Just to be clear, this image is not a 0.4 image, it is based on the older 0.3-beta Pi1 image. All functionality of the standard v0.3-beta (29/10/2014) image (for Pi models A/A+/B/B+) and v0.3-beta (23/03/2016) image (for Pi models 2B and 3B) is available, plus a few extras.
It should work on all single processor Pi models (A/A+/B/B+/Zero/Zero W). I do not have all of these models so cannot test everything. Other posts in the forum suggest that a real 0.4 version for the Pi Zero is being developed.

Various versions of this image have been tested using the Pi Zero, Pi Zero W (thanks rlsten) and Pi B+ in combination with generic Sabre ES9023 DAC, generic PMC5102 DAC, PiFi DAC+, HiFiBerry DAC+ Zero (thanks arakis), allo DigiOne (thanks thanhvo31), HiFiberry DAC+ Pro and HiFiberry DAC+, various types of USB Wi-Fi Dongles and for the Zero, wired-Ethernet using various USB-hubs and USB Fast Ethernet interfaces.

The image will fit on a 4Gb Micro-SD Card and the download version has been compressed with gzip.
You can download the image as gzip file from: http://www.mediafire.com/file/19kvxuife ... 9-1.img.gz
SHA256 of the gzip version is:
Code: Select all
03AC66E00FD29E3D4CAE4C3551CD44D2A2DED546F8C3462BC6221BCEB453A743
SHA256 of the unzipped image is:
Code: Select all
56AE95159C65D689958D3006F5143544E60D70FAA612181251F0D23B68D8E3F5
You will need to edit the config.txt file within the image to configure it. This can be done in Windows with notepad after writing the image to your Micro-SD card.

Features summary:
    - Upgraded the Arch Linux Kernel to 4.9.79-1, including support for more DAC/DIGI sound cards via overlays.
    - Upgraded MPD, including SoXr resampling support and working global random play.
    - Upgraded Samba file sharing, now works when accessed from Windows 10.
    - Upgraded Avahi, has better RuneUI connection reliability.
    - Improved Spotify reliability and speed.
    - Access Point functionality – works only for WiFi interfaces with Access Point support
    - Support for normally unsupported hardware (WiFi dongles, network cards, etc.) included.
    - Fix for KRACK WPA2 bug.
    - Python2, shairport-sync, shairport-sync-metadata-reader, alac, brutefir, snapcast server and client preinstalled.
    - Modifications to RuneOS and RuneUI.
    - See change details for detailed information...
Known issues:
    - There are Spotify issues, not specific for this image - see other posts on the forum.
    - Native DSD not supported.

You can also download my config.txt file, this set up for a Turbo Pi Zero (or B+) with a hifiberry dac+. You could copy this file directly to your Micro-SD card after you have written the image to it, but please check the contents first! Also read the overlay instructions for your DAC or DIGI module! The settings within the file are collected from several sources, no guarantees from me, I don’t have the hardware to test everything.
The file is here: http://www.mediafire.com/file/ry12ldc84 ... config.txt
SHA256 of the config.txt file is:
Code: Select all
4DC6D8C8316D80950E66E9767FBD26698914F88A6AD799FE1E566CD0A151129B


janui

EDIT7: 05-02-2018 - A new image with Access Point functionality and some more problems solved, for change details see here: post24463.html#p24463. Special thanks to porcupiney and gearhead.
EDIT6: 10-12-2017 - A new image, some irritating problems solved, mainly bug fixes, for change details see here: post23880.html#p23880
EDIT5: 10-11-2017 - A new image, for change details see here: post23506.html#p23506. Thanks to huckepucke, rern, Tall Person, andfor, waves and hondagx35.
EDIT4: 03-07-2017 - This post has been modified to include a new image. The image has been modified to support additional WiFi adaptor chip sets (for details see post: wifi-driver-update-for-unsupported-chip-sets-t4814.html#p21549, thanks to anandfr), linux-firmware (version 20170422) and 8812au.ko.gz (as of 3 july 2017) are installed.
EDIT3: 09-06-2017 - This post has been modified to include a new image and the text has been revised. The new image has been modified to disable Spotify logging. This will not solve the Spotify problems, but should allow Rune to continue working (see post: raspberry-pi-zero-support-in-0-4-t3711-80.html#p21250, thanks to hondagx35 and theskyentist).
EDIT2: 05-05-2017 - This post has been modified to include a new image. The new image has been modified to correct the player name and correctly start Samba (see post raspberry-pi-zero-support-in-0-4-t3711-70.html#p20849, thanks to delboy711). The image size has also been reduced to fit on a 2Gb SD card.
EDIT1: 02-04-2017 - This post has been modified to include a new image. The new image has the a couple of extra files included to enable the Zero W WiFi to work without modifications (see post raspberry-pi-zero-support-in-0-4-t3711-70.html#p20581, thanks to rlsten).
EDIT0: 29-03-2017 - Original post. After following several Raspberry Pi Zero threads on the forum many issues seem to be related to the ArchLinux kernel, so I decided to try to create a new image. The basis is the hpeter image available via previously published links in this thread (thanks to hpeter), see here: raspberry-pi-zero-support-in-0-4-t3711-10.html?hilit=hpeter#p15968. I upgraded the hpeter image to ArchLinux to 4.9.17-1 using the instructions in this thread: justboom-zero-dac-not-detected-t4320.html (thanks to gearhead). The image has also been updated to the latest build from the RuneAudio dev branch. The “pacman -S crda” issue in the hpeter image has disappeared.

Contact me if you need one of these older versions.
Last edited by janui on 28 Feb 2018, 02:37, edited 22 times in total.
User avatar
janui
 
Posts: 682
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: Raspberry Pi Zero Support in 0.4

Postby rlsten » 31 Mar 2017, 22:37

I do not have a PI Zero W so the image is not tested on this platform, you never know maybe the onboard Wi-Fi issues will disappear.


Janui,

I tried your new image on a PiZeroW and I got the onboard WiFi to work!

The onboard wifi appeared to work out of the box, but even though I had an IP address, I couldn't find the PiZeroW on my network. So, I followed RawDevice's advice from http://www.runeaudio.com/forum/raspberry-pi-zero-support-in-0-4-t3711-60.html#p20197:

Finally you'll need to grab (not sure if this step is 100% required yet) the firmware files from: https://github.com/RPi-Distro/firmware- ... 80211/brcm.

Specifically you need brcmfmac43143-sdio.bin and brcmfmac43430-sdio.txt which must go into the /lib/firmware/brcm/ folder."


and everything worked.

Great job!
rlsten
 
Posts: 114
Joined: 25 May 2015, 18:06

Re: Raspberry Pi Zero Support in 0.4

Postby delboy711 » 25 Apr 2017, 13:08

Thanks for the image janui. It worked fine with my Rasp pi Zero.

Two observations
1/ The hostname is rundeaudio not runeaudio which could cause a bit of confusion.

2/ Samba is not enabled out of the box, and then when enabled it does not start up properly on boot.
To fix it I did
Code: Select all
nano /etc/systemd/system/smbd.service

with the text
Code: Select all
[Unit]
Description=Samba SMB/CIFS server
After=network.target nmbd.service winbindd.service

[Service]
Type=forking
PIDFile=/var/run/smbd.pid
ExecStart=/usr/bin/smbd -D
ExecReload=/bin/kill -HUP $MAINPID

[Install]
WantedBy=multi-user.target


Then
Code: Select all
systemctl daemon-reload
systemctl enable smbd
systemctl start smbd


Thanks for taking the trouble to produce the image.
delboy711
 
Posts: 7
Joined: 04 Aug 2015, 20:36

Re: Raspberry Pi Zero Support in 0.4

Postby janui » 05 May 2017, 20:40

Thanks for the feedback delboy711,

The typo in the player name could have been worse by missing out the "n" :D
I have followed your instructions and published a new image, info here: raspberry-pi-zero-support-in-0-4-t3711-70.html#p20577

All additional feedback welcome,
Janui
User avatar
janui
 
Posts: 682
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: Raspberry Pi Zero Support in 0.4

Postby arakis » 13 May 2017, 17:19

Im using this image with a Pi Zero W and HiFiBerry DAC+ Zero.
To get the DAC+ Zero working I had to use the profile of the DAC
Code: Select all
dtoverlay=hifiberry-dac

Be aware the DAC+Z has volume control only via software!
PI Zero W & HiFiBerry DAC+ Zero
User avatar
arakis
 
Posts: 5
Joined: 11 May 2017, 23:51
Location: Germany

Re: Raspberry Pi Zero Support in 0.4

Postby theskyentist » 28 May 2017, 00:13

I am having some difficulties setting this up, so hopefully someone more experienced can help me.

I am using the image posted here on a pi zero v1.3 (not w, so with a wifi module), and when tested without changing the initial config text, literally taking the written SD card from computer to pi, I was able to stream spotify both with ethernet and wifi. The RuneUI would then become inaccessible after about 10-15 mins, although I could still SSH from my laptop. When updated with the given config text for turbo I could access the UI, but could not play any music, and again I could not access the UI after about 10 mins. As well, I could not SSH.

Any advice for troubleshooting would be greatly appreciated.

I am using a Trond model AC2 usb audio adapter, no display, realtek wireless module if that helps.
theskyentist
 
Posts: 2
Joined: 28 May 2017, 00:00

support RuneAudio Donate with PayPal

PreviousNext

Return to Raspberry Pi

Who is online

Users browsing this forum: cmh714 and 7 guests