Raspberry Pi Zero Support in 0.4

Raspberry Pi related support

Re: Raspberry Pi Zero Support in 0.4

Postby tej » 01 Jan 2017, 00:28

Hi
I recently purchased a Pi Zero 1.3 plus a Just Boom -Amp zero.
My aim is to use them in a wireless speaker system
I have used Rune audio in the past and the Amp Zero came with a Rune flyer in the box.

I have checked your downloads and cannot find a download for the Pi Zero ?
Is this version 0.4 the answer ?
Can I use an alternative Pi model download ?

I am a Pi beginner, apologies :!:
tej
 
Posts: 1
Joined: 01 Jan 2017, 00:17

Re: Raspberry Pi Zero Support in 0.4

Postby rlsten » 04 Feb 2017, 01:17

I am running the hpeter image on a PiZero 1.3.

I wanted to set up a plause/play button, so I installed python2. When I tried the script that worked successfully on the Raspberry Pi 3:

Code: Select all
#!/usr/bin/env python2
import RPi.GPIO as GPIO
import subprocess
GPIO.setmode(GPIO.BOARD)

#Select an unused GPIO header pin as input
InputPin = 11

# Set pin to input, and enable internal pull-up
GPIO.setup(InputPin, GPIO.IN, pull_up_down=GPIO.PUD_UP)

# Wait for a button press on the selected pin (pin pulled to ground, falling edge)
GPIO.wait_for_edge(InputPin, GPIO.FALLING)

# When pressed, execute the mpc toggle command:
print "*** Button press detected ***" # (print statement added for debugging)
subprocess.call("mpc toggle", shell=True, stdout=subprocess.PIPE, stderr=subprocess.PIPE)


I got a message that the RPi.GPIO module was not found.

I know that the PiZero has the same GPIO numbers as the Pi3, but I believe the image I am using is based on the Raspberry Pi 1, which has different GPIO numbers.

Do I need to alter the code, or do I need to install the RPi.GPIO module? If so, how?

Thanks,
Rod
rlsten
 
Posts: 116
Joined: 25 May 2015, 18:06

Re: Raspberry Pi Zero Support in 0.4

Postby janui » 20 Feb 2017, 14:23

sportsnapper wrote:It all appears to work, except airplay. I can see runeaudio in my airplay menus on phone/ipad, but I get no audio from the speaker. I can play a radio stream, and music from an OSX share.


Got Airplay working...
I followed the steps in this thread to get my zero working, including extra config.txt items (to speed up the zero to 1Ghz, and max usb current). Then I carried out several attempts to solve the AirPlay problem over the last couple of weeks, all trial and error (I know very little about the commands I am using). Below I have attempted to summarise the steps, forgive me if I have forgotten something. All the information below is published in various other posts in the forum.

Upgrade to the latest build:
Code: Select all
cd /var/www
rm command/mpd-watchdog
git config user.email "you @ example . com"
git config user.name "root"
git stash
git pull
systemctl reboot


If the rm command/mpd-watchdog gives a error no-problem, just continue.
I had problems with git stash, if it fails follow the instructions. Set a user-email (I used my own) and set user-name to root.
I needed to repeat the last three steps (last step forces a reboot) a couple of times before git pull gave no errors.
Set AirPlay name to "RuneAudio" in the settings via the menu.
For some reason an extra reboot is required before everything works.

I do not know what exactly fixes the AirPlay problem.

There seems to be still one issue. The only AirPlay name that will work is "RuneAudio", set it to this value! If you set it to anything else AirPlay connects and seems to play, but without sound.

The pacman -S crda command still gives the same error.

I have tested this on:
1. Pi zero using HiFiBerry DAC drivers with a cheapo Sabre ES9023 DAC card,
2. Pi zero using HiFiBerry DAC drivers with a cheapo PMC5102 DAC card,
3. Pi B+ using HiFiBerry DACplus drivers with a HiFiberry DACplus card.
User avatar
janui
 
Posts: 682
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: Raspberry Pi Zero Support in 0.4

Postby rlsten » 09 Mar 2017, 01:52

I just got a new Raspberry Pi Zero W, but when I tried the hpeter image, it wouldn't boot at all. No green light, nothing on the HDMI display. The Pi Zero W works with the standard Raspbian images, and the hpeter image works fine for me with the plain Pi Zero.

Does anyone have any idea what could be wrong?

Thanks,
Rod
rlsten
 
Posts: 116
Joined: 25 May 2015, 18:06

Re: Raspberry Pi Zero Support in 0.4

Postby hondagx35 » 09 Mar 2017, 12:06

Hi Rod,

the kernel and firmware has to be updated for the new Zero W.

Frank
User avatar
hondagx35
 
Posts: 3041
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: Raspberry Pi Zero Support in 0.4

Postby rawdevice » 09 Mar 2017, 12:16

Hi all,

I was able to get the Pi Zero W working with RuneAudio thanks to the instructions in this thread. In order to get the on-board Wi-Fi to work, I had to update the kernel and firmware as stated by Frank. I found the following info on the Pimoroni forum and confirm it works:

"You'll need a set up Pi or Linux computer to perform surgery from, and then you'll need to:

Code: Select all
git clone --depth=1 https://github.com/raspberrypi/firmware


This local copy should have a boot folder and a modules folder in it. You want to replace your /boot with the contents of this newly downloaded boot folder and you will also need to copy over the two folders from modules into /lib/modules on the root filesystem.

Finally you'll need to grab (not sure if this step is 100% required yet) the firmware files from: https://github.com/RPi-Distro/firmware- ... 0211/brcm1

Specifically you need brcmfmac43143-sdio.bin and brcmfmac43430-sdio.txt which must go into the /lib/firmware/brcm/ folder."

RawDevice
rawdevice
 
Posts: 15
Joined: 26 Sep 2014, 10:56

Re: Raspberry Pi Zero Support in 0.4

Postby rlsten » 09 Mar 2017, 13:50

Thanks Frank and RawDevice! I will try the update and see what happens :shock:
rlsten
 
Posts: 116
Joined: 25 May 2015, 18:06

Raspberry Pi Zero Support in 0.4

Postby McAllister » 09 Mar 2017, 21:51

Hi all,

i have tried to set up a raspberry zero with rune audio and the "JustBoom Digi Zero pHAT". I found some very helpful hints in this thread an will now make a little summary of my way to partially success.

1. I downloaded the image of hpeter (many Thanks!) from >this post< and put it on a 64 GB micro SD card.

2. I have no raspy 1, so i used a "USB to microUSB OTG Converter Shim" to get keyboard on the zero and a HDMI to Mini-HDMI Adapter to get something on the monitor.

3. I editet the etc/boot/config.txt and added:
Code: Select all
arm_freq=1000
gpu_freq=300
core_freq=400
over_voltage=6
force_turbo=1


and
Code: Select all
dtparam=audio=on

>like here<


4. Then i edited /etc/netctl/test like this:
Code: Select all
 Description='wlan0 connection'
    Interface=wlan0
    Connection=wireless
    Security=wpa-configsection
    IP=dhcp
    WPAConfigSection=(
        'ssid="YOUR-SSID"'
        'psk="YOUR-PASSPHRASE"'
        'key_mgmt=WPA-PSK'
        'proto=WPA'
        'group=TKIP'
        'pairwise=TKIP'
        'priority=3'
    )

>like here<


5. Then reboot the system, but now with Micro USB WiFi Dongle (like >This one<).
The dongle blinked blue and then the raspberry appeared on my router.

6. Now i have access with putty. And i can see and use the runeaudio-UI with http://runeaudio/.
I have succesfully set up access to my NAS. So far, so good.
And again, many thanks for the advices in this thread!

7. Now i just will use the digital audio output of the JustBoom Digi pHAT, but my receiver (Yamaha RX-V371) remains silent.
If is use the HDMI-output of the Raspy and an HDMI-Input of die Receiver it worked, but that is no permanent solution.
What do i need to do to get the digital audio-outpoot work?
On the >Justboom Software Guides Page < i found a "coming soon" for runeaudio. :(
And on the RuneAudio MPD Configuration-Site i just see the following 2 options for "Audio output interface":
* RaspberryPi HDMI out
* RaspberryPi Analog out

I tested both, but nothing worked.

Can someone help? Maybe >my debug info< helps?
And maybe i should open another thread for this specific question?

Edit: now i found the Troubleshooting-Page http://www.runeaudio.com/documentation/troubleshooting/rpi-troubleshooting/ with topic enabling digital output boards. I'll read it tomorrow.
McAllister
 
Posts: 2
Joined: 09 Mar 2017, 20:53
Location: Germany

Re: Raspberry Pi Zero Support in 0.4

Postby rlsten » 10 Mar 2017, 02:01

I tried RawDevice's instructions on the Pi Zero W with mixed results. I wasn't sure about a couple of things, but this is what I did:

1. Starting with Hpeter's image for the pizero, I deleted everything in the boot partition and copied the new stuff from the boot folder of the firmware download. The link https://github.com/RPi-Distro/firmware-nonfree/tree/master/brcm80211/brcm1 gave me a 404 error, but I was able to find the drivers at https://github.com/RPi-Distro/firmware-nonfree/tree/master/brcm80211/brcm.

When I tried to boot, it said that "no filesystem could mount root" and froze.

2. So, I made a fresh hpeter image, and this time copied the new stuff to the boot partition, overwriting the old stuff. This time, it booted to the rune login. However, ifconfig showed no wlan0 entry. Systemctl --type=service showed no wireless service; when I tried to enable it with systemctl restart netctl-auto@wlan0.service, it said something about a dependency was missing and to check journalctl -xn. When I tried to do that, it said there were no journal entries. I also had an entry from systemctl --type=service that "systemd-modules-load.service" had failed.

3. However, when I inserted a WiFi dongle to my USB Hub, that worked perfectly. But there still was no indication in ifconfig or otherwise that the internal WiFi module was recognized. I also had the entry from systemctl --type=service that "systemd-modules-load.service" had failed, but the wlan0.service was active and running.

Does anyone know what I am doing wrong? RawDevice, did you start with hpeter's image, or something else?

Thanks,
Rod
rlsten
 
Posts: 116
Joined: 25 May 2015, 18:06

Re: Raspberry Pi Zero Support in 0.4

Postby rawdevice » 10 Mar 2017, 09:14

Hi Rod,

No, I did not use hpeter's image as I had read in this thread that it was too big to fit on an 8GB Micro SD card. I started from scratch. However, like hpeter I started the process using a Raspberry Pi 1 (Pi B+). Here are the steps I took:

1. Download v0.3-beta (29/10/2014) for RASPBERRY PI (MODEL A/A+/B/B+)
Code: Select all
http://sourceforge.net/projects/runeaudio/files/Images/Raspberry%20Pi/RuneAudio_rpi_0.3-beta_20141029_2GB.img.gz/download


2. Uncompress and write to micro SD card using Win32DiskImager

3. Boot on Raspberry Pi B+ (with ethernet cable connected)

4. Update the kernel
Code: Select all
pacman -Sy --force raspberrypi-firmware-bootloader linux-raspberrypi
sync


5. Before shutting down and rebooting do the following steps:

a. During the update two new files are created cmdline.txt and kernel.img. These files are now the ones to boot from.

b. Because the file config.txt already exists pacman creates a new file called config.txt.pacnew, which is a good thing. The old version is the one too choose. Unfortnately after the update config.txt still points to the old files:

Code: Select all
# RuneAudio settings
   cmdline=cmdline_linux-arch-rpi_3.12.26-1-ARCH.txt
   kernel=linux-arch-rpi_3.12.26-1-ARCH.img

This has to be changed to:

Code: Select all
# RuneAudio settings
   cmdline=cmdline.txt
   kernel=kernel.img


c. The file cmdline.txt points to a wrong partition so

Code: Select all
root=/dev/mmcblk0p2


has to be changed to

Code: Select all
root=/dev/mmcblk0p5


before we can boot up.

6. Reboot the Raspberry Pi B+ (with ethernet cable and USB Wi-Fi adapter)

7. Add the Wi-Fi profile (/etc/netctl/profile_name). I actually did this from the GUI (Menu -> Network)

Code: Select all
Interface=wlan0
Connection=wireless
Security=wpa-configsection
AutoWired=yes
ExcludeAuto=no
IP=static
Address=('192.168.1.14/24')
Gateway='192.168.1.1'
DNS=('8.8.8.8' '8.8.4.4')
WPAConfigSection=(
    'ssid="XXX"'
    'psk="xxxxxxxxxx"'
    'key_mgmt=WPA-PSK'
    'proto=RSN'
    'group=CCMP'
    'pairwise=CCMP'
    'priority=3'
)


8. Reboot the Raspberry Pi B+ with the ethernet cable removed and a USB Wi-Fi adapter plugged in. Check that the Wi-Fi connection is working.

9. At this point you can boot the prepared micro SD card in the Raspberry Pi Zero W but the onboard Wi-Fi adapter will not work. If you plug in the USB Wi-Fi adapter you used in the Raspberry Pi B+, then the Raspberry Pi Zero W will be able to connect to the network. In order to get the onboard Wi-Fi working, I followed these steps from gadgetoid's post in the Pimoroni forum: http://forums.pimoroni.com/t/pi-zero-w- ... orted/4099

"Volumio is configured quite differently from Raspbian, and you shouldn't attempt to make any changes directly to it via SSH. Everything will crash and burn. We deliberately block our installers from running on any untested OS for this reason- they'll only get you into trouble!

That said, I've been working with the Volumio team to get our boards supported, but we're limited by their release cycle and the constraints of the OS.

For the time being you can get sound running just by configuring it through the Volumio UI as having a hifiberry DAC. Our own board definitions for Volumio are just clones of this config option, anyway.

Wifi

This is a little trickier, and we've no idea when Volumio- or any other distribution for that matter- will release a compatible version. Right now they will have been caught off guard.

You can get the Zero W WiFi running manually, but it's not a task for the faint of heart. That said, if it's a fresh image it doesn't matter if you make a hash of it- you can just try, try again!

I haven't tested this on Volumio yet, but it worked on ResinOS.

You'll need a set up Pi or Linux computer to perform surgery from, and then you'll need to:

git clone --depth=1 https://github.com/raspberrypi/firmware

This local copy should have a boot folder and a modules folder in it. You want to replace your Volumio /boot with the contents of this newly downloaded boot folder and you will also need to copy over the two folders from modules into /lib/modules on Volumio's root filesystem.

Finally you'll need to grab (not sure if this step is 100% required yet) the firmware files from: https://github.com/RPi-Distro/firmware- ... 0211/brcm1

Specifically you need brcmfmac43143-sdio.bin and brcmfmac43430-sdio.txt which must go into the /lib/firmware/brcm/ folder.


10. Update RuneAudio to Nightly Build
Code: Select all
http://www.runeaudio.com/documentation/troubleshooting/updating/


11. Add the following to the /boot/config.txt file to set the CPU to 1000 Mhz (otherwise it will run at 700 Mhz)

Code: Select all
arm_freq=1000
gpu_freq=300
core_freq=400
over_voltage=0
force_turbo=1
Last edited by rawdevice on 11 Mar 2017, 13:46, edited 1 time in total.
rawdevice
 
Posts: 15
Joined: 26 Sep 2014, 10:56

support RuneAudio Donate with PayPal

PreviousNext

Return to Raspberry Pi

Who is online

Users browsing this forum: cmh714 and 2 guests