Wireless on Rune

Raspberry Pi related support

Re: Wireless on Rune

Postby skrodahl » 19 Feb 2014, 11:51

vcelkamaja wrote:Well, it seems I made some progress :P


Long story, short question: What should I do to have Wifi available also after power off of Pi without a need for ethernet connection and configuring wifi after each power on?

Orion and the rest of the guys coding RuneAudio have come very far in a short amount of time. Although you could use wifi-menu and then 'netctl enable <wifi-menu profile>', the rest of the code doesn't seem to support wifi only at the moment. Doing that right now will not let you mount your network shares, so an ethernet cable is needed when booting up either way. Failure to do so will delete your entire MPD database.

Please keep in mind that this is a beta, and a fantastic one at that. Keep up the testing, and report any issues. Seeing what the team has accomplished so far gives me great faith, both in terms of audio quality and upcoming features.

Muffsy Phono Preamp PP-3 || Audiobah TPA3116 || ESP P88 || ProJect Debut Carbon Espirit DC || RuneAudio / RaspBerry Pi / HifiBerry DAC || Dynaco A25
User avatar
Posts: 160
Joined: 27 Jan 2014, 10:08
Location: Sweden

Re: Wireless on Rune

Postby vcelkamaja » 19 Feb 2014, 13:26

Hi skrodahl,

thanks for your comment and I fully agree that Rune is a great piece of SW even if it is in beta now.

Anyway I was thinking that if I'm able to setup wifi manually after power on with following commands:
wicd start
wicd curses
and them select wifi from the list, configure it and activate, connect to NAS over Wifi (through configuration in Rune UI running as a web page on iPad) it it should be also possible to do it somehow automatically after power on (a part of start up sequence or tasks?)

But as I mentioned before I'm a completely new in Linux so I'm not sure what is possible and what is not.
Posts: 7
Joined: 17 Feb 2014, 22:08

Re: Wireless on Rune

Postby Dave91 » 19 Feb 2014, 20:59


I have problems to install the driver for my usb wlan device (tp-wn725n).
I found some inforamtions to install it, but if I try:
"sudo insmod /lib/modules/3.6.11+/kernel/drivers/net/wireless/8188eu.ko"
I get an errormessage:
"Error: could not insert module /lib/modules/3.6.11+/kernel/drivers/net/wireless/8188eu.ko: Invalid module format"

could somebody help me?
Posts: 1
Joined: 19 Feb 2014, 20:51

Re: Wireless on Rune

Postby vcelkamaja » 19 Feb 2014, 23:46

Hi skrodahl,

quick update - I have finally managed to start Wifi after power on wihtout ethernet cable plugged-in. I can even connect to RuneUI using iPad.
But as you have mentioned, skrodahl, ¨the NAS that was originally mounted (while connected via ethernet) is no longer available and I can't mount it again as well while connected just via Wifi.

So a conclusion for now is it is only possible to use RuneUI via Wifi with initial setup via ethernet. When power off appears it is always necessary connect via ethernet first to be able to mount / use NAS.

Anyway RuneUI is still great SW and it would be an extremely nice feature to have a Wifi support in it.
Posts: 7
Joined: 17 Feb 2014, 22:08

Re: Wireless on Rune

Postby loopymonkey » 20 Feb 2014, 22:43

did you try this after successfully getting your wifi working:

Code: Select all
systemctl start wicd.service
Posts: 3
Joined: 18 Feb 2014, 03:36

Re: Wireless on Rune

Postby vcelkamaja » 22 Feb 2014, 13:52

I have tried it but it didn't work. What probably helped was:

sysctl enable wicd.service

As I mentioned above I can see Wifi after restart of Rune/RPi but I can mount NAS using just Wifi connection.
Posts: 7
Joined: 17 Feb 2014, 22:08

Re: Wireless on Rune

Postby jkelly30 » 25 Feb 2014, 17:06

Hi All,

Has anyone else suffered any issues with trying to get wifi operation? I have tried several attempts at bringing in wifi using wicd, wifi-menu, etc. etc. but still cant get it to operate only over wifi.. (I have tried to follow the arch-linux guide but to no avail). The closest I came was seeing both IP addresses of the on-board eth0 and wlan0 on my router attached devices page, however they shared the same MAC address confusingly.. My guess is that it was somehow bridging to the wlan0 through the ethernet port, because as soon as it is unplugged no devices show as attached...

For reference my wifi adapter is the Edimax 7811(?) USB adapter..

My next step is to try with a self powered USB hub in case it is a power issue...

Any pointers would be appreciated..

Edit: Sorry, should have noted that I have a Model B RaspPi, I also updated all packages using #Pacman -Syu
Posts: 5
Joined: 25 Feb 2014, 16:50

Re: Wireless on Rune

Postby jkelly30 » 06 Mar 2014, 23:42

Hello Again...

well what a saga it has been to get my little pi working with it's wifi dongle... but.. at last I now have it picking up a reserved IP address from my router by enabling netctl-auto@wlan0.service with systemctl (enabling the profile setup with wifi-menu).

However I think I still have 2x issues that I just can't seem to mine the appropriate sollutions for... so I am looking for some advice ;)

Firstly, I think the wifi dongle is going into power saving mode (blue LED slowly blinking on the dongle, occasionally flickering as if traffic is present), I have seen in various forum posts on the web (http://www.raspberrypi.org/forum/viewto ... 28&t=61665) that you can create a file in the /etc/modprobe.d/ directory to disable power management features, however if I use the mentioned command I get an error telling me that the directory doesn't exist.. so where should I create the .conf file in order to use the below instruction?? (and what is the best way to create a file)?
# Disable power management
options 8192cu rtw_power_mgnt=0 rtw_enusbss=0

Secondly, I think I have the ifplugd issue where the eth0 connection takes priority over the wlan0 link, I think I disabled ifplugd correctly but would like to remove it from the system, how do I achieve this in Archlinux? The reason I believe this to be the issue is that the attached devices page in my router management interface shows the IP addresses for both inet interfaces but under the same MAC address, when the e-net cable is removed the correct mac address shows on the router management page... Am I on the right track here or has anyone else had a similar experience with a better sollution?

Thanks in advance

edit: hmm this is so frustrating... so when I see the wireless adapter in my router management page with the correct MAC address it seems I still cant ping the IP from my laptop... I am now officially confused!!
Posts: 5
Joined: 25 Feb 2014, 16:50

Re: Wireless on Rune

Postby Midnight » 07 Mar 2014, 13:21

vcelkamaja wrote:1. Is it good to use WEP or would it be better / more stable / more secure to use WPA? And if WPA which type?

Don't use WEP, it's not secure! Use WPA2 instead.
User avatar
Posts: 141
Joined: 19 Feb 2014, 14:46

Re: Wireless on Rune

Postby mrrnb » 12 Mar 2014, 06:25

This is a very helpful thread.

I have been struggling with this for a couple days now and have found a somewhat suitable, albeit quirky workaround. I have a stack of derelict routers in storage. On one I disabled wireless and set it up as a different subnet from my LAN, plugged the RPi into that while setting my wireless dongle to a static IP below my regular router's DHCP threshold and it seems to be working, both audio and NAS.

At least I can tuck the rogue router away and not have to trip over the cables.
Posts: 2
Joined: 12 Mar 2014, 06:15

support RuneAudio Donate with PayPal


Return to Raspberry Pi

Who is online

Users browsing this forum: cmh714 and 3 guests