Trouble with Mamboberry Dac and Kali Reclocker

Raspberry Pi related support

Trouble with Mamboberry Dac and Kali Reclocker

Postby rich110 » 18 Aug 2019, 07:53

Hi,
After moving away from Runeaudio several years ago to use Volumio and later Moode, I have returned to Rune because of it's active support, ease and speed of use and simple interface.

Since I last used Rune I've upgraded my setup to include a Rpi3B, Kali Reclocker and Mamboberry LS DAC+.

I have Runeaudio loaded and configured (extended partition, updated MPD via addons plugin, etc) but I can't seem to get any audio to output. I am wondering if it has something to do with my audio settings.

From reading the forums, I believe that the Mamboberry LS DAC+ is supported via the 'Hifiberry DAC' selection under Rune 'Settings' tab. I have done this and then selected 'Hifiberry DAC (I2C)' under the MPD 'Audio output interface' - but I get no sound when playing tracks.

Are these DAC settings still correct for Rune 0.5?

I am running the following version:
Ver. 0.5 build janui-20180903-10
Linux version 4.14.34-1-ARCH (alarm@alarmpi) (gcc version 7.3.1 20180312 (GCC)) #1


A copy of my debug after a clean reboot and trying to play a flac file is https://pastebin.com/Dg3eadG2.

Any help would be appreciated.

cheers,
Rich
rich110
 
Posts: 3
Joined: 18 Aug 2019, 07:35

Re: Trouble with Mamboberry Dac and Kali Reclocker

Postby janui » 18 Aug 2019, 09:48

Hi rich110,
rich110 wrote:...but I can't seem to get any audio to output...
You could try the 'Allo Boss DAC in slave mode' setting for 'I²S kernel modules' in the Settings UI.
However, there could be a more fundamental problem. Kali expects a slave mode DAC, this is the situation where Kali supplies the clock signal to the DAC. Any DAC with an on-board oscillator (like the Mamboberry LS DAC+) would need to be able switch off using its own oscillator and use the clock signal provided by Kali. The Mamboberry LS DAC+ does not seem capable of switching off the on-board oscillator used for its ES9023 DAC chip.
So, even if Kali works with the a DAC using the ES9023 chip, I suspect that the benefit which Kali provides will be removed by the ES9023 using its on-board clock and its built-in reclocking processing.
All of the Allo product which support their Kali Reclocker are based on Texas Instruments DAC chips in the pcm51xx series (specifically the pcm5122 and pcm5142 chips).
Maybe other forum members have some suggestions for Kali compatible DAC’s.
janui
User avatar
janui
 
Posts: 682
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: Trouble with Mamboberry Dac and Kali Reclocker

Postby rich110 » 18 Aug 2019, 10:52

Hi janui,
Thanks for the reply....
If what you say is true, then I'm a little disappointed (with myself)....
I bought the combination of Kali Reclocker and Mamboberry LS DAC based on several articles I'd read saying they worked well together. See the links here:
https://collybia.com/soundcheck-hamburg ... guess-won/ (half-way down the page)
https://volumio.org/allo-kali-i2s-reclo ... mechanger/ (again, about half-way down the page)

I'm pretty disappointed to find out the the combined benefit of the Reclocker and the DAC are in actual fact not able to be utilised in this combination.
Either way, I'll try your suggestion of the "Allo DAC" setting and see how it goes.

Cheers,
Rich
rich110
 
Posts: 3
Joined: 18 Aug 2019, 07:35

Re: Trouble with Mamboberry Dac and Kali Reclocker

Postby janui » 18 Aug 2019, 21:08

Hi rich110,
rich110 wrote:...several articles I'd read saying they worked well together...
I have looked at the articles, then I did a little more searching on the net. I found several other references of the products working together, on the KODI LibreELEC Forum they suggested using the 'HiFiBerry DAC Plus' setting.
janui
User avatar
janui
 
Posts: 682
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: Trouble with Mamboberry Dac and Kali Reclocker

Postby rich110 » 19 Aug 2019, 11:10

Hi janui,
Thanks again...

Unfortunately, "Hifiberry Dac Plus" setting doesn't work. If I use this setting then I get no option in the MPD Config > Audio Input Interface except 'RPi Analogue Out' and 'RPi HDMI Out' - no matter how many times I reboot the system.

If I choose the plain "Hifiberry DAC" option, I get the "Hifiberry DAC I2S" option in the MPD Config > Audio Input Interface section but no sound.
I think I may need to return to moOde Audio.
Cheers,
Rich
rich110
 
Posts: 3
Joined: 18 Aug 2019, 07:35

Re: Trouble with Mamboberry Dac and Kali Reclocker

Postby janui » 19 Aug 2019, 14:12

Hi rich110,
rich110 wrote:...I think I may need to return to moOde Audio...
Sorry I cant help more, I don’t have a Kali so cant debug in detail.
If you do get it working on another player could please send me the file: /boot/config.txt
Thanks in advance.
janui
User avatar
janui
 
Posts: 682
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: Trouble with Mamboberry Dac and Kali Reclocker

Postby lynx » 14 Mar 2020, 16:44

Hi I am trying the same setup with similar results, were you able to find a solution?
lynx
 
Posts: 1
Joined: 14 Mar 2020, 16:41

support RuneAudio Donate with PayPal


Return to Raspberry Pi

Who is online

Users browsing this forum: cmh714 and 17 guests