Stutter and jittering with airplay and hifiberry

Raspberry Pi related support

Stutter and jittering with airplay and hifiberry

Postby Rups » 29 Dec 2019, 17:49

Hi, I wonder if anyone can help with this problem, I’d be very grateful. I’ve got a Raspberry Pi 3 with hifiberry and am trying to play music to it from an iPhone (XS Max). But the quality is terrible as it keeps stuttering (almost like suddenly becoming slightly louder or catching up itself). It’s subtle but very noticeable.

I’ve just upgraded to the latest download version of RuneAudio today and I play through a hifiberry. The problem is present whether I use SPDIF or Toslink outputs and regardless of which App/source I airplay from.

I can airplay to an Apple TV plugged into my DAC via Toslink without any issues.

Any suggestions very welcome, even if it’s a pointer to a previous post or discussion (I did search but didn’t find anything)

Thanks
Rups
 
Posts: 2
Joined: 15 Jun 2016, 21:16

Re: Stutter and jittering with airplay and hifiberry

Postby eea123 » 31 Dec 2019, 14:21

I don't use AirPlay so this is a shot in the dark, but from what I am reading it sounds like your iPhone can either connect to a device via WiFi directly or stream to it over the WiFi network. How is your Raspberry PI attached to the network, hardwire ethernet or WiFi? Can you direct connect the PI to the network via ethernet and just AirPlay to the WiFi? I wonder it there is just too much WiFi traffic and if pulling the PI over to a hardwired connection would help?

https://en.wikipedia.org/wiki/AirPlay
eea123
 
Posts: 94
Joined: 23 Dec 2017, 19:19

support RuneAudio Donate with PayPal


Return to Raspberry Pi

Who is online

Users browsing this forum: cmh714 and 3 guests