Sound for only a few seconds when DAC turned on

Raspberry Pi related support

Sound for only a few seconds when DAC turned on

Postby martinb0820 » 08 Mar 2020, 20:45

3/12: Still doesn't work. I verified the following:

- The DAC works fine when driven by a laptop PC
- Using a powered USB hub between the PI and the DAC didn't help

An additional problem is random dropouts. WRT this:

- WiFi signal being picked up by the RPI is strong on both 2.4 and 5GHz. I'm not seeing any errors on the RPI (no lost packets, overruns, etc.)
- The dropouts also occur when playing from a USB FLASH drive

WRT both issues: I experimented with different buffer sizes and different sound profiles, but this didn't help.

---------------------------------------

Added 3/9: If I send the output to a TV via HDMI, it works. If I then turn on the preamp with output still to the TV, and without changing anything else, the sound stops! I think the preamp is excessively loading the board. I could measure voltages, etc., but it is easier to try a powered USB hub and see if that works...

---------------------------------------

I just installed 20200213 on a RPI 3B+, with a 32 GB SD (file system resized to use the whole thing), Internet connection is via WiFi and the DAC is a Parasound P6. The 7" touch screen is also installed. I'm using a Y-connector to the 2.5 A official power supply to power the PI and the screen directly due to a voltage drop encountered when the PI was connected to the screen via its GPIO.

What's happening is that I'm getting sound only for a few seconds each time the preamp is turned on, and also occasionally at what seem like random times (but seemingly more likely when logged in via SSH, although it doesn't seem related to running certain commands, etc.)

I also note that in the Audio Output Interface combo box, there are two entries: "PARASOUND-1" and "PARASOUND-2". (Is this normal?) Trying each, and changing various associated options hasn't helped.

Another observation is that the UI seems to slow down when the DAC is on.

Looking at the PI via SSH, nothing stands out as using excessive memory or CPU.

If this is a known issue, I haven't found it yet via Google. If it is something new, I'd welcome suggestions about what to look at and what debug data to collect. (I don't see Menu --> Debug referred to in an old post.)

Thanks!
Last edited by martinb0820 on 13 Mar 2020, 01:07, edited 2 times in total.
martinb0820
 
Posts: 4
Joined: 08 Mar 2020, 17:33

Re: Sound for only a few seconds when DAC turned on

Postby martinb0820 » 08 Mar 2020, 20:59

Couldn't attach this as a file for some reason...

Status 
mpd.service - Music Player Daemon
Loaded: loaded (/usr/lib/systemd/system/mpd.service; disabled; vendor preset: disabled)
Active: active (running) since Sun 2020-03-08 15:48:39 EDT; 1min 28s ago
Docs: man:mpd(1)
man:mpd.conf(5)
Main PID: 8581 (mpd)
Tasks: 9 (limit: 2280)
Memory: 10.3M
CGroup: /system.slice/mpd.service
└─8581 /usr/bin/mpd --no-daemon

Mar 08 15:48:36 runeaudio systemd[1]: Starting Music Player Daemon...
Mar 08 15:48:37 runeaudio mpd[8581]: Mar 08 15:48 : exception: Decoder plugin 'wildmidi' is unavailable: configuration file does not exist: /etc/timidity/timidity.cfg
Mar 08 15:48:37 runeaudio mpd[8581]: Mar 08 15:48 : exception: Input plugin 'tidal' is unavailable: No Tidal application token configured
Mar 08 15:48:37 runeaudio mpd[8581]: Mar 08 15:48 : exception: Input plugin 'qobuz' is unavailable: No Qobuz app_id configured
Mar 08 15:48:39 runeaudio systemd[1]: Started Music Player Daemon.


/etc/mpd.conf
auto_update "no"
bind_to_address "0.0.0.0"
db_file "/srv/http/data/mpd/mpd.db"
filesystem_charset "UTF-8"
follow_inside_symlinks "yes"
follow_outside_symlinks "yes"
log_level "default"
log_file "/var/log/mpd.log"
max_connections "20"
mixer_type "none"
music_directory "/mnt/MPD"
pid_file "/var/run/mpd/pid"
playlist_directory "/var/lib/mpd/playlists"
port "6600"
replaygain "off"
state_file "/var/lib/mpd/mpdstate"
sticker_file "/var/lib/mpd/sticker.sql"
user "mpd"
volume_normalization "no"
zeroconf_enabled "yes"
zeroconf_name "RuneAudio"

input {
plugin "curl"
}

decoder {
plugin "ffmpeg"
enabled "no"
}

resampler {
plugin "soxr"
quality "very high"
}

audio_output {
name "RaspberryPi Analog Out"
device "hw:0,0"
type "alsa"
auto_resample "no"
auto_format "no"
mixer_control "PCM"
mixer_device "hw:0"
}

audio_output {
name "RaspberryPi HDMI Out"
device "hw:0,1"
type "alsa"
auto_resample "no"
auto_format "no"
mixer_control "PCM"
mixer_device "hw:0"
}

audio_output {
name "PARASOUND-1"
device "hw:1,0"
type "alsa"
auto_resample "no"
auto_format "no"
}

audio_output {
name "PARASOUND-2"
device "hw:1,1"
type "alsa"
auto_resample "no"
auto_format "no"
}

Hardware Devices

.
.
.
card 1: PARASOUND [PARASOUND], device 0: USB Audio [USB Audio]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 1: PARASOUND [PARASOUND], device 1: USB Audio [USB Audio #1]
Subdevices: 0/1
Subdevice #0: subdevice #0
martinb0820
 
Posts: 4
Joined: 08 Mar 2020, 17:33

support RuneAudio Donate with PayPal


Return to Raspberry Pi

Who is online

Users browsing this forum: cmh714, kiko and 7 guests