[solved] Runeaudio downrate with my dac

Raspberry Pi related support

[solved] Runeaudio downrate with my dac

Postby willou » 09 Jun 2021, 16:54

Hi,

At home, Runeaudio is running on a raspberry Pi 2, wired to a dac cambridge dacmagic 100 with a brand new usb 2.0 cable.
My DAC is supposed to support 192khz but when I read a 192 khz file it detects a 96 khz file.
On runeaudio GUI it indicates that the file is a 192khz file.
when I run cat /proc/asound/card1/pcm0p/sub0/hw_params
Code: Select all
access: RW_INTERLEAVED
format: S24_3LE
subformat: STD
channels: 2
rate: 96000 (96000/1)
period_size: 12000
buffer_size: 48000


I tested :
- new usb cable
- add format "192000:*:*" in the right audio_output in mpd.conf
- edit /etc/asound.conf with the rate I want on the right card

No effect, but if I change format in mpd.conf with values under 96khz, it works as expected.

Here's my /etc/mpd.conf :
Code: Select all
state_file      "/var/lib/mpd/mpdstate"
zeroconf_enabled        "yes"
zeroconf_name   "runeaudio"
bind_to_address "/run/mpd.sock"
bind_to_address         "any"
port    "6600"
max_connections         "20"
user    "mpd"
group   "audio"
db_file         "/var/lib/mpd/mpd.db"
sticker_file    "/var/lib/mpd/sticker.sql"
pid_file        "/var/run/mpd/pid"
music_directory         "/mnt/MPD"
playlist_directory      "/var/lib/mpd/playlists"
follow_outside_symlinks         "yes"
follow_inside_symlinks  "yes"
auto_update     "no"
filesystem_charset      "UTF-8"
id3v1_encoding  "UTF-8"
volume_normalization    "no"
audio_buffer_size       "2048"
buffer_before_play      "10%"
gapless_mp3_playback    "yes"
mixer_type      "disabled"

input {
        plugin  "curl"
}

decoder {
        plugin  "ffmpeg"
        enabled "yes"
}
replaygain      "off"

audio_output {
        name            "Cambridge AudioDAC100 USB 1"
        type            "alsa"
        device          "hw:1,0"
        auto_resample   "no"
        auto_format     "no"
        format          "192000:*:*"
        enabled         "yes"
}

audio_output {
        name            "bcm2835 ALSA_2"
        type            "alsa"
        device          "hw:0,0"
        auto_resample   "no"
        auto_format     "no"
}

audio_output {
        name            "bcm2835 ALSA_1"
        type            "alsa"
        device          "hw:0,0"
        auto_resample   "no"
        auto_format     "no"
"/etc/mpd.conf" 67 lines, 1317 characters


Thank you for your help!

Willou
Last edited by willou on 10 Jun 2021, 14:19, edited 1 time in total.
willou
 
Posts: 4
Joined: 01 Jun 2021, 10:33

Re: Runeaudio downrate with my dac

Postby willou » 10 Jun 2021, 12:27

I have more informations.

Obviously My dac, cambridge dac magic 100
I recognized as a usb audio 1 dac and not usb audio 2.0 what's needed to play rate over 96khz.
So my question would, how can i do to make mpd and alsa recognize my dac as a usb audio 2.0 dac.
On a market site it indicates that the dac needs a specific driver to do so on windows...

cat /proc/asound/card1/stream0:
Code: Select all
Cambridge Audio Cambridge AudioDAC100 USB 1 at usb-3f980000.usb-1.2, full speed : USB Audio

Playback:
  Status: Running
    Interface = 1
    Altset = 1
    Packet Size = 582
    Momentary freq = 96006 Hz (0x60.0180)
    Feedback Format = 10.14
  Interface 1
    Altset 1
    Format: S24_3LE
    Channels: 2
    Endpoint: 1 OUT (ASYNC)
    Rates: 44100, 48000, 88200, 96000


willou
willou
 
Posts: 4
Joined: 01 Jun 2021, 10:33

Re: [solved] Runeaudio downrate with my dac

Postby willou » 10 Jun 2021, 14:23

Don't know how to significate my question was answererd, so edited the title.
No linux issue.
The fact is that to switch to USB audio class 2 on the cambridge dac magic 100 you have to put it on stand by mode, push and hold the source button and click on the poweron button in the same time.
willou
 
Posts: 4
Joined: 01 Jun 2021, 10:33

support RuneAudio Donate with PayPal


Return to Raspberry Pi

Who is online

Users browsing this forum: cmh714 and 1 guest