Rune UI is slow

Raspberry Pi related support

Re: Rune UI is slow

Postby Golgi » 31 May 2019, 10:37

Yes, works like a charm.
Thanks RandomRuneUser, good job!

Posts: 5
Joined: 18 Apr 2019, 13:28

Re: Rune UI is slow

Postby englishtim » 31 May 2019, 11:31

Hi Everyone,

Works here too - thanks to RandomRuneUser for the fix!

Please note that - unsurprisingly - Dirble no longer works when the fix is applied. I don't use it here, but those of us who do use it should just be aware...

Peace and friendship,
Synology DS918+ NAS >
  • Raspberry Pi 3 Model B+ > Behringer UCA202 >
    • Denon RCD-M38DAB > KEF Cresta II
    • Pro-Ject Head Box S > Sennheiser HD 650
  • Raspberry Pi 3 Model B > FiiO E10K > Sansui AU-317 > Celestion SL6
User avatar
Posts: 40
Joined: 20 Feb 2015, 11:36
Location: Always European

Re: Rune UI is slow

Postby dragos_nedelcu » 31 May 2019, 15:21

Works perfectly!!!!!! Thank you!!!!!
Posts: 25
Joined: 19 Jul 2017, 05:54

Re: Rune UI is slow

Postby dragos_nedelcu » 31 May 2019, 15:31

Faster than first install. Thank you RandomRuneUser!!!!!!!!!
Posts: 25
Joined: 19 Jul 2017, 05:54

Re: Rune UI is slow

Postby Ears of Tin » 31 May 2019, 20:12

Here's another thank you for the fix. Working great and I got to use SSH for the first time.
Ears of Tin
Posts: 6
Joined: 17 Dec 2018, 00:42

Re: Rune UI is slow

Postby Colin » 31 May 2019, 20:21


This is due to the Dirble not responding anymore.
I've not found a way to disable it yet, will look into it.

Edit: I've made a merge request that adds a setting to disable it :
Posts: 17
Joined: 14 Dec 2018, 11:51

Re: Rune UI is slow

Postby Tantal » 01 Jun 2019, 10:51

The interface works as usual again,
without editing any files.
Rune version: 0.4 (build: beta-20160313) on RB Pi2 + Fiio e17-e09
Posts: 6
Joined: 28 May 2019, 10:00

Re: Rune UI is slow

Postby tml3nr » 01 Jun 2019, 10:57

RandomRuneUser wrote:
dynobot wrote:Would something like iftop or some other network monitoring tool be of use to determine what is trying to connect to what and holding up the UI?

using iftop I can see as possibly being the problem....any way to remove this from Rune?

I ran a trace on my router and saw timeouts with my pi connecting to that corresponded closely to the delays in the UI. Just blocking that IP did not work, but wildcard-blacklisting on my pi-hole did.


If you don't have control over your DNS, probably you could edit the hosts file on your rune box (or whatever the equivalent is ... I'm not super familiar with arch linux.)

Edit: can confirm that adding the following to /etc/hosts works:

It works perfectly! Many thanks RandomRuneUser.
Posts: 56
Joined: 02 Apr 2016, 07:43

Re: Rune UI is slow

Postby Toube » 02 Jun 2019, 16:14

Works like a charm, great work @RandomRuneUser thanks.

Posts: 131
Joined: 10 Oct 2018, 08:10

Re: Rune UI is slow

Postby anana » 05 Jun 2019, 08:41

This resolved the issue. (Added wildcarded to my pihole blacklist.)

It may work now even faster than before. Thank you!
Posts: 4
Joined: 12 Aug 2014, 17:49

support RuneAudio Donate with PayPal


Return to Raspberry Pi

Who is online

Users browsing this forum: ben569 and 19 guests