Reinstalling shairport

Raspberry Pi related support

Re: Reinstalling shairport

Postby dror » 29 Dec 2017, 07:34

janui wrote:
Code: Select all
pacman -Sy openssl pacman wpa_supplicant
janui


About this
(Frank ?) is updating those packages might break RuneOS ?
dror
 
Posts: 122
Joined: 03 Dec 2015, 10:14

Re: Reinstalling shairport

Postby hondagx35 » 29 Dec 2017, 11:33

Hi dror,

(Frank ?) is updating those packages might break RuneOS ?

It shouldn't see here
On my latest image you should also update hostapd!

Frank
User avatar
hondagx35
 
Posts: 3041
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: Reinstalling shairport

Postby dror » 31 Dec 2017, 07:53

Hi,

Thanks for the answer.
I tied undating the above packages, altough Rune is ok, still NO GO for the shairport-sync installation.
First, through all the packages installation process, I kept getting the warnings about permission issues, like the one I mentioned before
Code: Select all
 warning: directory permissions differ on /usr/lib/systemd/system/


did a chmod for that folder and they have gone.
Nevertheless, executing
Code: Select all
shairport-sync -V


gives the same result, therfore not installed correctly
Code: Select all
root@runeaudio(rw):~# shairport-sync -V
shairport-sync: error while loading shared libraries: libcrypto.so.1.1: cannot open shared object file: No such file or directory


:( :?

Now, I'm sure not a Linux / Rpi expert, but I noticed AUR page of shairport-sync lists a x84_x64 version, and as the dev says in the readme:
"Shairport Sync is available for x86_64 and i686 platforms in the Arch Linux Community Repository"

Don't we need an ARM7 version?

Dror

Edit:
I also tried to check if openssl files are recognized using
Code: Select all
ldd /usr/bin/openssl


and got the output:
Code: Select all
root@runeaudio(rw):~# ldd /usr/bin/openssl
        linux-vdso.so.1 (0x7eef7000)
        libssl.so.1.1 => /usr/lib/libssl.so.1.1 (0x76e8f000)
        libcrypto.so.1.1 => /usr/lib/libcrypto.so.1.1 (0x76cc3000)
        libpthread.so.0 => /usr/lib/libpthread.so.0 (0x76c9a000)
        libc.so.6 => /usr/lib/libc.so.6 (0x76b5b000)
        /lib/ld-linux-armhf.so.3 (0x76f07000)
        libdl.so.2 => /usr/lib/libdl.so.2 (0x76b46000)
root@runeaudio(rw):~#


which I understand shows the libcrypto file is recognized.
dror
 
Posts: 122
Joined: 03 Dec 2015, 10:14

Re: Reinstalling shairport

Postby hondagx35 » 31 Dec 2017, 13:31

Hi,

with my latest image from here it should be easy to install/upgrade shairport-sync.
Here the way i did this:

- get a fresh image

- update openssl, pacman, wpa_supplicant and hostapd
Code: Select all
pacman -Sy openssl pacman wpa_supplicant hostapd

This also will fix the KRACK () WPA2 bug.

- update shairport-sync
Code: Select all
pacman -Sy shairport-sync


- check if it works
Code: Select all
root@runeaudio(rw):~# shairport-sync -V
shairport-sync: error while loading shared libraries: libconfig.so.11: cannot open shared object file: No such file or directory

Code: Select all
root@runeaudio(rw):~# find / -name  libconfig.so*
/usr/lib/libconfig.so.9.2.0
/usr/lib/libconfig.so.9
/usr/lib/libconfig.so

OK, shairport-sync needs a different version of libconfig. What can we do?
* we can try to make a softlink from libcrypto.so.11 to libcrypto.so. This is a ugly and not recommended workaround.
* we can try to update libconfig
Code: Select all
root@runeaudio(rw):~# pacman -Qi libconfig
Name            : libconfig
Version         : 1.5-3
Description     : C/C++ Configuration File Library
Architecture    : armv7h
URL             : http://hyperrealm.com/libconfig/libconfig.html
Licenses        : LGPL
Groups          : None
Provides        : None
Depends On      : gcc-libs  texinfo
Optional Deps   : None
Required By     : shairport-sync
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 196.00 KiB
Packager        : Arch Linux ARM Build System <builder+xu7@archlinuxarm.org>
Build Date      : Sun 12 Jun 2016 04:19:59 PM CEST
Install Date    : Thu 08 Sep 2016 10:57:28 AM CEST
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : SHA-256 Sum

Ah, libconfig is only used by shairport-sync, so it should be save to update.
Code: Select all
pacman -Sy libconfig

Now let us try if we are done:
Code: Select all
root@runeaudio(rw):~# shairport-sync -V
3.1.7-OpenSSL-Avahi-ALSA-pa-soxr-sysconfdir:/etc


Frank
User avatar
hondagx35
 
Posts: 3041
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: Reinstalling shairport

Postby dror » 31 Dec 2017, 14:08

Hi Frank, that's exactly what I did, and I was about to update after I return home and check shairport-sync to be functioning correctly :)

Thanks for the help. Indeed the "Pacman - Qi" command can very handy for ensuring Rune won't break while updating packages.

Cheers
dror
 
Posts: 122
Joined: 03 Dec 2015, 10:14

support RuneAudio Donate with PayPal

Previous

Return to Raspberry Pi

Who is online

Users browsing this forum: cmh714, Ears of Tin and 5 guests