[Solved] Raspberry Pi 1 with NAS share to FreeNAS 11.3

Raspberry Pi related support

[Solved] Raspberry Pi 1 with NAS share to FreeNAS 11.3

Postby Ali Mac » 31 May 2020, 14:24

Hi Everyone,
Just spent quite some time trying to sort this one out but I found the key items to making sure you can link your NAS drive which uses FreeNAS

[Rune Audio]
Under the "Sources"
Fileshare protocol - SMB/CIFS
IP Address - correct to your server.
Remote directory - SMB share Name under the "Windows Shares (SMB)" on FreeNAS
Guest access - depends on your setup of your server, mine was off.
Username - Username of your FreeNAS user account.
Password - password for the above.
Advanced options - turn on.
Mount flags - sec=ntlmssp

It took me a while to get the one key item to work which was that Mount Flag which was the security item, it was all that was really needed, all the rest above about the Fileshare and IP, etc was fairly straight forward.

[FreeNAS]
Under the "Services" select to configure the 'SMB' and you will need to make sure only one item is definitely switched on, "Enable SMB1 support"
because currently FreeNAS 11.3 I believe is using SMB 4.0 and Rune Audio is only using SMB 1.0 maybe

(Please note all of the above is coming from a complete newbie to this, I am just trying to save the next person in line like me hours of searching to find the same thing)
Ali Mac
 
Posts: 1
Joined: 31 May 2020, 14:03

Re: [Solved] Raspberry Pi 1 with NAS share to FreeNAS 11.3

Postby eea123 » 04 Jun 2020, 21:58

Thanks for sharing this. We all had some level of sorting out to do, no matter what our configuration. Mine is a QNAP NAS and it was finicky on the directory share as well.
eea123
 
Posts: 104
Joined: 23 Dec 2017, 19:19

support RuneAudio Donate with PayPal


Return to Raspberry Pi

Who is online

Users browsing this forum: cmh714 and 7 guests