[SOLVED]Problem Adding Synology NAS as Source

Raspberry Pi related support

[SOLVED]Problem Adding Synology NAS as Source

Postby poecameraon » 13 Mar 2021, 17:13

I'm not able to add my synology nas as a source for my RuneAudio Pi running a newer version of rAudio. Here's my setup:

version: rAudio 1 • 20210302
OS: 5.10.17-2-ARCH armv7l
Hardware: Raspberry Pi 3 Model B Plus Rev 1.3
SoC: BCM2837B0 • 962MiB
CPU: 4 Cortex-A53 @ 1.4GHz

Synology is a DS218+ on a VLAN setup for IOT/music.

I'm able to access the nas normally from a windows pc by mounting it \\192.168.XX.YY\music\

When I try to add the nas folder via the UI I have tried adding it as a CIFS with the following settings:
name: MediaNas
IP: 192.168.XX.YY
sharename: music
user: xx
password: xx
options: blank

When I click ok "network mount mount... " shows up in the bottom left corner blinking and a blinking icon shows up at the top for a short while and then stops and no new device is added.

I've tried changing the share name to several variations: music\ music/ etc. I've also tried enabling NFS on the synology and tried adding the folder as that and get the same result. Am I missing anything obvious? Any suggestions to try to debug? Any help would be greatly appreciated.
Last edited by poecameraon on 17 Mar 2021, 06:28, edited 1 time in total.
poecameraon
 
Posts: 2
Joined: 13 Mar 2021, 16:52

Re: Problem Adding Synology NAS as Source

Postby eea123 » 14 Mar 2021, 10:51

I would double check the directory, I have a QNAP NAS and had to use the default music directory of:

Multimedia/Music

On my network it appears as //10.0.0.XX/Multimedia/Music/ I also had to login as admin.
eea123
 
Posts: 113
Joined: 23 Dec 2017, 19:19

Re: Problem Adding Synology NAS as Source

Postby rlsten » 14 Mar 2021, 16:13

poecameraon wrote:I'm not able to add my synology nas as a source for my RuneAudio Pi running a newer version of rAudio. Here's my setup:

version: rAudio 1 • 20210302
OS: 5.10.17-2-ARCH armv7l
Hardware: Raspberry Pi 3 Model B Plus Rev 1.3
SoC: BCM2837B0 • 962MiB
CPU: 4 Cortex-A53 @ 1.4GHz

Synology is a DS218+ on a VLAN setup for IOT/music.

I'm able to access the nas normally from a windows pc by mounting it \\192.168.XX.YY\music\

When I try to add the nas folder via the UI I have tried adding it as a CIFS with the following settings:
name: MediaNas
IP: 192.168.XX.YY
sharename: music
user: xx
password: xx
options: blank

When I click ok "network mount mount... " shows up in the bottom left corner blinking and a blinking icon shows up at the top for a short while and then stops and no new device is added.

I've tried changing the share name to several variations: music\ music/ etc. I've also tried enabling NFS on the synology and tried adding the folder as that and get the same result. Am I missing anything obvious? Any suggestions to try to debug? Any help would be greatly appreciated.


Having exact same problem with Synology NAS 918. Using RPi4, rAudio 1 • 202103121. Tired both CIFS and NFS. Flashing box in corner, says Done, no network source added.
rlsten
 
Posts: 118
Joined: 25 May 2015, 18:06

Re: Problem Adding Synology NAS as Source

Postby giovilux » 14 Mar 2021, 17:05

Hi,
I'm using a Synology DS218J with NAS.
You should find out what is the shared folder path in your NAS:
Control panel --> shared folders --> change your folder (in my case "Music") --> NFS tab --> you should see "mount path: /volume1/music"

in RAudio sources providing that the IP of your nas is correct --> /volume1/music

It should work

Giovanni
giovilux
 
Posts: 23
Joined: 05 Sep 2017, 21:11

Re: Problem Adding Synology NAS as Source

Postby rlsten » 14 Mar 2021, 17:15

Was able to mount the Synology network drive by editing /etc/fstab manually to add the following and then rebooting:
Code: Select all
//192.168.x.xx/sharedfolder  /mnt/MPD/NAS/FolderName  cifs  noauto,username=xxxxxxxx,password=xxxxxxxxxxxx,uid=45,gid=45,iocharset=utf8  0  0


Replace "x"s with the values for your system; "sharedfolder" with name of the network folder you want to share on Rune; and "FolderName" with the name you want the shared folder to have in the Rune library. I also manually created a directory called "FolderName" (in my case Music) in the /mnt/MPD/NAS/ directory of Rune. I don't know if that has to be done or not.
rlsten
 
Posts: 118
Joined: 25 May 2015, 18:06

Re: Problem Adding Synology NAS as Source

Postby tsawyer » 16 Mar 2021, 17:04

great response risten. I had the same problem trying to get rune attach to a nas (pi running samba sharing a portable drive) and never got a chance to go back to it. in my case, part of the issue was getting samba to talk to the win10 box the way I wanted but even after solving that rune would only blink. I need to redo the nas (other reasons and need to finalize documentation for a lab exercise) but I definitely think editing fstab that way is going to bypass the nas button that hasn't been working. I only got a chance to do a quick look at the syntax of connecting to a 'windows' share from rune but think that nails it.
tsawyer
 
Posts: 57
Joined: 05 Jul 2017, 03:02

Re: Problem Adding Synology NAS as Source

Postby poecameraon » 17 Mar 2021, 06:27

Oh man, I was about to call it quits after another evening of banging my head against the screen. I took a look at this post
post21144.html
and took another look at my NFS permissions in synology and realized the IP I gave permissions to (supposed to be rune pi) was incorrect, updated it and boom, source shows up. For others working with Synology NAS take a look at NFS permissions:

The Answer: A bad configuration of NFS on my NAS Synology.
For those who have the same problem:

in Control Panel/shared folder/music
In "Permissions", verify if on the line "admin", read/write is checked.
After in "Autorisations NFS"
I have the configuration like this:

Hostname or IP: 192.168.x.xx (it's the ip of my runeaudio)
Privilege: Read/Write
Squash: Mapping all users on admin
Security: sys

And check all after (mode asynchrone...)


While trying to debug I have not been able to ssh into my pi (using root/rune) but that's a battle/post for another day.

Thank you for all the helpful suggestions, it is much appreciated.
poecameraon
 
Posts: 2
Joined: 13 Mar 2021, 16:52

Re: [SOLVED]Problem Adding Synology NAS as Source

Postby neanderthaler » 20 Mar 2021, 22:18

While trying to debug I have not been able to ssh into my pi (using root/rune)

You for sure did realize that rern changed RuneAudios credentials in his rAudio-version.
Try "ros"
https://github.com/rern/rAudio-1/blob/main/README.md
neanderthaler
 
Posts: 22
Joined: 01 May 2015, 08:20

support RuneAudio Donate with PayPal


Return to Raspberry Pi

Who is online

Users browsing this forum: cmh714 and 3 guests