Mount NAS Synology

Raspberry Pi related support

Mount NAS Synology

Postby K3nt » 30 Nov 2020, 15:39

Hi,
I'm trying to mount my NAS by runeaudio UI, i get error: No such file or directory
Source Name: Music
Fileshare Protocol: SMB/CIFS
IP Adress: 192.168.x.xx
Remote Directory: volume1/Music
User:Admin
Pass:xxxxx
Advanced Options: No
In MPD
Daemon user: group root:root

When I enter this command:
mkdir /mnt/MPD/NAS/Music
The error I get is:
mkdir: cannot create directory ‘/mnt/MPD/NAS/Music’: No such file or directory
What should i do ?
Thanks !
K3nt
 
Posts: 2
Joined: 13 Dec 2017, 12:14

Re: Mount NAS Synology

Postby englishtim » 02 Dec 2020, 18:14

H K3nt,

There are a few things in your RuneAudio settings that I'd suggest you try changing:

Sources:
  • Check what the path for your saved Network Mount looks like - it should be something like "your-share-name //192.168.x.x/music/your-library-name";
Sources > Network Mounts > your saved network mount:
  • Remote directory: if you're storing your music in Synology's default "music" share, then this should be simply "music". The "volume1/" prefix isn't needed. If you've put your music library in a sub-folder, then the path should look something like "music/your-library-name";
  • Username & password: I'd strongly advise you not to use your Admin account to access your library, as this seriously compromises your NAS's security. In my case I created a separate "music" user-account with its access restricted just to the "music" share;
MPD:
  • Daemon user: group: I'd set this to "mpd:audio (default)", again for reasons of security.
There shouldn't be any need to set up a custom mount-point. With both my previous Synology NAS (DS212) and my current one (DS918+) everything works fine without needing to do anything on the command-line.

There is one thing to watch out for, depending on which version of RuneAudio you're using and what you're running it on. If you're using an older model of Raspberry PI then you might need to allow SMB to support SMB1 (Synology: Control Panel > File Services > SMB/APF/NFS > Advanced Settings > Minimum SMB Protocol: SMB1). Later versions of RuneAudio and RPi can tolerate more recent varieties of SMB.

I hope this helps.

Peace and friendship,
englishtim
Synology DS918+ NAS >
  • Raspberry Pi 3 Model B+ > Behringer UCA202 >
    • Denon RCD-M38DAB > KEF Cresta II
    • Pro-Ject Head Box S > Sennheiser HD 650
  • Raspberry Pi 3 Model B > FiiO E10K > Sansui AU-317 > Celestion SL6
User avatar
englishtim
 
Posts: 42
Joined: 20 Feb 2015, 11:36
Location: Always European

support RuneAudio Donate with PayPal


Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 5 guests