JustBoom Zero DAC not detected

Raspberry Pi related support

JustBoom Zero DAC not detected

Postby josepz » 15 Jan 2017, 19:25

I just installed rune audio, but my JustBoom Zero DAC isn´t detected on setup.

aplay -l don´t show it, and I edited my /boot/config.txt as:

Code: Select all
dtparam=i2c_arm=on
#dtparam=i2c_vc=on
dtparam=i2s=on
device_tree_overlay=JustBoom-dac
#dtparam=spi=on
#dtparam=act_led_trigger=mmc
dtoverlay=JustBoom-dac


This DAC is working fine in raspbian with kodi , max2play or volumio... What could be the problem here?
josepz
 
Posts: 5
Joined: 15 Jan 2017, 19:18

Re: JustBoom Zero DAC not detected

Postby Yatsushiro » 15 Jan 2017, 19:49

You don't need 'device_tree_overlay=JustBoom-dac'

The overlay file is called 'justboom-dac.dtbo' so you should edit your config.txt to read 'dtoverlay=justboom-dac'
Yatsushiro
 
Posts: 90
Joined: 11 May 2016, 10:30

Re: JustBoom Zero DAC not detected

Postby josepz » 15 Jan 2017, 21:30

Thaks for the answer! Unfortunately, this not solved the problem. I did a fresh install of rune audio, edited config.txt as:
Code: Select all
dtparam=i2c_arm=on
#dtparam=i2c_vc=on
#dtparam=i2s=on
#dtparam=spi=on
#dtparam=act_led_trigger=mmc
#dtparam=uart1=off
#dtoverlay=pi3-disable-bt-overlay
# Uncomment one of these lines to enable an audio interface
#dtoverlay=hifiberry-dac
#dtoverlay=hifiberry-dacplus
#dtoverlay=hifiberry-digi
#dtoverlay=hifiberry-amp
#dtoverlay=iqaudio-dac
#dtoverlay=iqaudio-dacplus
dtoverlay=justboom-dac


but my DAC isn´t detected yet. aplay -l command don´t detect it, mpd setup don´t show it....
josepz
 
Posts: 5
Joined: 15 Jan 2017, 19:18

Re: JustBoom Zero DAC not detected

Postby Yatsushiro » 15 Jan 2017, 21:42

I assume you have updated the kernel? Does justboom-dac.dtbo exist in /boot/overlays?

If so, have you selected the justboom-dac under mpd configuration via the UI?
Yatsushiro
 
Posts: 90
Joined: 11 May 2016, 10:30

Re: JustBoom Zero DAC not detected

Postby josepz » 15 Jan 2017, 23:13

No, I just installed the last image file available for download... the justboom-dac.dtbo isn´t at the directory ... ok, I will search how to update, apt-get don´t wotk for arch, right?

Thanks for your help
josepz
 
Posts: 5
Joined: 15 Jan 2017, 19:18

Re: JustBoom Zero DAC not detected

Postby hondagx35 » 16 Jan 2017, 00:15

Hi josepz,

updating the kernel:
* get access to the console (ssh)

* check the free space on your sd card (<=85%). If not resize your partition (see documentation)

* update the kernel and firmware
Code: Select all
pacman -Sy --force raspberrypi-firmware raspberrypi-bootloader linux-raspberrypi


* add "dtparam=audio=on" to your /boot/config.txt
Code: Select all
    # Uncomment one of these lines to enable an audio interface
    #dtoverlay=hifiberry-dac
    #dtoverlay=hifiberry-dacplus
    dtoverlay=hifiberry-digi
    #dtoverlay=hifiberry-amp
    #dtoverlay=iqaudio-dac
    #dtoverlay=iqaudio-dacplus
    dtparam=audio=on


* delete the file /etc/modules-load.d/ras....conf

* change the kernel name in data base (optional only cosmetic)
Code: Select all
uname -a
Linux runeaudio 4.4.33-1-ARCH #1 SMP Sat Nov 19 14:09:17 MST 2016 armv7l GNU/Linux

Code: Select all
redis-cli set kernel "Linux runeaudio 4.4.33-1-ARCH"


Frank
User avatar
hondagx35
 
Posts: 3041
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: JustBoom Zero DAC not detected

Postby josepz » 16 Jan 2017, 00:38

Ok, no way... :cry: tried to update from a fresh rune image, following steo by step the docs, and this is the result:
Code: Select all
[root@runeaudio ~]# cd /var/www
[root@runeaudio www]# git pull
remote: Counting objects: 153, done.
remote: Total 153 (delta 103), reused 103 (delta 103), pack-reused 50
Receiving objects: 100% (153/153), 37.48 KiB | 0 bytes/s, done.
Resolving deltas: 100% (107/107), completed with 27 local objects.
From https://github.com/RuneAudio/RuneUI
   71f5236..836ec22  dev        -> origin/dev
   c9dbad5..e61ef56  master     -> origin/master
Updating 71f5236..836ec22
error: The following untracked working tree files would be overwritten by merge:
        command/mpd-watchdog
Please move or remove them before you can merge.
Aborting
[root@runeaudio www]#


Updating by gui does nothing...

So, I went to guithub and downloaded justboom-dac.dtbo to /boot/overlays. I edited /boot/config.txt adding dtoverlay=Justboom-dac and i2c=on, but the card wasn´t detected yet. If I change /etc/modules-load.d/raspberrypi.conf to #snd-bcm2835 , aplay -l don´t detect any audio card. Now I don´t know how to do
josepz
 
Posts: 5
Joined: 15 Jan 2017, 19:18

Re: JustBoom Zero DAC not detected

Postby josepz » 16 Jan 2017, 01:02

YES.....IT WORKS!!!. I did the update following this steps, and after the update the card finally was detected, :D Is detected as card1. Thank you very much for your support
josepz
 
Posts: 5
Joined: 15 Jan 2017, 19:18

Re: JustBoom Zero DAC not detected

Postby JustBoom » 16 Jan 2017, 13:37

Hi all,

Just to chime in here, the kernel in the current image of Rune Audio is quite an old one so does not have the correct drivers in it yet. Hopefully that may be fixed soon with any luck.

So one option is updating the kernel like you have done to pull in the new drivers.

Alternatively, and please note this has not been tested, but if there are other DACs out there using the same chip the JustBoom boards may work with their drivers. This is worth testing before going to the trouble of downloading a new kernel, however this is unsupported by us...

EDIT: the previous content of this post was actually incorrect. So I have deleted a lot of it to avoid any confusion.

If there is anything the Rune Audio devs need to get support built in (I believe we already sent all the boards over for them to play with) happy to help in any way that we can!
JustBoom - Affordable High Quality Audio for Everyone!
https://www.JustBoom.co
User avatar
JustBoom
 
Posts: 1
Joined: 16 Jan 2017, 13:21

Re: JustBoom Zero DAC not detected

Postby DomieMic65 » 23 Feb 2017, 20:40

hondagx35 wrote:Hi josepz,

updating the kernel:
* get access to the console (ssh)

* check the free space on your sd card (<=85%). If not resize your partition (see documentation)

* update the kernel and firmware
Code: Select all
pacman -Sy --force raspberrypi-firmware raspberrypi-bootloader linux-raspberrypi


* add "dtparam=audio=on" to your /boot/config.txt
Code: Select all
    # Uncomment one of these lines to enable an audio interface
    #dtoverlay=hifiberry-dac
    #dtoverlay=hifiberry-dacplus
    dtoverlay=hifiberry-digi
    #dtoverlay=hifiberry-amp
    #dtoverlay=iqaudio-dac
    #dtoverlay=iqaudio-dacplus
    dtparam=audio=on


* delete the file /etc/modules-load.d/ras....conf

* change the kernel name in data base (optional only cosmetic)
Code: Select all
uname -a
Linux runeaudio 4.4.33-1-ARCH #1 SMP Sat Nov 19 14:09:17 MST 2016 armv7l GNU/Linux

Code: Select all
redis-cli set kernel "Linux runeaudio 4.4.33-1-ARCH"


Frank

Hallo Frank!
In order to update the kernel should I be in the "Sound signature: RuneAudio" which is the default (now i use Archlinux default) or is it irrelevant?
I don't have any issues with my DAC! Just want to use the latest version...

Thank you!!!!
DomieMic65
 
Posts: 41
Joined: 12 Feb 2017, 21:04

support RuneAudio Donate with PayPal

Next

Return to Raspberry Pi

Who is online

Users browsing this forum: cmh714 and 2 guests