Infineon Amp HAT support ?

Raspberry Pi related support

Infineon Amp HAT support ?

Postby ceejayemm » 22 May 2020, 22:42

Any version of RuneAudio likely to support this interesting HAT ?

[https://www.infineon.com/cms/en/product/evaluation-boards/kit_40w_amp_hat_zw/?redirId=119773]

Chris
ceejayemm
 
Posts: 45
Joined: 29 Oct 2016, 18:13

Re: Infineon Amp HAT support ?

Postby rern » 25 May 2020, 08:29

Hi,

RuneAudio+R e3 now has it in I2S module list.
Please report the result.

rern
Raspberry Pi 3B > SMSL M8 DAC
Raspberry Pi Zero W
Raspberry Pi 4B
GitHub
User avatar
rern
 
Posts: 555
Joined: 14 Jul 2016, 08:15

Re: Infineon Amp HAT support ?

Postby ceejayemm » 01 Jun 2020, 20:24

Rern

Thanks for making this change to implement this new HAT Amp.

I have just taken delivery of the new Merus Amp HAT, installed RA+e3 on a new PI Zero W, using the wifi0 file as a template for the wireless settings which seems OK,and applied the 20200527 updates which suggests the wireless is working OK. I have configured the system via the web pages, specifying the I2S Module as the new Merus Audio Amp. The Sources and Network pages were also configured correctly without any problems. I then moved on to the MPD settings, however the MPD page will not render at all. I disabled the I2S Module and I WAS then able to access the MPD page. Switched back to the Merus and the MPD page was not accessible again.

It would seem that there is something in the Merus Audio Amp setup which is interrupting access to the MPD settings page. What might that be ?

Thanks

Chris
ceejayemm
 
Posts: 45
Joined: 29 Oct 2016, 18:13

Re: Infineon Amp HAT support ?

Postby rern » Yesterday, 05:30

Hi Chris,

1. Verify /boot/config.txt contains these 2 lines:
dtparam=i2s=on
dtoverlay=merus-amp

Code: Select all
cat /boot/config.txt

2. Post result of:
Code: Select all
aplay -l
aplay -L
/srv/http/bash/mpd-data.sh


rern
Raspberry Pi 3B > SMSL M8 DAC
Raspberry Pi Zero W
Raspberry Pi 4B
GitHub
User avatar
rern
 
Posts: 555
Joined: 14 Jul 2016, 08:15

Re: Infineon Amp HAT support ?

Postby ceejayemm » Yesterday, 09:49

Rern

See below for the answers to your questions:

1. Verify /boot/config.txt contains these 2 lines:
dtparam=i2s=on
dtoverlay=merus-amp


Code: Select all
over_voltage=2
hdmi_drive=2
force_turbo=1
gpu_mem=32
initramfs initramfs-linux.img followkernel
max_usb_current=1
disable_splash=1
disable_overscan=1
dtparam=audio=off
dtparam=i2s=on
dtoverlay=merus-amp


aplay -l


Code: Select all
root@raamp1+R e3:~ # aplay -l
aplay: device_list:274: no soundcards found...


aplay -L


Code: Select all
root@raamp1+R e3:~ # aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)


/srv/http/bash/mpd-data.sh


Code: Select all
root@raamp1+R e3:~ # /srv/http/bash/mpd-data.sh
amixer: Mixer attach default error: No such file or directory
aplay: device_list:274: no soundcards found...
/srv/http/bash/mpd-devices.sh: line 51: ((: == 0 : syntax error: operand expected (error token is "== 0 ")

Invalid card number.
{ "devices":[{ "aplayname":"" , "card": , "device": , "dop":0 , "mixercount":1 , "mixermanual":"" , "mixertype":"software" , "name":" " , "hw":"" , "hwmixer":"" , "routecmd":"" }] , "mixerdevices":[""] , "audiooutput":"MERUS Audio Amp" , "audioaplayname":"merus-amp" , "autoplay":false , "autoupdate":false , "buffer":"" , "crossfade":0 , "ffmpeg":false , "mixertype":"software" , "mpd":true , "normalization":false , "reboot":"" , "replaygain":"off" , "usbdac":"" }


I hope these answers help.

Thanks

Chris
ceejayemm
 
Posts: 45
Joined: 29 Oct 2016, 18:13

Re: Infineon Amp HAT support ?

Postby ceejayemm » Yesterday, 11:36

Rern

I think I have found the problem. The new HAT was not supplied with any spacers to fit it to the PI Zero and I had simply push fitted the new board for testing. It would appear that the board was not seated correctly and/or shorting some of its underside connections of the PI power/ HDMI connectors. I have fitted some correct spacers, rebooted the boards now and I now get the following in answer to your earlier questions:

Code: Select all
root@raamp1+R e3:~ # aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: sndrpimerusamp [snd_rpi_merus_amp], device 0: Merus Audio Amp ma120x0p-amp-0 [Merus Audio Amp ma120x0p-amp-0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
root@raamp1+R e3:~ # aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
default:CARD=sndrpimerusamp
    snd_rpi_merus_amp, Merus Audio Amp ma120x0p-amp-0
    Default Audio Device
sysdefault:CARD=sndrpimerusamp
    snd_rpi_merus_amp, Merus Audio Amp ma120x0p-amp-0
    Default Audio Device
root@raamp1+R e3:~ # /srv/http/bash/mpd-data.sh
MERUS Audio Amp
{ "devices":[{ "aplayname":"merus-amp" , "card":0 , "device":0 , "dop":0 , "mixercount":4 , "mixermanual":"" , "mixertype":"software" , "name":"MERUS Audio Amp" , "hw":"hw:0,0" , "hwmixer":"A.Mstr Vol" , "routecmd":"" }] , "mixerdevices":["A.Mstr Vol","B.L Vol","C.R Vol","D.Lim thresh","F.Limiter Enable","G.Limiter Attck","H.Limiter Rls","I.Err flycap","J.Err overcurr","K.Err pllerr","L.Err pvddunder","M.Err overtempw","N.Err overtempe","O.Err pinlowimp","P.Err dcprot","Q.PM Prof","R.Power Mode"] , "audiooutput":"MERUS Audio Amp" , "audioaplayname":"merus-amp" , "autoplay":false , "autoupdate":false , "buffer":"" , "crossfade":0 , "ffmpeg":false , "mixertype":"software" , "mpd":true , "normalization":false , "reboot":"" , "replaygain":"off" , "usbdac":"" }


I do now seem able to access the MPD settings screen but I have not yet had time to check through its configuration, that will have to wait until later today.

Sorry for the earlier confusion..

Chris
ceejayemm
 
Posts: 45
Joined: 29 Oct 2016, 18:13

support RuneAudio Donate with PayPal


Return to Raspberry Pi

Who is online

Users browsing this forum: cmh714 and 14 guests
cron