I want to help but don't know how ))

Help wanted! How to contribute to RuneAudio project

Re: I want to help but don't know how ))

Postby ACX » 24 Feb 2015, 15:58

bastienauneau wrote:Is that because you mount SMB share locally, and then access it with ocal mounted ath only ?

Yes, we don't use MPD's internal mount method.

bastienauneau wrote:Also, trying to install SMB, with pacman -S samba, I get

:: samba and samba-rune are in conflict. Remove samba-rune? [y/N]
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: samba and samba-rune are in conflict

That's because we use a lightweight and custom version of smbd:
https://github.com/RuneAudio/RuneOS/blo ... e/PKGBUILD
User avatar
ACX
RuneAudio co-founder
 
Posts: 1680
Joined: 29 Nov 2013, 02:25
Location: Udine, Italy

Re: I want to help but don't know how ))

Postby bastienauneau » 09 Mar 2015, 19:34

Hi

Related to samba, I looked at the issue 13 on github
https://github.com/RuneAudio/RuneOS/issues/13

I whitnessed the same error as described. I did not find anything obvious, so I tried to build the latest 4.2.0. After removing lots of deprecated optons in ./configure, I stumbled on a make error
Code: Select all
                                                  : ok
Checking linker accepts -Wl,-no-undefined                                                       : yes
Checking linker accepts ['-undefined', 'dynamic_lookup']                                        : no
Checking linker accepts -Wl,--as-needed                                                         : yes
Checking for -lc not needed                                                                     : ok 
Checking configure summary                                                                      : ok
Checking compiler for PIE support                                                               : yes
Checking compiler for full RELRO support                                                        : yes
Checking for libsystemd-daemon                                                                  : yes
Checking for header systemd/sd-daemon.h                                                         : yes
Checking for library systemd-daemon                                                             : yes
Checking compiler accepts ['-fstack-protector']                                                 : yes
Checking linker accepts ['-fstack-protector']                                                   : yes
'configure' finished successfully (16m47.100s)
   Selected embedded Heimdal build
Checking project rules ...
Project rules pass
Unable to find build target matching make
==> ERROR: A failure occurred in build().
    Aborting...



I didnt manage to understand that, and tried to compare with other PKGBUILD on the net, but they all seam very complicated

Then I tried to install 4.2.0 with pacman, and realised it only take 34MB extra
Plus, considering the RPI 2 replacing the RPI, the cpu/mem gain may be less important (or no relevant anymore) compared to effort of supporting a custom build ? So it may be a good move to get back using default samba and smbclient ?

What do you think ?
bastienauneau
 
Posts: 17
Joined: 16 Jan 2015, 15:18

support RuneAudio Donate with PayPal

Previous

Return to Help the project

Who is online

Users browsing this forum: No registered users and 1 guest