HiFiBerry Amp ?

Raspberry Pi related support

HiFiBerry Amp ?

Postby d2000 » 08 Nov 2014, 12:19

Hi - i see that the HiFiBerry Dac works with runeaudio - but has anyone got the HifiBerry Amp up and running with it?

...the config instructions that i've found are for Raspbian - and am a bit lost with archlinux!

Cheers
d2000
 
Posts: 2
Joined: 08 Nov 2014, 12:10

Re: HiFiBerry Amp ?

Postby ACX » 08 Nov 2014, 12:34

We are going to officially support it in the near future.
In the meanwhile I invite anyone who is already using it to share here any useful information to let us integrate it quickier.
User avatar
ACX
RuneAudio co-founder
 
Posts: 1689
Joined: 29 Nov 2013, 02:25
Location: Udine, Italy

Re: HiFiBerry Amp ?

Postby d2000 » 09 Nov 2014, 22:17

Thanks ACX - I'll look forward to testing it out!
d2000
 
Posts: 2
Joined: 08 Nov 2014, 12:10

Re: HiFiBerry Amp ?

Postby pmoorhead » 24 Dec 2014, 13:37

anyone taken this on yet? I bought the hifiberry AMP too recently. great piece of kit. works with the rival player whose name I don't mention. I'm using raw MPD/MPC on Raspbian for now but it would be great to have Rune support it.
pmoorhead
 
Posts: 12
Joined: 11 Nov 2014, 21:58

Re: HiFiBerry Amp ?

Postby gregk » 19 Feb 2015, 22:18

This is how I got the original Hifiberry Amp for Raspberry Pi A/B working with RuneAudio 0.3 and RuneUI 1.3.

Steps 1-7 draw upon popov's post here: http://www.runeaudio.com/forum/rpi-b-plus-and-iqaudio-dac-plus-problems-t454-10.html#p3084.

Starting from a clean install:

1.

Code: Select all
pacman -Syu


2.

Code: Select all
pacman -S linux-raspberrypi


(If asked to resolve a conflict, choose "no")

3.

Code: Select all
pacman -S linux-raspberrypi-headers


4.

Code: Select all
nano /boot/config.txt


5. Change the last line to:

Code: Select all
kernel = kernel.img


6.

Code: Select all
nano /etc/modules-load.d/raspberrypi.conf


7. Replace the contents of raspberrypi.conf with:

Code: Select all
bcm2708-rng
#snd-bcm2835
snd_soc_pcm5102a
snd_soc_hifiberry_amp


8.

Code: Select all
nano /srv/http/app/templates/settings.php


9. Search ([CTRL] - [W]) for "hifiberry digi" and insert the following on a new line as the next entry:

Code: Select all
<option value="hifiberryamp" <?php if($this->i2smodule === 'hifiberryamp'): ?> selected <?php endif ?>>HiFiBerry Amp</option>


10.

Code: Select all
nano /srv/http/db/redis_acards_details


11. Search ([CTRL] - [W]) for "hifiberry digi" and insert the following on a new line as the next entry:

Code: Select all
$redis->hSet('acards_details', 'snd_rpi_hifiberry_amp', '{"sysname":"snd_rpi_hifiberry_amp","extlabel":"HiFiBerry Amp (I&#178;S)","mixer_numid":"1","mixer_control":"Playback Digital","hwplatformid":"01","type":"i2s"}');


12.

Code: Select all
nano /srv/http/app/libs/runeaudio.php


13. Search ([CTRL] - [W]) for "hifiberry digi" and insert the following on a new line as the next entry:

Code: Select all
        case 'hifiberryamp':
            sysCmd('modprobe bcm2708_dmaengine').usleep(300000);
            sysCmd('modprobe snd_soc_wm8804').usleep(300000);
            sysCmd('modprobe snd_soc_bcm2708_i2s').usleep(300000);
            sysCmd('modprobe snd_soc_pcm5102a').usleep(300000);
            sysCmd('modprobe snd_soc_hifiberry_amp');
            break;


14.

Code: Select all
reboot


The Hifiberry Amp is now an option on the "i2s kernel modules" dropdown on the "Settings" page. It's working for me, but make sure the volume isn't at 100% before testing output . . . .
gregk
 
Posts: 1
Joined: 19 Feb 2015, 20:44
Location: Cambridge, MA

Re: HiFiBerry Amp ?

Postby ACX » 19 Feb 2015, 22:39

gregk wrote:This is how I got the original Hifiberry Amp for Raspberry Pi A/B working with RuneAudio 0.3 and RuneUI 1.3.

Thank you for the detailed tips, I hope we find the time to test this personally next week...
User avatar
ACX
RuneAudio co-founder
 
Posts: 1689
Joined: 29 Nov 2013, 02:25
Location: Udine, Italy

Re: HiFiBerry Amp ?

Postby pmoorhead » 17 Mar 2015, 16:49

I tried this but couldn't get it to work.
If you include the first step pacman -Syu it breaks Runeaudio immediately - Nginx reports a 404 on the rune server pages after a restart.
If you skip that step and work through the rest, then all seems fine and Rune runs, you can select Hifiberry Amp as an option but... no sound.
If you log in and run aplay -l no sound cards are found.

If anyone has tried it and got it working, please let us know.
pmoorhead
 
Posts: 12
Joined: 11 Nov 2014, 21:58

Re: HiFiBerry Amp ?

Postby pkriek » 26 May 2015, 17:18

Hi

I have the same issue. Followed all the steps, and can select the amp,

but thats it,

any ideas?

Patrick
pkriek
 
Posts: 1
Joined: 26 May 2015, 17:16

Re: HiFiBerry Amp ?

Postby joshaspinall » 03 Jun 2015, 10:41

Hello,

I am keen for official support with the amp, as I have been hovering over the Buy button for a few weeks on one of these.

Watching the thread with interest.

J.
joshaspinall
 
Posts: 1
Joined: 03 Jun 2015, 10:38

support RuneAudio Donate with PayPal


Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 4 guests
cron