[SOLVED] Cannot connect to runeaudio.local

Raspberry Pi related support

[SOLVED] Cannot connect to runeaudio.local

Postby supertrogg » 16 Jan 2014, 15:17

Hi all,

I had high hopes for Rune Audio, given the flashy website but the reality of the situation is that rune audio.local cannot be contacted by its name, ip address or console! Any other version of Raspbian works fine but not this!
I have a Pi B, with nothing connected. The worrying aspect is that I can't even login via a console cable. The router has designated an ip address but Rune fails to use it.
Anyone have any ideas/suggestions for fault finding?
supertrogg
 
Posts: 15
Joined: 16 Jan 2014, 15:05

Re: Cannot connect to runeaudio.local

Postby ACX » 17 Jan 2014, 00:08

Hello supertrogg, everything leads me to think that something went wrong with the installation. Are you sure that it boots correctly? Have you tried to connect a HDMI monitor and a keyboard to see what happened? Let me know.
User avatar
ACX
RuneAudio co-founder
 
Posts: 1685
Joined: 29 Nov 2013, 02:25
Location: Udine, Italy

Re: Cannot connect to runeaudio.local

Postby supertrogg » 17 Jan 2014, 17:53

Thanks for the reply. I have tried a few times on different cards to install but keep getting the same results! Obviously it does work as others have succeeded. I'll have another go later tonight!
supertrogg
 
Posts: 15
Joined: 16 Jan 2014, 15:05

Re: Cannot connect to runeaudio.local

Postby ACX » 17 Jan 2014, 22:24

Let me know about that, it never happened to anyone before so it's really strange. It's worth to investigate the reason behind it.
User avatar
ACX
RuneAudio co-founder
 
Posts: 1685
Joined: 29 Nov 2013, 02:25
Location: Udine, Italy

Re: Cannot connect to runeaudio.local

Postby supertrogg » 18 Jan 2014, 12:00

Booted it up on a Pi A. Monitor, keyboard and wifi attached via monitors powered hub.
It gets to the "runeaudio login:"and just sits there. If I log in, eventually I get:
rpcbind: cannot create socket for udp6
rpcbind: cannot create socket for tcp6

Below the last line is just a blinking underscore until I hit Enter. Then nothing happens.

Tried it on a B.

The rpcbind messages come up as soon as the os does!
Nothing else happens.

I have tried two Edimax wifi adapters that work with every other distro I've tried.
Now hooked up via eth0, nothing, unless I ignore the dire warnings by going in as root and run dhcpcd eth0. At least it now gets an IP address and shows up on the router. However, audio.local and it's IP address results in nothing on a browser.

At this point I'm giving up on Rune as I spent far too much time already on something that is supposed to run out of the box.

Thanks for trying, ACX, but I'm going back to Raspbian and Squeezelite.
supertrogg
 
Posts: 15
Joined: 16 Jan 2014, 15:05

Re: Cannot connect to runeaudio.local

Postby ACX » 18 Jan 2014, 17:05

Please don't surrender at the first obstacle and lose your faith in our project :)
As we announced here, this is the first beta version of a new-born project, with temporary limited features (specifying that there was no Wi-Fi support yet). The purpose of beta releases is to test them and get useful feedbacks to fix problems, so nobody pretends that it has to run out of the box in the 100% of the cases.
I'm sorry that it didn't work for you, but you were kind to report your problem here and I thank you for that.
If you still are interested in your project, let me say that we are going to release the 0.2-beta (mind the -beta part :D) very soon.
User avatar
ACX
RuneAudio co-founder
 
Posts: 1685
Joined: 29 Nov 2013, 02:25
Location: Udine, Italy

Re: Cannot connect to runeaudio.local

Postby supertrogg » 20 Jan 2014, 11:42

Hi ACX,

Thanks for the reply. I will keep an eye out for beta 2!
supertrogg
 
Posts: 15
Joined: 16 Jan 2014, 15:05

Re: Cannot connect to runeaudio.local

Postby ACX » 20 Jan 2014, 12:40

supertrogg wrote:Hi ACX,

Thanks for the reply. I will keep an eye out for beta 2!

Just released! http://www.runeaudio.com/runeaudio-0-2-beta-released/
User avatar
ACX
RuneAudio co-founder
 
Posts: 1685
Joined: 29 Nov 2013, 02:25
Location: Udine, Italy

Re: Cannot connect to runeaudio.local

Postby supertrogg » 20 Jan 2014, 14:28

Hi ACX,

Thanks for the heads-up.
Its downloading as I type!
Will give it a go later on both the B and the A! The A has a HifiBerry DAC attached so that should be an interesting test! It works under Raspbian and Sqeezelite, happily playing 24/192 from Logitech Media Server on the B! :D
Hopefully it will be the same with Rune!
supertrogg
 
Posts: 15
Joined: 16 Jan 2014, 15:05

Re: Cannot connect to runeaudio.local

Postby bassiedt » 20 Jan 2014, 16:22

Just a suggestion as I am not running rune, but volumio (will switch when I find the time).

When I enter the following:
Code: Select all
netstat -tn

or
Code: Select all
netstat -l


It shows that mpd (port 6600) is using tcp6 (IP version 6). And also ssh protocol is using tcp6

I think that you may have switched off (or maybe unsupported) the support for IPV6 in your router.
bassiedt
 
Posts: 5
Joined: 18 Jan 2014, 11:19

support RuneAudio Donate with PayPal

Next

Return to Raspberry Pi

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 4 guests