USB-HDD not mounted

General discussion about RuneAudio. Do not post any support or feature requests here.

USB-HDD not mounted

Postby nixda » 02 Jun 2016, 09:14

Hi
after I re-installed rune, the usb-disk, that worked flawless in the past, is no longer recognized.
The little pop-up window* appears ("usb connected / disconnected") but it´s not shown in library or sources. ( i.e. usb stick works).
I tried different cables, rune 03 and 04, connecting before and after booting rune etc.
Of course automount is on.
What can I do to get this HD working with rune again?
What is the recommended time to connect usb-devices (before rune/raspi is powered or when it´s already running)?

big thx

[Setup is 3,5hdd 1TB + RB Pi3 + FiioE17]

* in the "connect" pop-up, there are tiny play/pause icons - to what?
nixda
 
Posts: 9
Joined: 04 May 2016, 09:52

Re: USB-HDD not mounted

Postby nixda » 03 Jun 2016, 16:29

not even this
nixda wrote:What is the recommended time to connect usb-devices (before rune/raspi is powered or when it´s already running)?


or this question
nixda wrote:* in the "connect" pop-up, there are tiny play/pause icons - to what?


can be answered by someone?

:|
nixda
 
Posts: 9
Joined: 04 May 2016, 09:52

Re: USB-HDD not mounted

Postby PeteB » 03 Jun 2016, 18:15

nixda wrote:What is the recommended time to connect usb-devices (before rune/raspi is powered or when it´s already running)?


There is no simple answer to this. Depends on the device. I leave USB WiFi and wireless kbd and remote dongles connected, and only connect/disconnect them with power off.

I connect flash drives any time, and RuneAudio has no issues with it.

My own 2.5" native usb 1TB Western Digital rotating HD has to be connected before power is turned on, and has to spin up during the normal Pi USB management sequence to be consistently recognized, but this is not universally the case. A WD "Pi" drive has a different startup, for example, and so does a typical portable USB HD.

If you have a 3.5" HDD as you posted above, your startup will be different from all of the ones I mentioned.

nixda wrote:* in the "connect" pop-up, there are tiny play/pause icons - to what?


I only get a popup with a check mark on the left, and the text "USB storage connected" or "...disconnected". No tiny icons.

Which RuneAudio image do you have?
PeteB
 
Posts: 421
Joined: 06 Feb 2016, 05:07

Re: USB-HDD not mounted

Postby hondagx35 » 03 Jun 2016, 21:44

Hi nixda,

nixda wrote:The little pop-up window* appears ("usb connected / disconnected")

You have a power issue, your HDD draws too much current.

nixda wrote:* in the "connect" pop-up, there are tiny play/pause icons - to what?

Normally the pop-ups disappear after a few seconds.
You can pause and restart the notifier with this icons (buttons).

Frank
User avatar
hondagx35
 
Posts: 3034
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: USB-HDD not mounted

Postby nixda » 04 Jun 2016, 08:51

thanks for the replies,
the 3,5" is with power supply (of course) and worked on the RB in the past (and always on pc)
I tried a 2,5" (without psu) and that works, too - actually only when connected before booting rune.
But RB get pretty warm (?)

I´ll try volumino, moode and older rune these days, just to see if the 3,5" hd stays invisible....

@PeteB
the tiny icons appear if you hit the pop-up ;)
nixda
 
Posts: 9
Joined: 04 May 2016, 09:52

Re: USB-HDD not mounted

Postby PeteB » 04 Jun 2016, 16:20

nixda wrote:@PeteB
the tiny icons appear if you hit the pop-up ;)

Ok, I found the tiny icons... who knew? Thanks, LOL.

Be careful adding USB devices with their own power supplies. They can be a conduit for enough noise to reduce your hi-fi to FM tuner quality.

I measured a significant increase in the noise floor as I started to connect other things via USB and ethernet. The worst by far turned out to be the HDMI port (known issue, apparently, but news to me... :roll: ), which I documented in a thread here, but a powered USB hub was not far behind.

noise-from-hdmi-port-pi2-hifiberry-dac-t3621.html
(I did not test a 3.5" drive)
PeteB
 
Posts: 421
Joined: 06 Feb 2016, 05:07

Re: USB-HDD not mounted

Postby albert6720 » 20 Jul 2016, 17:33

I have these unmounting issues at start then i check it to a tachnician who resolve the issue and now they working perfect from last three months.
albert6720
 
Posts: 6
Joined: 20 Jul 2016, 17:14

Re: USB-HDD not mounted

Postby vikassm73 » 16 Aug 2016, 11:38

Mounting and Unmounting happens if your File System is corrupt. In that case, connect HDD to any windows machine. If it has a problem, It will popup file system error Also It will help us to correct the same.
vikassm73
 
Posts: 4
Joined: 16 Aug 2016, 10:44

Re: USB-HDD not mounted

Postby Kassia » 21 Jan 2020, 07:23

Hello, I have met a similar situation, and my solutions are here, hope they can also help you:

1. Repair USB Root Hub:

Step1: Press Win+R and type devmgmt.msc and then open Device manager of your computer system.
Step2: Look for “Universal Serial Bus Controllers” and click on it to expand the list.
Step3: Now, search for “USB Root Hub” option and right click on it to select the properties.
Step4: After this, open “Power Management” option to uncheck the option “Allow the computer to turn off this device to save power” and press “OK”.

2. Re-install USB device driver


Step1: Go to Device Manager.
Step2: Search for the option “Universal Serial Bus Controllers”, right-click on “USB drivers”, and then click on “Update Driver Software”. Do this for all USB drivers by selecting them one by one.
Step3: Now, restart the computer system.

And I also met data loss on my hard drive, I used the Bitwar Data Recovery to recover my deleted files, if you also meet the issue, you can use this tool.
Really hope it can help you.
Kassia
 
Posts: 1
Joined: 21 Jan 2020, 07:08

Re: USB-HDD not mounted

Postby J4K » 25 Jan 2020, 11:15

Hi lnixda,

Just on the off chance, Connect your hdd to a computer and make sure that the Drive letter is still assigned. if not, then Assign the drive letter. I'm on rune 4 and occasionally rune/rpi will lose the drive letter and the usb drive will not show up in the Library.

J
J4K
 
Posts: 30
Joined: 25 Mar 2017, 21:20

support RuneAudio Donate with PayPal


Return to General discussion

Who is online

Users browsing this forum: No registered users and 3 guests