Schiit MODI DAC

Working DACs, USB dongles, ...

Schiit MODI DAC

Postby DustySeven » 11 Jun 2014, 19:12

Got my Schiit MODI in the mail today, works fantastic. To control volume from RUNE UI or MPD you do have to use software control.
DustySeven
 
Posts: 22
Joined: 10 Jun 2014, 02:18

Re: Schiit MODI DAC

Postby ACX » 12 Jun 2014, 11:11

I'm afraid I have bad news for you :(
I have the same DAC and it has big problems with the more recent kernel versions. It seems a sort of firmware compatibility issue, as it was working flawlessly with older kernels. Now I'm using a custom recompiled kernel:

Code: Select all
Linux studio 3.12.19-2-ARCH #1 PREEMPT Thu May 22 15:35:00 UTC 2014 armv6l GNU/Linux

and, while it works better that the one shipped with 0.2-beta with almost every USB and I2S DAC I personally tried, it makes the Modi unusable (the sound is completely distorted).

So the possible solutions could be:
1) use a older kernel (sic)
2) try to update the Modi's firmware. I don't know if it's possible but this tool could work to produce a fully working firmware. Sadly Schiit does not give support on Linux issues.
User avatar
ACX
RuneAudio co-founder
 
Posts: 1680
Joined: 29 Nov 2013, 02:25
Location: Udine, Italy

Re: Schiit MODI DAC

Postby DustySeven » 19 Jun 2014, 04:09

Interesting, I have had no issues what so ever with the 0.2 beta. It sounds amazing and there is no volume, distortion or any other issues whatsoever. I am using the Orion v2 kernel on the RUNE. strange that you have had issues. I hope you find out what is causing it.
DustySeven
 
Posts: 22
Joined: 10 Jun 2014, 02:18

Re: Schiit MODI DAC

Postby ACX » 19 Jun 2014, 17:30

With 0.2-beta everything works fine because it uses an older version of kernel, the problem shows with the more recent ones. Ah, I confirm you that OrionV2 is the best kernel profile with that DAC in my experience.
User avatar
ACX
RuneAudio co-founder
 
Posts: 1680
Joined: 29 Nov 2013, 02:25
Location: Udine, Italy

Re: Schiit MODI DAC

Postby DustySeven » 14 Jul 2014, 01:02

Just tried the .3 alpha and I see what you are talking about. Such a shame that it wont work on the new kernels. I highly ask that you try to find a fix. The MODI is an amazing DAC considering its price and makes a great choice with RUNE and Raspi for a low cost great sounding system.
DustySeven
 
Posts: 22
Joined: 10 Jun 2014, 02:18

Re: Schiit MODI DAC

Postby ACX » 14 Jul 2014, 12:50

I know because I own it and I cannot use it anymore :?
Such incompatibility between Modi's firmware and newer kernels is a true pity. I hope we can find a workaround for that...

EDIT: In the next release we are going to include also the old kernel (working with Modi), because we are realizing that it's almost impossible to cover all the possible cases with a single kernel version/config. So we are going to give the possibility to switch between kernels from the RuneUI (we already set up the switch function for the Wolfson Audio Card support in the Settings screen).
User avatar
ACX
RuneAudio co-founder
 
Posts: 1680
Joined: 29 Nov 2013, 02:25
Location: Udine, Italy

Re: Schiit MODI DAC

Postby Orion » 14 Jul 2014, 12:57

We can only provide the old kernel available via Kernel Switch feature.
I will integrate it in the next upcoming v0.3-alpha build.

Bye.
RuneAudio - Embedded Hi-Fi music player
SoloStereo - Alla riscoperta dell'alta fedeltà
User avatar
Orion
RuneAudio co-founder
 
Posts: 189
Joined: 29 Nov 2013, 02:03
Location: Udine, Italy

Re: Schiit MODI DAC

Postby DustySeven » 14 Jul 2014, 21:53

Thanks for the Reply Orion, as long as we have a way to use the MODI we are good. Cant wait to see what you guys have in store for beta release of .3
DustySeven
 
Posts: 22
Joined: 10 Jun 2014, 02:18

Re: Schiit MODI DAC

Postby Orion » 12 Aug 2014, 20:18

Hi Dusty even,
in these days I'm playing with the Schiit MODI DAC, borrowed by ACX.
I've found a little tweak to fix the issue with the MODI.

Since I'm working on the next image of RuneAudio, the kernel that I'm using is a little bit different from the one shipped with the 0.3-alpha, so I'm not 100% sure that this fix also work for you.

To solve the issue with your MODI, try this procedure:

1. connect on your RuneAudio player console (ssh)

2. stop mpd playback
Code: Select all
mpc stop


3. unload snd_usb_module
Code: Select all
rmmod snd_usb_audio


4. reload snd_usb_module with a different initialization
Code: Select all
modprobe snd-usb-audio nrpacks=1


5. start playback
Code: Select all
mpc play


Let me know if your MODI starts "to sing" as it should do.

Bye.
Simone.
RuneAudio - Embedded Hi-Fi music player
SoloStereo - Alla riscoperta dell'alta fedeltà
User avatar
Orion
RuneAudio co-founder
 
Posts: 189
Joined: 29 Nov 2013, 02:03
Location: Udine, Italy

Re: Schiit MODI DAC

Postby cmh714 » 14 Aug 2014, 17:06

to make the setting stick between reboots edit this file:
/etc/modprobe.d/modprobe.conf
cmh714
 
Posts: 393
Joined: 04 May 2014, 03:06

support RuneAudio Donate with PayPal

Next

Return to Compatibility list

Who is online

Users browsing this forum: No registered users and 1 guest