Issue running RuneAudio on BBB Rev. C from SD card

Beaglebone Black related support

Issue running RuneAudio on BBB Rev. C from SD card

Postby retrography » 25 May 2014, 06:45

I just downloaded and wrote the boot image to a micro SD card as per instructions. I insert it in my Beagle Bone, I hold the user boot button, and I plug in the power (tried USB from computer, USB connected to charger, and also 5v adapter connection). I have tried holding the user boot button for more than five minutes but Beagle Bone Black does not boot up. The power LED turns on and stays on, but user LEDs never turn on. Am I just being too impatient? How much time does it take for RuneAudio to boot from a Class 4 micro SD? What can be wrong with my boot process? Is there a way I can flash RuneAudio on eMMC or have Beagle Bone to boot from SD by default?
Posts: 2
Joined: 24 May 2014, 22:08

Re: Issue running RuneAudio on BBB Rev. C from SD card

Postby ACX » 26 May 2014, 00:03

Hi retrography, take a look at this post: did you do the same? The boot process is very quick on BBB anyway.
User avatar
RuneAudio co-founder
Posts: 1693
Joined: 29 Nov 2013, 02:25
Location: Udine, Italy

Re: Issue running RuneAudio on BBB Rev. C from SD card

Postby retrography » 07 Jun 2014, 07:02

I just managed to boot the BBB with a SD that I flashed using ApplePi-Baker instead of using the native dd command. I tried the same thing with Volumio, and their image definitely does not work! For some reason none of the two images (rune and volumio) work when I write them using dd.

Now Rune runs well on BBB. I confirm that I can keep browsing the DB while database is being updated over a SMB mount and I am listening to a 24bit/96khz flac file. CPU load remains at about 33%. I can also confirm that Rune plays nicely with HiFiMeDIY USB Sabre DACs.

Other issues I had to resolve:

1) Time Capsule CIFS mount

Once BBB booted, the new issue was to mount my Apple Time Capsule SMB Shares. I found some instructions here: and they worked. The point is to set the CIFS mount options manually. But then for some obscure reason RuneAudio distribution of Arch Linux fails to load the required libraries to mount SMB drives with UTF-8 encoding. Removing that mount option leaves us with: "rw,perm,sec=ntlm"

Note: I don't use User identification on my Time Capsule as mentioned in the post above. Instead, I use the TC in the default device password mode. I used the wireless network name as smb/cifs user name and the device password as cmb/cifs password and identification went on successfully.

Another note: Don't include the first slash in your remote directory name. Mine is: Data/Content/Music/Lossless. Writing it as /Data/... failed the mounting process.

2) Apple Lossless (ALAC) and ffmpeg

More than half of my music files are lossless encoded, and the majority of them in ALAC format. The fact that RuneAudio 0.2 disables ffmpeg by default trumps the whole idea of having a music server for me. To solve this issue follow these instructions:

Note: Before editing mpd.conf make all the required modifications to MPD settings in RuneUI. After changing mpd.conf you won't be able to use the graphical interface to manipulate MPD settings, and everything falls back to manual mode.

Unresolved issues:

1) All the lacking features

I am an ex-mopidy user. Obviously I miss the option to listen to internet radios, but more importantly the integration with Spotify and Google Play Music. Mopidy is a heavy/crashing/crumbling piece of software, while Rune seems to be developing on sound foundations. It is nimble and responsive and uses the minimum of resources. I just scanned a library of more than 25000 songs over a network drive with plenty of ALAC (that are supposed to crash ffmpeg). No issue at all. Also Rune plays nicely with MPD clients such as MPaD, which is not really the case with Mopidy. Still, I miss all those lost features.

2) Volume Control

RuneUI suggests keeping the volume control disabled. But when disabling the mixer, it does not push the mixer to 100% gain, so it the player gets stuck at the volume level right before disabling! Plus, I have noticed that disabling the mixer in RuneUI does not really disable ALSA Mixer. I can still change the volume using alsamixer in command line. If the objective is to get bitperfect audio, this should probably be either trumping it...

3) Views

Where is the artist view? Where is album view? How can I search for an album and then add the entire album to the playlist? These are all missing... The good news is that clients such as MPaD and Theremin offer these views. But without these RuneUI is toothless...

4) iOS integration

RuneUI doesn't manage to put Safari in full screen mode when we load it using a home screen icon. It does not have a proper website icon either.
The result is that it does not look nor feel like an application when loaded in iOS devices. Mopidy's skins all manage to do so...
Posts: 2
Joined: 24 May 2014, 22:08

support RuneAudio Donate with PayPal

Return to Beaglebone Black

Who is online

Users browsing this forum: No registered users and 0 guests