How to upgrade to newer MPD on raspberry pi B+?

General discussion about RuneAudio. Do not post any support or feature requests here.

How to upgrade to newer MPD on raspberry pi B+?

Postby jac » 30 Aug 2017, 05:00

Hi,

I am having an issue with streams encoded using aacp. I have a raspberry pi B+ and it is running Rune 0.3 Beta, which has mpd-rune v0.18.16-1

I read that mpd 0.18.17 and 0.19.2 have support for aac, so I was hoping those also had support for aacp. So I was wanting to upgrade the mpd to the mpd-rune-0.19.10-1-armv7h.pkg.tar.xz that's on the RUNE GITHUB site.

So, I downloaded the file and ran the update command, but it failed:

Code: Select all
 [root@runeaudio ~]# pacman -U mpd-rune-0.19.10-1-armv7h.pkg.tar.xz
loading packages...
error: failed to prepare transaction (package architecture is not valid)
:: package mpd-rune-0.19.10-1-armv7h does not have a valid architecture
 


Can someone help me with this please?

Thanks!
jac
 
Posts: 5
Joined: 27 Jan 2016, 19:13

Re: How to upgrade to newer MPD on raspberry pi B+?

Postby jac » 30 Aug 2017, 05:03

Duh... The Raspberry Pi B+ is of armv6l architecture, not armv7h!

Sigh... Anyone know where I can get an MPD-rune 0.18.17 that's packaged/compiled for armv6l?

Thanks!
jac
 
Posts: 5
Joined: 27 Jan 2016, 19:13

support RuneAudio Donate with PayPal


Return to General discussion

Who is online

Users browsing this forum: No registered users and 1 guest