[SOLVED] RaspTouch+RuneAudio / Walkthrough and Button Issue

Build/modify/repair equipment and improve systems performance by yourself

[SOLVED] RaspTouch+RuneAudio / Walkthrough and Button Issue

Postby fredsaule » 24 Dec 2016, 15:35

Hello Community,

I have recently aquired a Rasptouch from Audiophonics.fr + AUDIOPHONICS I-Sabre V3 DAC ES9023.


Very good deal, very good stuff.

I post for 2 reasons :
_ I wish to leave some info on how to make it work,
_ ask some help to finish my installation.

You can acquire a complete/working version of Rasptouch, but it's more fun to DIY.

I have followed the steps to build it, it's fairly simple and the result is very nice. The challenge comes when you want to setup the sd card.

I have chosen to go with Rune Audio.

_ I have downloaded the version RuneAudio_rpi2_rp3_0.4-beta_20160321_2GB.img.
_ Used Etcher-linux-x64.AppImage in order to flash my SD (I'm running Linux Ubuntu).
_ The next step is to get the first boot with the SD in the Rasptouch. You can expand the second partition to get more space / but that's optionnal)
_ probably you'll get 2 issues : the DAC is not recognized from RuneAudio + the screen is upside down.
_ stop the rasptouch, get SD card into your PC (or ssh on the Rasptouch ; logon with root/rune).
_ change the /boot/config.txt to this :

Code: Select all

dtoverlay=pi3-disable-bt-overlay   # UNCOMMENT THIS LINE

# Uncomment one of these lines to enable an audio interface
dtoverlay=hifiberry-dac         # AND THIS LINE TOO


# LCD settings
# 180 degrees
#lcd_rotate=2            # COMMENT THIS LINE
# Normal

_ Reboot - the DAC is in the menu MPD/"Audio output interface". Select "Hiffiberry DAC I²S". The screen is correct now.
_ you're ready to go !

... Almost. I'm left with the button issue.

The DIY kit is delivered with a nice button. the doc explains that it acts like GP022 at boot (the button should stop blinking when a script delivers a "boot complete" signal) and GPIO017 to execute the shutdown. this is where I need some help.

RuneAudio stands on ArkLinux - which I'm not top familiar with distro.

I understand that : a service (declared in /usr/lib/systemd/system/) will start a script that will run after boot until it receives the GPIO17 signal (from the button).

_ I have got to "gpio -g readall" to run on my RaspTouch.
_ But I'm not a scripter, so I would need some corrections on what I have implemented :

_ I have this script in /usr/lib/systemd/system/ :
Code: Select all
Description=Turns off the rpi



_ I have this script in /usr/bin/ :
Code: Select all
#Gestion du bouton d'alimentation
echo "Audiophonics Shutdown script starting..."
echo "Asserting pins : "
echo "ShutDown : GPIO17=in, set to Low"
echo "BootOK : GPIO22=out, set to High"
gpio -g mode 17 in
gpio -g write 17 0
gpio -g mode 22 out
gpio -g write 22 1
while [ 1 ]; do
if [ "$(gpio -g read 17)" = "1" ]; then
echo "ShutDown order received, RaspBerry pi will now enter in standby mode..."
sudo shutdown -h -P now
/bin/sleep 0.25
exit 0

It should be working... and it does not...

Thanks if you can help.

Last edited by fredsaule on 24 Dec 2016, 21:25, edited 1 time in total.
Posts: 2
Joined: 24 Dec 2016, 15:21

Re: RaspTouch+RuneAudio / Walkthrough and Button Issue

Postby fredsaule » 24 Dec 2016, 21:24

Actually, silly me!

There is a simple solution, which is to grab the RuneAudio image sitting there :


You'll still have to reverse the screen (/boot/config.txt)... but the button works just fine.

Posts: 2
Joined: 24 Dec 2016, 15:21

support RuneAudio Donate with PayPal

Return to DIY and tweaks

Who is online

Users browsing this forum: No registered users and 0 guests