MPD Down sample

Everything about Hi-Fi equipment

MPD Down sample

Postby osanto » 26 Apr 2016, 22:34

Hi,

I´m using RA with this setup:
Pi3 + DIGI+ - connected with SPDIF coax to my Anthem MR510

I found out that my receiver only accepts coax inputs samples up to 176.4 kHz (optical is less).

My problem is to find out why the MPD is not down sampling the 192K files, with those files my amp doesn´t recognize the music files.

What can I do to change this?

Thanks.
osanto
 
Posts: 30
Joined: 24 Mar 2016, 18:10
Location: Portugal

Re: MPD Down sample

Postby hondagx35 » 26 Apr 2016, 23:17

Hi osanto,

My problem is to find out why the MPD is not down sampling the 192K files

The problem is, that your DAC does not know anything about your AMP and its issues.

You can try to add:
format "96000:*:*"
to your mpd.conf file.
This will up/downsample all files to 96k.

Frank
User avatar
hondagx35
 
Posts: 3039
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: MPD Down sample

Postby osanto » 27 Apr 2016, 22:53

hondagx35 wrote:Hi osanto,

My problem is to find out why the MPD is not down sampling the 192K files

The problem is, that your DAC does not know anything about your AMP and its issues.

You can try to add:
format "96000:*:*"
to your mpd.conf file.
This will up/downsample all files to 96k.

Frank


Thanks for your help.
Where I can find the mpd.conf file? Using console.
Other thing, if my Receiver DAC suports samples up to 176.4 kHz, it should make more sense to limite the up/downsample to that value?
osanto
 
Posts: 30
Joined: 24 Mar 2016, 18:10
Location: Portugal

Re: MPD Down sample

Postby matlo74 » 28 Apr 2016, 15:18

Can enter this in SSH :

sudo nano /etc/mpd.conf

I did it for testing. It works but in Runaudio in the MPD menu I have now no access to the page but instead a message saying File /etc/mpd.conf was modified outside Player UI.
You can edit it manually or reset back to default settings.

I restarted MPD but no changes

Mat
matlo74
 
Posts: 34
Joined: 10 Apr 2016, 13:18

Re: MPD Down sample

Postby hondagx35 » 28 Apr 2016, 16:49

Hi Mat,

I have now no access to the page but instead a message saying File /etc/mpd.conf was modified outside Player UI.

This is not an error it is a feature.
Rune changes the configuration at boot.

hondagx35 wrote:You can try to add:
format "96000:*:*"
to your mpd.conf file.
This will up/downsample all files to 96k.

If you like to have this setting permanent, than try this:
- edit the file "/srv/http/db/redis_acards_details"
from
Code: Select all
$redis->hSet('acards_details', 'snd_rpi_hifiberry_digi', '{"sysname":"snd_rpi_hifiberry_digi","extlabel":"HiFiBerry Digi (I²S)","hwplatformid":"01","type":"i2s"}');

to
Code: Select all
$redis->hSet('acards_details', 'snd_rpi_hifiberry_digi', '{"sysname":"snd_rpi_hifiberry_digi","extlabel":"HiFiBerry Digi (I²S)","card_option":"format\t\"96000:*:*\"","hwplatformid":"01","type":"i2s"}');


- execute these commands:
Code: Select all
redis-cli del acards
php /srv/http/db/redis_acards_details


- reboot

Frank
User avatar
hondagx35
 
Posts: 3039
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: MPD Down sample

Postby matlo74 » 28 Apr 2016, 17:11

thanks frank
matlo74
 
Posts: 34
Joined: 10 Apr 2016, 13:18

Re: MPD Down sample

Postby osanto » 28 Apr 2016, 21:12

hondagx35 wrote:Hi Mat,

If you like to have this setting permanent, than try this:
- edit the file "/srv/http/db/redis_acards_details"


when i enter: /srv/http/db/redis_acards_details i have this msn:
"Audio Cards database initialized
[root@runeaudio ~]#"
It shouldn´t open the file?
osanto
 
Posts: 30
Joined: 24 Mar 2016, 18:10
Location: Portugal

Re: MPD Down sample

Postby hondagx35 » 28 Apr 2016, 21:21

Hi,

- edit the file "/srv/http/db/redis_acards_details"

Means:
Use an editor of your choice and open the file.
For example use nano:
nano /srv/http/db/redis_acards_details


Frank
User avatar
hondagx35
 
Posts: 3039
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: MPD Down sample

Postby osanto » 28 Apr 2016, 23:31

hondagx35 wrote:Hi,

- edit the file "/srv/http/db/redis_acards_details"

Means:
Use an editor of your choice and open the file.
For example use nano:
nano /srv/http/db/redis_acards_details


Frank


Thanks for everything. It worked!!!! Problem solved.
One doubt, with this settings all files will play at 96K, i can understand that a 190K file has to be down sample to play in my system, but why a 48K file has to be up sample? Do I have any advantage?

Once again, THANKS for your help.
osanto
 
Posts: 30
Joined: 24 Mar 2016, 18:10
Location: Portugal

support RuneAudio Donate with PayPal


Return to Hi-Fi systems

Who is online

Users browsing this forum: No registered users and 0 guests
cron