[BugFix] HiFiBerry DAC+ HW Volume (RuneAudio 0.3-beta)

Raspberry Pi related support

Re: [BugFix] HiFiBerry DAC+ HW Volume (RuneAudio 0.3-beta)

Postby Tom2112 » 29 Nov 2016, 04:21

hondagx35 wrote:This is a known issue, but nothing we can solve at the moment.
volume-control-linear-or-logarithmic-t254.html


So what would you recommend? Just use software volume control?

Does this affect all DACs? I'm experiencing it on my SainSmart SX400 (which pretends to be an IQaudIO DAC+).
Tom2112
 
Posts: 4
Joined: 19 Nov 2016, 16:57

Re: [BugFix] HiFiBerry DAC+ HW Volume (RuneAudio 0.3-beta)

Postby bloodnok » 12 Dec 2016, 03:22

matt wrote:Thanks for this, I got it to work this time.
I also find that the volume control is really only usable between 60 and 100, can we fix this or is it a hardware issue?


I have just released a hack for this. There is an executable for Pi model 1 which you can try.

https://github.com/marcmunro/MPD
bloodnok
 
Posts: 4
Joined: 16 Nov 2016, 02:03

Re: [BugFix] HiFiBerry DAC+ HW Volume (RuneAudio 0.3-beta)

Postby snafu » 10 Feb 2018, 19:35

Hmmm. When I run the "redis-cli.....", I get- "(interger) 0" displayed. Is that a good thing or a bad thing?
Then when I run the "refresh_ao" I get "command not found".
My guess is the refresh_ao error is a path related issue? Which folder does this command reside?

I'm using a HiFiBerry Dac+. It's working except the hardware volume control fails to work. Software enabled works, but it effects the sound quality. I'm hoping if I can get your command to work, it'll fix this.
snafu
 
Posts: 3
Joined: 10 Feb 2018, 03:02

Re: [BugFix] HiFiBerry DAC+ HW Volume (RuneAudio 0.3-beta)

Postby drfrink24 » 27 Mar 2019, 20:43

Hello,

I've tried all the suggestions here, and I can't get HW volume control to work with HifiBerry Dac+ Pro and Pi2, I think its related to the fact that I can't get the audio_output mpd.config, as shown below from the guide to match the same syntax.

Any ideas?

#expected output
audio_output {
name "snd_rpi_hifiberry_dacplus"
type "alsa"
device "hw:1,0"
mixer_control "Master"
mixer_type "hardware"
mixer_device "hw:1"
auto_resample "no"
auto_format "no"
enabled "yes"

#my output
audio_output {
name "snd_rpi_hifiberry_dacplus"
type "alsa"
device "hw:1,0"
mixer_control "Digital"
mixer_type "hardware"
mixer_device "hw:1"
auto_resample "no"
auto_format "no"
enabled "yes"
}

Entire dump:
Attachments
debug.zip
(19.67 KiB) Downloaded 55 times
drfrink24
 
Posts: 2
Joined: 16 Mar 2016, 16:29

Re: [BugFix] HiFiBerry DAC+ HW Volume (RuneAudio 0.3-beta)

Postby janui » 29 Mar 2019, 12:12

Hi drfrink24,
drfrink24 wrote:…I can't get HW volume control to work with HifiBerry Dac+ Pro…
I have the same DAC, no problems, it really does work. See this post for a possible solution: post26802.html This problem has been fixed in the latest version of 0.5b.
janui
User avatar
janui
 
Posts: 674
Joined: 20 Dec 2014, 12:55
Location: Ollanda

support RuneAudio Donate with PayPal

Previous

Return to Raspberry Pi

Who is online

Users browsing this forum: cmh714, Google [Bot] and 5 guests