Wolfson Audio Card patch for RuneAudio

Raspberry Pi related support

Wolfson Audio Card patch for RuneAudio

Postby saman » 13 Apr 2014, 21:39

You can try to use my patch for runeaudio
Patch contains a modified kernel with modules and other supporting files, including the necessary changes in runeaudio
It also includes support for hw and safe shutdown power-on-off module, described in attachment.

Download from:
http://www.element14.com/community/mess ... oad#109102

New 3.12RT21 kernel and patch (inform and download link): post990.html#p990


Scheme, PCB layout and photo power-on-off module:
Attachments
power_on_off_WAC.zip
SCH and PCB for shudown module
(179.52 KiB) Downloaded 613 times
Last edited by saman on 01 May 2014, 14:01, edited 5 times in total.
saman
 
Posts: 6
Joined: 13 Apr 2014, 21:32

Re: Wolfson Audio Card patch for RuneAudio

Postby ACX » 16 Apr 2014, 10:01

Hi saman, thank you very much for your contribution, this adds an important device in the list of working ones. Are you planning to mantain this regularly on future releases?
User avatar
ACX
RuneAudio co-founder
 
Posts: 1685
Joined: 29 Nov 2013, 02:25
Location: Udine, Italy

Re: Wolfson Audio Card patch for RuneAudio

Postby monochrome » 17 Apr 2014, 13:11

Hi Saman, many thanks for this. Small problem, after running the inst.sh script to apply the patch it renders the SDcard unbootable.
Any ideas?
Any possibility of making available a .img of a fully patched Rune installation?
Again, many thanks and warmest regards.
monochrome
 
Posts: 10
Joined: 17 Apr 2014, 13:09

Re: Wolfson Audio Card patch for RuneAudio

Postby saman » 21 Apr 2014, 18:47

I lost three hours of my time, to verify your claim, about how the system will not boot after applying the patch.
Everything I installed from scratch on a new SD card.
First RuneAudio_rpi_0.2-beta.img, then wolfson4runeaudio.tar.gz.
I did not find a problem, everything works as it should.
To install you must be root, you have to be in / for "tar xzvf wolfson4runeaudio.tar.gz" and running "inst.sh" and RPi must have access to the internet, due to update ALARM.
If it bothers you that it has no output to display, comment out the item in config.txt "hdmi_ignore_hotplug = 1" and execute "systemctl disable tv-off.service".
After the final reboot, you will login using ssh to RPi and run "/root /use_case_scripts/Playback_to_Lineout.sh".

Everything works, trust me, you're making a mistake somewhere.
saman
 
Posts: 6
Joined: 13 Apr 2014, 21:32

Re: Wolfson Audio Card patch for RuneAudio

Postby wildestpixel » 22 Apr 2014, 06:39

Hi forum,

Great image distribution and a good foray into me learning a bit of the "arch side".

Hi to Saman,

I can confirm as follows (with windows on my parent-client) :

[list=]Win32DiskImage runeaudio0.20 to a 8GB SD
copy Saman's patch to USB
putty or ssh in as root
goto the /mnt directory of USB, cp it to /
untar it there
run ./inst.sh[/list]

Nothing easier - and after a "reboot" command we are able to select wolfson audio card and run the relevant use_case_script from shell.

My only issue with rune audio is that on my NFS share its not picking up all the tracks in the database in the UI - those that are in the utmost subdirectories show - but those a level above are invisible - difficult to explain properley, but I also have ympd running on this distro and it catches ALL of the tracks in the UI (I set ympd as a systemd exec at boot). Hope this isn't evident in 0.3 / 1.3.
wildestpixel
 
Posts: 7
Joined: 22 Apr 2014, 06:32

Re: Wolfson Audio Card patch for RuneAudio

Postby monochrome » 22 Apr 2014, 12:11

Thanks for your responses and directions Saman & Wildestpixel.
Will examine my setup and retry - I'll grab a brand new SD card.
monochrome
 
Posts: 10
Joined: 17 Apr 2014, 13:09

Re: Wolfson Audio Card patch for RuneAudio

Postby monochrome » 22 Apr 2014, 12:51

OK - all working just fine now.
Two corrupted Sandisk 8GB SD cards!
Who knew.
Again, many thanks Saman for producing this patch and I apologise for the time lost double checking your work.
Warmest regards,
monochrome
 
Posts: 10
Joined: 17 Apr 2014, 13:09

Re: Wolfson Audio Card patch for RuneAudio

Postby wildestpixel » 22 Apr 2014, 18:20

So to extend the topic does anyone else experience rune not displaying all items in the dB ?
wildestpixel
 
Posts: 7
Joined: 22 Apr 2014, 06:32

Re: Wolfson Audio Card patch for RuneAudio

Postby monochrome » 23 Apr 2014, 02:02

Yes, but only for file types it is unable to render.
Assuming this is because ffmpeg is disabled by default.
More here post257.html?hilit=ffmpeg%20disabled#p257
monochrome
 
Posts: 10
Joined: 17 Apr 2014, 13:09

Re: Wolfson Audio Card patch for RuneAudio

Postby saman » 23 Apr 2014, 08:59

I added to the original post file photo a scheme for switching a safe shutdown RPi.
All the necessary software is already included in the patch.
saman
 
Posts: 6
Joined: 13 Apr 2014, 21:32

support RuneAudio Donate with PayPal

Next

Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 8 guests
cron