Synology NAS > how not to re-build library every day

Raspberry Pi related support

Synology NAS > how not to re-build library every day

Postby JetAir » 06 Aug 2019, 14:04

Synology NAS > how not to re-build library every day

Hello to all members and respect to the developers of this brilliant product!

I'm doing my first steps with RPI+DIGI equipment and RuneAudio is my first Linux- based media soft in my life. So excurse me if question is stupid. Searched forum but didn’t found answer(. So asking here.

setup: RPI3 B+ and HiFiberry Digi+ Pro. Connected to Burson 160D via coax. Network: home WiFi and Synology 414 NAS.

Bought and configured Pi+DIGI several days ago. Easy even for amateur like me.
Nevertheless, faces the issue with listening the music from my NAS device.
(Connection via login/password. No issues. Access to Music/ folder granted)

QUESTION:
After 1st time connection it showed NAS and empty music folder. I've pressed to update MPD library. This looks ligical.

issue:
Now I realized that when I turn Rune OFF/ON, folder is again empty. I'm doing build/update (it takes quite a lot of time (approx. 15mins for ~200GB) to make all folders and sub-folders visible). As soon as I turn off .... I need again to update and wait.

NAS is always working. Not in sleeping mode.


I'm 100% sure that it could be fixed somehow. Please advise how can I avoid every day update of library to have all albums visible. and what are the steps when I'll add more music to my NAS? Again re-update even if I've added 1 album?)


thxs!
Sources:
- LP: ProJect-1 Anniversary + phono Cambridge Audio 651P
- CD: Philips CD104
- Digital: Hifiberry DIGI+ PRO & NAS Synology DS414
- FM: Sony 3ES
DAC/Pre.Amp: Burson Audio 160D
Power Amp: QUAD 405-2
Acoustics: Celestion SL6 Signature
JetAir
 
Posts: 7
Joined: 06 Aug 2019, 13:46

Re: Synology NAS > how not to re-build library every day

Postby AndyF » 06 Aug 2019, 19:07

Hello JetAir,

some questions to get some infos about your setup:
- what Image did you flash to your MicroSD-Card? 0.5b? 0.5b with UIe pre-installed?
- how did you add your NAS as source - SMB/NFS?
- how do you switch off your RPi? Via menu?
- do you use StandardUI or UIenhanced (which is IMHO much better)?

The second question is easy to answer: You can update sub-folders via context-menu at library. Or you can update whole library at source-menu - it´s much faster after inital building.

Give 0.5b with pre-installed UIe a chance - Perhaps your first problem is gone after that.
http://www.runeaudio.com/forum/rune0-5-runeuie-pre-installed-t6847.html

regards, Andy
AndyF
 
Posts: 112
Joined: 02 Aug 2015, 07:36
Location: Germany - Bavaria

Re: Synology NAS > how not to re-build library every day

Postby janui » 06 Aug 2019, 20:23

Hi JetAir,
JetAir wrote:...Synology NAS > how not to re-build library every day...
In addition to the suggestions from AndyF I also have a question for you.
How do you shutdown your RuneAudio player?
I have a very similar setup which works without problems. But RuneAudio will save the MPD library only when you shutdown or reboot via the UI. If you just remove the power the MPD library will not be saved.
janui
User avatar
janui
 
Posts: 674
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: Synology NAS > how not to re-build library every day

Postby JetAir » 06 Aug 2019, 21:35

Dear Andy, many thanks for your reply and suggestions!!
My answers below are marked by color:

- what Image did you flash to your MicroSD-Card? 0.5b? 0.5b with UIe pre-installed?
> looks like I use "nude" version downloaded by the following link: runeaudio-0-5-beta-for-all-raspberry-pi-models-t6532.html
> I used version for 3B+ models. Answering your question about pre-installed ... honestly saying this was my first experience with ARM machines and I pray they it works and a bit afraid that changing the version will solve one problem, but add 1-2 new ones)

- how did you add your NAS as source - SMB/NFS?
> I use SMB/CIFS option. And SMB is allowed in NAS. As I shared in the very beginning, access itself was not a problem (I knew that Synology will let connect only via real user name/pass if "guest" is disabled.)

- how do you switch off your RPi? Via menu?
> YES. Definitely only via menu in my browser. After that I have only red diode working. Green light is not blinking/OFF .

- do you use StandardUI or UIenhanced (which is IMHO much better)?
> Std version. and proceed with the settings based on the forum and manuals.

The second question is easy to answer: You can update sub-folders via context-menu at library. Or you can update whole library at source-menu - it´s much faster after inital building.
> Here now is clear. But most critical is that after stop/start Library and Queue are empty again.


Give 0.5b with pre-installed UIe a chance - Perhaps your first problem is gone after that.
rune0-5-runeuie-pre-installed-t6847.html
> if I'll fail with MPD library > will try. But looks like current version fully match my demands as I need a pure and clean NAS>DAC transport with few settings and easy to drive interface. More over - looks like most users don't face such trouble.



thxs!!!!
Andrei
Sources:
- LP: ProJect-1 Anniversary + phono Cambridge Audio 651P
- CD: Philips CD104
- Digital: Hifiberry DIGI+ PRO & NAS Synology DS414
- FM: Sony 3ES
DAC/Pre.Amp: Burson Audio 160D
Power Amp: QUAD 405-2
Acoustics: Celestion SL6 Signature
JetAir
 
Posts: 7
Joined: 06 Aug 2019, 13:46

Re: Synology NAS > how not to re-build library every day

Postby JetAir » 07 Aug 2019, 09:30

Hi!!!!

janui wrote:How do you shutdown your RuneAudio player?
I have a very similar setup which works without problems. But RuneAudio will save the MPD library only when you shutdown or reboot via the UI. If you just remove the power the MPD library will not be saved.
janui


Always use "turn off" in browser's menu. That's why I'm a bit concerned why it not saving.
Interesting > where this library should be stored - on SD card? May be I should somehow make any changes directly in the code .... what makes me scared ... but ready to try))))
Sources:
- LP: ProJect-1 Anniversary + phono Cambridge Audio 651P
- CD: Philips CD104
- Digital: Hifiberry DIGI+ PRO & NAS Synology DS414
- FM: Sony 3ES
DAC/Pre.Amp: Burson Audio 160D
Power Amp: QUAD 405-2
Acoustics: Celestion SL6 Signature
JetAir
 
Posts: 7
Joined: 06 Aug 2019, 13:46

Re: Synology NAS > how not to re-build library every day

Postby janui » 07 Aug 2019, 12:25

Hi JetAir,
It is a bit of a mystery why it is not working. I see two possibilities, the MPD library database is not being stored or the NAS is connecting in a way that the connection is made, but the files are not immediately visible. First to answer your question:
JetAir wrote:...where this library should be stored...
It is here: /var/lib/mpd/mpd.db
All the settings for MPD (like the library database location) are generated automatically by RuneAudio and are saved in the file: /etc/mpd.conf
To work through the possible problems:
You can force the database to be saved by logging in via SSH and running the command:
Code: Select all
mpd kill
Then you can restart MPD with the following command:
Code: Select all
systemctl start mpd
Your library should still be available.
Try the following…
Shut down RuneAudio, switch off or disconnect your NAS from the network, restart RuneAudio, the library database file should be unchanged. Then you can then try switching on/reconnecting the NAS and wait about 15 minutes. It should then automatically remount. The question is whether the library will still be there? Could you report how this works out.
janui

PS Here is some documentation for SSH, for Windows: https://www.raspberrypi.org/documentati ... windows.md and for Linux/MacOS: https://www.raspberrypi.org/documentati ... sh/unix.md (user name: root, password: rune).
User avatar
janui
 
Posts: 674
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: Synology NAS > how not to re-build library every day

Postby JetAir » 07 Aug 2019, 21:42

Hello!

my first SSH connection happened)

let me share my actions step-by-step:
- Turn-on of Rune
- Check#1: Network mount > active. With green tick
- Check#2 of Library: Shows 1 network mounts ; EMPTY/No folders with music
- Action: Sources > Update MPD library
…… 15-30 mins was required to update and all music albums become visible. (it really should take so long?!)
- Check: 1 Mount + All folder visible

- Connected via SSH with commands (via PuTTY):
- Systemctl kill mpd >>> Music disappeared
- Systemctl start mpd >>> Music visible

- Reboot > and after F5 in browser …. 1 Network mount shown. Empty folder, no music.

After that I performed many other combinations, but the only what I see > after reboot/ turn off-on I can’t see the library.
and the only option to see it - execute Update/Rebuild library (by the way what is the difference?).

This is all what I know for now ((((((

and the question is why so many people easily connect, and I have issue where (potentially) shouldn't be an issue!)))))

any additional suggestions are more than welcome.

Andrei
Sources:
- LP: ProJect-1 Anniversary + phono Cambridge Audio 651P
- CD: Philips CD104
- Digital: Hifiberry DIGI+ PRO & NAS Synology DS414
- FM: Sony 3ES
DAC/Pre.Amp: Burson Audio 160D
Power Amp: QUAD 405-2
Acoustics: Celestion SL6 Signature
JetAir
 
Posts: 7
Joined: 06 Aug 2019, 13:46

Re: Synology NAS > how not to re-build library every day

Postby englishtim » 07 Aug 2019, 22:37

Hi JetAir,

Here are some more simple questions / things to try. These can all be done in the standard UIs - they don't need SSH:

  • Does MPD really completely forget the library on restart, or is it just very slow to refresh (i.e. several minutes)? There's a known issue - a workaround is here: rune-ui-is-slow-t6829-10.html#p28023
  • Do you Update or Rebuild the library?
  • In the MPD settings screen, what is your 'Auto Update' setting? Enabled or Disabled?
  • I assume you're using the latest version of Synology DSM (currently DSM 6.2.2-24922 Update 2 for both my DS212 and DS918+). Is the NAS generally responsive? Try installing something like foobar2000 on your PC, and pointing it at your NAS's music library - does the library refresh in only a few minutes? Do you have many other Synology apps running?
  • In DSM's Control Panel > File Services > Advanced, are SSDP and WS-Discovery activated?
  • In DSM's Control Panel > Indexing Service > Indexed Folder, is the 'music' folder set with File Type 'music'?
  • Do you have the Synology Drive Admin Console installed on your NAS? If so, is 'Intelliversioning' switched off? How many versions are set for the 'music' folder? (from memory I recall the default number is quite high - 32 or something like that). Try reducing the number to 4.

I hope this helps,

Peace and friendship,
englishtim
Synology DS918+ NAS >
  • Raspberry Pi 3 Model B+ > Behringer UCA202 >
    • Denon RCD-M38DAB > KEF Cresta II
    • Pro-Ject Head Box S > Sennheiser HD 650
  • Raspberry Pi 3 Model B > FiiO E10K > Sansui AU-317 > Celestion SL6
User avatar
englishtim
 
Posts: 40
Joined: 20 Feb 2015, 11:36
Location: Always European

Re: Synology NAS > how not to re-build library every day

Postby janui » 08 Aug 2019, 11:13

Thanks englishtim,
Excellent suggestions.

@JetAir
JetAir wrote:my first SSH connection happened
The actions which you carried out show that the MPD music library is created properly and is correctly saved. The only way I know which would delete the library contents is to mount the NAS with no music files present. I suspect that somehow the NAS is mounted correctly, but its contents only become visible after a delay.

Just to eliminate other potential problems, could you look in the Sources UI, click on your NAS mount, then in the NAS Mounts UI click on 'Advanced Options'. Could you report the value shown in the 'Mount flags' field?
janui
User avatar
janui
 
Posts: 674
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: Synology NAS > how not to re-build library every day

Postby JetAir » 08 Aug 2019, 23:16

Hello!!!

many thanks for advises. now checking. will be back with detailed answers.

Andrei
Sources:
- LP: ProJect-1 Anniversary + phono Cambridge Audio 651P
- CD: Philips CD104
- Digital: Hifiberry DIGI+ PRO & NAS Synology DS414
- FM: Sony 3ES
DAC/Pre.Amp: Burson Audio 160D
Power Amp: QUAD 405-2
Acoustics: Celestion SL6 Signature
JetAir
 
Posts: 7
Joined: 06 Aug 2019, 13:46

support RuneAudio Donate with PayPal

Next

Return to Raspberry Pi

Who is online

Users browsing this forum: cmh714, MSN [Bot] and 6 guests