RuneAudio+R e6

Raspberry Pi related support

Re: RuneAudio+R e6

Postby G0MJW » 25 Dec 2020, 15:07

Following yesterdays update my Pi zero W can no longer connect to the network. It tries briefly then I suspect crashes as it disappears from the network. I have no way to connect it to a wired network as I am away from home until the new year. It does not have a keyboard and monitor attached. All was well until yesterday. I can't download the new image as I don't have the bandwidth here and I can't log into it from my WiFi only laptop without the WiFi working. Is there any way to rescue this?

Mike
G0MJW
 
Posts: 2
Joined: 18 Nov 2020, 21:34

Re: RuneAudio+R e6

Postby cocogex » 25 Dec 2020, 15:44

Hello,

I'm currently running the 0.5 beta with Brutefir (see rune-audio-and-brutefir-convolver-for-roomcorrection-t1094-20.html) on my RPI3.
I'm happy with that but I'd like to upgrade to my RPI4 with the +Re6 version.

I succeeded in installing and running brutefir with the same config files as on my current RPI3. I have customized the file /srv/http/bash/mpd-conf.sh in order to set the mpd.conf file as required (my FIR filters are supposed to work at 88.2kHz):

Code: Select all
for (( i=0; i < cardL; i++ )); do
        card=${Acard[i]}
        dop=${Adop[i]}
        hw=${Ahw[i]}
        hwmixer=${Ahwmixer[i]}
        mixermanual=${Amixermanual[i]}
        mixertype=${Amixertype[i]}
        name=${Aname[i]}
        aplayname=${Aaplayname[i]}

########
        mpdconf+='

audio_output {
        type "pipe"
        name "brutefir pipe"
        command "/usr/bin/brutefir -nodefault /home/.brutefir.config" # 2>/dev/null"
        mixer_type "software"
        format "88200:32:2"
        enabled         "yes"
}'
done


I can play files, I do see the brutefir processes.

Code: Select all
RuneAudio:/home  #  ps -ef | grep mpd
upmpdcli   296     1  0 13:21 ?        00:00:10 /usr/bin/upmpdcli -c /etc/upmpdcli.conf
mpd       7806     1  0 14:20 ?        00:00:01 /usr/bin/mpd --no-daemon
root      7813     1  0 14:20 ?        00:00:00 /bin/bash /srv/http/bash/mpdidle.sh
root      7823  7813  0 14:20 ?        00:00:00 /bin/bash /srv/http/bash/mpdidle.sh
mpd       8468  7806  1 14:24 ?        00:00:00 /usr/bin/brutefir -nodefault /home/.brutefir.config
mpd       8513  8468 11 14:24 ?        00:00:01 /usr/bin/brutefir -nodefault /home/.brutefir.config
mpd       8514  8468 12 14:24 ?        00:00:01 /usr/bin/brutefir -nodefault /home/.brutefir.config
mpd       8516  8468  0 14:24 ?        00:00:00 /usr/bin/brutefir -nodefault /home/.brutefir.config
mpd       8517  8468  0 14:24 ?        00:00:00 /usr/bin/brutefir -nodefault /home/.brutefir.config
root      8581  7628  0 14:24 pts/0    00:00:00 grep --color=auto mpd


But when I stop any song the mpd is not responding anymore: indeed the brutefir processes are still alive and there is one in defunct.
Code: Select all
RuneAudio:/home  #  ps -ef | grep mpd
upmpdcli   296     1  0 13:21 ?        00:00:10 /usr/bin/upmpdcli -c /etc/upmpdcli.conf
mpd       7806     1  0 14:20 ?        00:00:02 /usr/bin/mpd --no-daemon
root      7813     1  0 14:20 ?        00:00:00 /bin/bash /srv/http/bash/mpdidle.sh
root      7823  7813  0 14:20 ?        00:00:00 /bin/bash /srv/http/bash/mpdidle.sh
mpd       8468  7806  0 14:24 ?        00:00:00 /usr/bin/brutefir -nodefault /home/.brutefir.config
mpd       8513  8468  9 14:24 ?        00:00:02 /usr/bin/brutefir -nodefault /home/.brutefir.config
mpd       8514  8468 10 14:24 ?        00:00:02 /usr/bin/brutefir -nodefault /home/.brutefir.config
mpd       8516  8468  0 14:24 ?        00:00:00 /usr/bin/brutefir -nodefault /home/.brutefir.config
mpd       8517  8468  0 14:24 ?        00:00:00 [brutefir] <defunct>
root      8647  7628  0 14:24 pts/0    00:00:00 grep --color=auto mpd


I have to kill all 5 of them and to restart the mpd service.

Thanks in advance for your help or tips and Merry Christmas to Rern how does an amazing job and to all Runeaudio users!

Charles.
cocogex
 
Posts: 8
Joined: 03 Nov 2017, 23:08

Re: RuneAudio+R e6

Postby GriffinUcos » 26 Dec 2020, 11:47

rastus wrote:
GriffinUcos wrote:Which files do I have to modify to get it operational? What information is required?

Maybe look here: https://github.com/rern/rAudio-1


Thanks, Rastus but I've read everything there that I can.

Can someone whose bluetooth works confirm that the distro picks up the bluetooth automatically? If that is the case then perhaps bluetooth is only enabled for the Raspis that have onboard bluetooth. I'm using a Pi 1 B+ with a usb dongle so maybe that's a dead end.

Kind regards
GriffinUcos
 
Posts: 13
Joined: 09 Dec 2020, 16:00

Re: RuneAudio+R e6

Postby AndyF » 26 Dec 2020, 12:13

Hi GriffinUcos,

I'm using RPi3 with rAudio-1. Bluetooth works fine at both directions.
Re6 won't get any updates - please post your problem to github.

Regards, Andy
AndyF
 
Posts: 151
Joined: 02 Aug 2015, 07:36
Location: Germany - Bavaria

Re: RuneAudio+R e6

Postby Ears of Tin » 26 Dec 2020, 15:41

I'm using the new rAudio https://github.com/rern/rAudio-1 and Bluetooth working great in both directions. Previously with Re6 I could only send phone>pi. Sometimes it helps to regenerate the list of bluetooth devices with the search icon in Networks setting page and select device from that list.

Edited to add I have RPi3 and RPi4 both with onboard BT. No dongles.
Ears of Tin
 
Posts: 58
Joined: 17 Dec 2018, 00:42

Re: RuneAudio+R e6

Postby GriffinUcos » 26 Dec 2020, 23:20

Ears of Tin wrote:I'm using the new rAudio https://github.com/rern/rAudio-1 and Bluetooth working great in both directions. Previously with Re6 I could only send phone>pi. Sometimes it helps to regenerate the list of bluetooth devices with the search icon in Networks setting page and select device from that list.

Edited to add I have RPi3 and RPi4 both with onboard BT. No dongles.


Thanks EoT. No response to the search icon so pretty sure it's the use of a BT dongle that isn't catered for. No worries I'll leave it for now.

Have a great New Year everyone.

Edited because the lower case h was annoying me. ;-))
Last edited by GriffinUcos on 27 Dec 2020, 10:37, edited 1 time in total.
GriffinUcos
 
Posts: 13
Joined: 09 Dec 2020, 16:00

Re: RuneAudio+R e6

Postby cmh714 » 27 Dec 2020, 06:09

@rern, any reason why fstab has the mounts set to "noauto"? Changing that to auto fixed my mounting issue where one NAS wasnt mounting automatically.......oddly enough both were set to noauto......now I have it at auto and all is well.

TY and Happy New Year!
cmh714
 
Posts: 450
Joined: 04 May 2014, 03:06

Re: RuneAudio+R e6

Postby Rijidij » 27 Dec 2020, 20:18

Hi @rern,
I have just installed the latest https://github.com/rern/rAudio-1 release. Many thanks, BT sink is now working for me.
However, I am unable to SSH onto my Pi4 using the creds from the docs. Have they changed for this release?

Thanks again.
Rijidij
 
Posts: 2
Joined: 27 Dec 2020, 18:43

Re: RuneAudio+R e6

Postby cycl157 » 27 Dec 2020, 20:32

Rijidij wrote:Hi @rern,
I have just installed the latest https://github.com/rern/rAudio-1 release. Many thanks, BT sink is now working for me.
However, I am unable to SSH onto my Pi4 using the creds from the docs. Have they changed for this release?

Thanks again.


See the readme -- default password is `ros`
cycl157
 
Posts: 16
Joined: 02 Jun 2020, 02:37

Re: RuneAudio+R e6

Postby Rijidij » 27 Dec 2020, 20:37

Thanks @cycl157
That will teach me to RTFM in future. :oops:
Rijidij
 
Posts: 2
Joined: 27 Dec 2020, 18:43

support RuneAudio Donate with PayPal

PreviousNext

Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 3 guests