RuneAudio+R e6

Raspberry Pi related support

RuneAudio+R e6 and Access point

Postby cedefe » 18 Nov 2020, 21:18

Hello,
I would like to use RuneAudio+Re6 without any network access and I try to activate the Access point "RuneAudio" function but I did not succeed.
The access point does not always appear in the list of accessible networks of the client machine.
When it finally appears, after several restarts of RueAudio, it does not stay there for long and I had to hurry to grab the wifi key:" RuneAudio". Finally, without knowing why, I managed to connect the client machine to the "RuneAudio" access point. I specify that my initial connection was made with an RJ45 Ethernet link. to be able to enter parameters.
I got stuck at this point because it was impossible for me to connect neither with the IP address "http://192.168.5.1", nor by "http: // RuneAudio /", except once, this which I more managed to reproduce.
Of course, I have several times left with a new download and a blank configuration, without success. I use a Raspberry Pi 3 B + and a HifiBerry Digi Pro card on the GPIO connector.
Did you encounter this problem on this version of RuneAudio? Did you succeed ?

RPI 3B+ and HifiBerry Digi Pro and RuneAudio+R e6
cedefe
 
Posts: 1
Joined: 18 Nov 2020, 20:52

Re: RuneAudio+R e6

Postby G0MJW » 18 Nov 2020, 21:40

I had the same problem earlier, where were the playlists. Sorting it was easy enough I saved a playlist with a name and used the find command. Let's say the playlist is called Mix

find / -name "Mix"

ought to do the job.


RuneAudio:~ # find / -name "Mix"
/srv/http/data/playlists/Mix


Mike
G0MJW
 
Posts: 1
Joined: 18 Nov 2020, 21:34

Re: RuneAudio+R e6

Postby haddock » 21 Nov 2020, 13:29

I'm trying to use RuneAudio+R e6 on a Rpi 3B+ with an Allo Piano 2.1 dac. Not all that easy.
First thing i did was updating RuneAudio. No problem, After that Selecting the Piano 2.1 dac and rebooting went smoothly. Music files were found on an inserted USB stick. But no sound coming from the dac. Opening the mpd tab is not possible. RuneAudio displays the flashing logo.
Unselecting the piano 2.1 dac is also possible. RuneAudio appears to be running correctly.
The dac is ok, as it works with the fork Volumio, but I prefer RuneAudio (running older version for years now).
Any suggestions how to proceed?
Rpi 3B+, Allo Piano 2.1, RuneAudio+R e6
haddock
 
Posts: 3
Joined: 21 Nov 2020, 13:10

Re: RuneAudio+R e6

Postby bink » 21 Nov 2020, 14:22

haddock wrote:I'm trying to use RuneAudio+R e6 on a Rpi 3B+ with an Allo Piano 2.1 dac. Not all that easy.
First thing i did was updating RuneAudio. No problem, After that Selecting the Piano 2.1 dac and rebooting went smoothly. Music files were found on an inserted USB stick. But no sound coming from the dac. Opening the mpd tab is not possible. RuneAudio displays the flashing logo.
Unselecting the piano 2.1 dac is also possible. RuneAudio appears to be running correctly.
The dac is ok, as it works with the fork Volumio, but I prefer RuneAudio (running older version for years now).
Any suggestions how to proceed?

i have the same problem with a kali reclocker in between.

i think it has to do with the kernel but not sure if this same problem is also for runeaudio .
for now I'm using runeaudio over raspberry pi 4 with a musical fidelity m1 usb dac until this problem is solved

i am using a raspberry pi 3b for the kali and piano 2.1.

https://audiophilestyle.com/forums/topi ... nt-1090411
bink
 
Posts: 4
Joined: 21 Nov 2020, 14:11

Re: RuneAudio+R e6

Postby klassikmann » 21 Nov 2020, 14:26

Update R+Re6 20201121

Update successful (image file 20201108, boot, update, restore backup).
Up to now one minor issue (but could be my fault): Using Bluetooth as sender not possible, sink found but no connection.

klassikmann
RPI 3B + HifiBerry Digi+ Pro + RuneAudio+R e6
klassikmann
 
Posts: 181
Joined: 27 Apr 2016, 18:36

Re: RuneAudio+R e6

Postby rern » 21 Nov 2020, 14:33

@haddock and @bink,

Please try the updated image files from the first post.
- RPi 4, 3, and 2: kernel 5.4.77
- RPi 1 and Zero: kernel 5.4.72 (5.4.77 has some issues with onboard audio.)

By the way, anyone with a character LCD, please try them as well. (System > GPIO Devices)

rern
RuneAudio+R @ github.com/rern
Raspberry Pi 4B
Raspberry Pi 3B > SMSL M8 DAC
Raspberry Pi Zero W
User avatar
rern
 
Posts: 668
Joined: 14 Jul 2016, 08:15

Re: RuneAudio+R e6

Postby klassikmann » 21 Nov 2020, 14:44

rern wrote:...
- RPi 4, 3, and 2: kernel 5.4.77
...

Here 5.4.74:
Code: Select all
RuneAudio:~  #  uname -a
Linux runeaudio 5.4.74-1-ARCH #1 SMP PREEMPT Wed Nov 4 16:43:09 UTC 2020 armv7l GNU/Linux

klassikmann
RPI 3B + HifiBerry Digi+ Pro + RuneAudio+R e6
klassikmann
 
Posts: 181
Joined: 27 Apr 2016, 18:36

Re: RuneAudio+R e6

Postby rern » 21 Nov 2020, 15:00

@klassikmann,

The updated image files. Still hot right from the oven.

rern
RuneAudio+R @ github.com/rern
Raspberry Pi 4B
Raspberry Pi 3B > SMSL M8 DAC
Raspberry Pi Zero W
User avatar
rern
 
Posts: 668
Joined: 14 Jul 2016, 08:15

Re: RuneAudio+R e6

Postby haddock » 21 Nov 2020, 15:06

rern wrote:@haddock and @bink,

Please try the updated image files from the first post.
- RPi 4, 3, and 2: kernel 5.4.77
- RPi 1 and Zero: kernel 5.4.72 (5.4.77 has some issues with onboard audio.)

By the way, anyone with a character LCD, please try them as well. (System > GPIO Devices)

rern


Thanks rern, works now.
Rpi 3B+, Allo Piano 2.1, RuneAudio+R e6
haddock
 
Posts: 3
Joined: 21 Nov 2020, 13:10

Re: RuneAudio+R e6

Postby ceejayemm » 21 Nov 2020, 16:45

@Rern

Just updated Pi3B+ to RE6 20201121 (from 20201108) but kernel on system page and via uname -a still reports 5.4.70-1-ARCH. Rebooted, still the same:

uname -a
Linux runeaudio 5.4.70-1-ARCH #1 SMP PREEMPT Wed Oct 7 15:34:50 UTC 2020 armv7l GNU/Linux

Regards

Chris
ceejayemm
 
Posts: 119
Joined: 29 Oct 2016, 18:13

support RuneAudio Donate with PayPal

PreviousNext

Return to Raspberry Pi

Who is online

Users browsing this forum: cmh714 and 9 guests