RuneAudio+R e5

Raspberry Pi related support

Re: RuneAudio+R e5

Postby ceejayemm » 12 Sep 2020, 18:34

Hi

It appears that by default NFS clients connect to an NFS server using the 'Nobody' user account.

Thus adding 'rw' to the NFS mount Options in the RA Source section and giving the 'Nobody' user on my NAS Server read/write access to my music library folder was sufficient to allow the new Album/Coverarts update process to run successfully.

There may well be other, better, solutions to this issue and if anybody knows what they are I would be happy to give it a try but for now it seems to work for me.

Regards.

Chris
ceejayemm
 
Posts: 86
Joined: 29 Oct 2016, 18:13

Re: RuneAudio+R e5

Postby R101 » 12 Sep 2020, 19:33

Hi rern,

The 20200912 changes have disabled "hide cover art band in tracks view" in Library-Playlist Options. This is a useful feature for small screens.
(Pi 4B, RuneAudio+R e5, JLS I2S over USB)
R101
 
Posts: 305
Joined: 29 Apr 2016, 16:16

Re: RuneAudio+R e5

Postby jsouza » 13 Sep 2020, 17:32

After my unsuccessful attempt to use +R e4, I decided to try again with e5. I have two RPi setups, one Pi 2 Model B, one Pi 3 Model B+, both with same PiHAT DAC (HiFiBerry+). The Pi 2 B is connected to a NAS over Ethernet. The Pi 3 B+ has a USB hard drive connected. I burned e5 20200912 to micro SD cards and immediately updated each to the latest, which was 20200913. Chose the correct DAC, which also disabled on-board audio, and turned off the mixer/set No Volume for Bit Perfect playback. Rebuilt the library (first time library build) on the Pi 3 B+. I have about 37,000 songs and the library build took about two hours. When that was completed, played back some audio as a test. Everything seemed to work great. Had a completely different experience on the Pi 2 B, just like last time with e4. Went through the same initial/configuration steps, and started a library rebuilt. Let that run overnight, and this morning the library was still being updated, according to the UI anyway. Shutdown the Pi via the UI, cut the power to the device for a few seconds, turned power back on, and can no longer connect to the device. What seems to have happened is that library rebuild became hung, and perhaps the device did not cleanly shut down, and now it won't boot anymore. The difference between my two setups is that the successful one is the faster, more recent Pi device. The successful one is connected to a local USB drive, not NAS over the network. The Pi 2 has only 100Mbps Ethernet, so perhaps that is a factor, although unlikely, I would think. Another difference is that my NAS has files other than audio files, and perhaps the library rebuild has issues with non-audio files? I seem to recall that I had that same issue a few years back when I tried Volumio. It had problems with non-audio files in the library.
jsouza
 
Posts: 6
Joined: 02 Mar 2016, 21:31

Re: RuneAudio+R e5

Postby R101 » 13 Sep 2020, 19:29

Thanks for today's fixes, rern. The current version is working well for me.

A minor bug is that radio stations sometimes stop showing cover art and revert to the meter gif. Switching to another station and back again restores normal working, but it does not happen often enough to pinpoint a cause.
(Pi 4B, RuneAudio+R e5, JLS I2S over USB)
R101
 
Posts: 305
Joined: 29 Apr 2016, 16:16

Re: RuneAudio+R e5

Postby jsouza » 13 Sep 2020, 21:37

I have an update of the problem with my RPi 2 pointed at my NAS. I reburned the image to the SD card and went through the exact same setup steps as before. This time, however, I created a new share on the NAS that contains only my 24-bit FLAC files, far fewer files than the entire NAS contains and almost completely FLAC files. The library was updated rather quickly and I was successfully able to play some files. I will next add another share on the NAS that contains my 16-bit FLAC files (CD rips), update the library, and try playing some of those. I have many thousands of 16-bit FLAC files so I am expecting the library update to take some time, if it is successful. I'll post another update later with the results.
jsouza
 
Posts: 6
Joined: 02 Mar 2016, 21:31

Re: RuneAudio+R e5

Postby jsouza » 14 Sep 2020, 01:35

Adding a NAS share that contains only my 16-bit FLAC files was successful. This tells me that some of the non-audio files if I add the root share of the NAS are causing the problem. Perhaps the library building code could be updated to ignore non-audio files. If you need me to investigate further and/or gather some logs, let me know.
jsouza
 
Posts: 6
Joined: 02 Mar 2016, 21:31

Re: RuneAudio+R e5

Postby yeowds » 14 Sep 2020, 07:36

rern wrote:Hi Roland,

I've just tried a fresh R+R e5, Spotify is running fine.

Try:
1. Reflash the SD card.
2. Don't update, setup or restore anything, just enable Spotify.
3. Connect Spotify from the app on your device.
4. If it's OK, disconnect Spotify and do the update otherwise post the status.
5. Reconnect Spotify.
6. If it's not OK, post the status.
7. Disconnect Spotify and setup audio device, nothing else. Don't restore from backup.
8. Reconnect Spotify.
-----------------------------------------------------------------------

@yeowds

Setup your HifiBerry Dac+ Pro with System > I2S Module

rern


@rern

Hi,

Sorry for the late reply. Just to update that it could be the HifiBerry DAC+ Pro card that is faulty. Was instructed to test with
HifiBerry OS and it too had issues. Will update when I receive the replacement card and test it.

BTW, Yes, I2S module was selected as HifiBerry DAC+ pro.

Thanks Rern ! Keep up the good work !

Regards,
Yeow
yeowds
 
Posts: 3
Joined: 04 Sep 2020, 14:52

Re: RuneAudio+R e5

Postby rern » 14 Sep 2020, 17:03

Update 20200914

Anyone who had trouble updating, please download the latest image files from the 1st post. They include this latest update.

rern
RuneAudio+R @ github.com/rern
Raspberry Pi 4B
Raspberry Pi 3B > SMSL M8 DAC
Raspberry Pi Zero W
User avatar
rern
 
Posts: 630
Joined: 14 Jul 2016, 08:15

Re: RuneAudio+R e5

Postby BVLabs » 15 Sep 2020, 09:59

Hello! I would like to express my deepest gratitude for the fact that you support the development of this excellent project! You are doing a very big and necessary job, guys. Your version is currently the most practical one to work with. I wish you all the best and good luck! Sorry for my French :)
BVLabs
 
Posts: 2
Joined: 26 Sep 2016, 06:30

Re: RuneAudio+R e5

Postby matt » 17 Sep 2020, 06:14

Ok, so I'm still having problems with cover art.
I have installed the update and made sure that RA has write permissions with my NAS.
The albums tab shows only the RA logo for each album and no cover art.....but if I open up an album the cover art is shown. If I click on the cover art and then choose update thumbnail the coverart appears in the album directory....but it doesnt work for all albums many come up with the message 'no coverart found' even though the coverart is in the folder, shows up when I open the album and shows on the playback page.
I can see in the folders where it has worked that RA has written 2 files - Coverart and Thumb.
I have tried updating the database several times, nothing changes
This is doing my head in ! :lol:

I also dont really want to have to go through 1300 albums individually to get the coverart showing (or not).
I'm getting ready to give up on coverart and just access everything through the NAS tab. That would be a shame , coverart is a great feature.
Can anybody help me. please
Pi 3b+
RA+R e5 latest update
Synolgy NAS
User avatar
matt
 
Posts: 99
Joined: 09 Sep 2014, 21:57
Location: Bay of Plenty, New Zealand

support RuneAudio Donate with PayPal

PreviousNext

Return to Raspberry Pi

Who is online

Users browsing this forum: cmh714 and 13 guests