RuneAudio+R e5

Raspberry Pi related support

Re: RuneAudio+R e5

Postby daoane » 06 Sep 2020, 16:25

I can confirm RonaldBlaze's observation. I have a similar setup with USB DAC and disabled on-board audio.

1. Flash latest image, change audio to USB DAC and activate spotifyd - everything ok.
2. Disable onboard audio, reboot. No covers, RuneAudio generally unresponsive.
3. Enable onboard audio, reboot. Everything ok again.

This problem did not occur with the image that I downloaded on Sunday, 30th August. I occurred the first time during the update to this image.
daoane
 
Posts: 3
Joined: 02 Sep 2020, 14:00
Location: Sweden

Re: RuneAudio+R e5

Postby matt » 07 Sep 2020, 03:52

Hi,
I am having problems with coverart.
I have around 1100 albums on a synology nas. All of these show up under the album tab in the library but only 410 show in cover art.
also many of the 410 in the coverart tab don't actually show any art just the rune icon.
All Albums contain .jpg files labelled cover, front or folder.
There are examples of all of these differently labelled .jpgs showing up under cover art and also not showing up. I can't see any consistent pattern.

I'm using a pi 3 B+ and the latest updated version of Re5.
Synology NAS, wired LAN,
Any help greatly appreciated.
Cheers
User avatar
matt
 
Posts: 99
Joined: 09 Sep 2014, 21:57
Location: Bay of Plenty, New Zealand

Re: RuneAudio+R e5

Postby rern » 07 Sep 2020, 09:11

@matt,

Browse by CoverArt and Album are going to be unified. Browse by Album will display coverarts from directories of each album. Thumbnails of the coverarts will be placed directly in each directory. So write permission is required.

rern
RuneAudio+R @ github.com/rern
Raspberry Pi 4B
Raspberry Pi 3B > SMSL M8 DAC
Raspberry Pi Zero W
User avatar
rern
 
Posts: 630
Joined: 14 Jul 2016, 08:15

Re: RuneAudio+R e5

Postby matt » 08 Sep 2020, 21:01

rern wrote:@matt,

Browse by CoverArt and Album are going to be unified. Browse by Album will display coverarts from directories of each album. Thumbnails of the coverarts will be placed directly in each directory. So write permission is required.

rern


ok. thanks
User avatar
matt
 
Posts: 99
Joined: 09 Sep 2014, 21:57
Location: Bay of Plenty, New Zealand

Re: RuneAudio+R e5

Postby R101 » 08 Sep 2020, 21:30

Hi rern,

After the 20200904 update, I find playlist entries are not being played in order, and previous/next buttons jump to random tracks in the playlist.
(Pi 4B, RuneAudio+R e5, JLS I2S over USB)
R101
 
Posts: 305
Joined: 29 Apr 2016, 16:16

Re: RuneAudio+R e5

Postby matt » 09 Sep 2020, 05:27

Hi again,
loving this version thanks for all your hard work.
I have come across another issue which I'm pretty sure I haven't had in previous versions of rune.
Some albums have the tracks repeated. For example an album may have 12 songs on it which are displayed correctly and numbered 1-12 then they are listed again as 13-24 . Exactly the same songs, all 24 songs will play. There is definitely only 12 songs in the file.
I have checked to see if its a tagging error, it doesnt seem to be.
pi 3b+
20200904 update installed
cheers
User avatar
matt
 
Posts: 99
Joined: 09 Sep 2014, 21:57
Location: Bay of Plenty, New Zealand

Re: RuneAudio+R e5

Postby yeowds » 10 Sep 2020, 16:21

@rern

Thanks for the suggestion. I actually did that but I believe the fault could be the Hifiberry Dac+ Pro card. I contacted Hifiberry and we went through the steps to diagnose ie. Installing Hifiberry OS, testing it on my 2nd Pi4, sending the logs, etc. They have agreed to send me a replacement card which I shall update the outcome once I have it. Thanks again!
yeowds
 
Posts: 3
Joined: 04 Sep 2020, 14:52

Re: RuneAudio+R e5

Postby ceejayemm » 12 Sep 2020, 10:22

@rern

I have applied today's update (20200912) which although the changelog says only 'Bug Fixes' you have obviously released the change to the Coverarts setup (to merge the Album and Coverarts data) you mentioned earlier in this thread. Has anything else changed and should this have been noted in the changelog too ?

The problem I have now is how to modify my Sources NFS settings in RA to have read/write access to my NAS based share ? The NFS share provided by my NAS (OMV5.x) is definitely configured on that server to have read/write access but when mounted in RA shows the directory setup, for example, as:

drwxrwsr-x+ 5 1001 100 4096 Jul 24 09:15 'Dire Straits'

I can obviously read the music files stored on the NFS share but can't write to it. I presumably need to add some 'options' to the Source NFS settings in RA but what should I add ? I have tried 'uid=0,guid=0' and 'uid=1001,gui=100' to no avail.

Thanks

Chris
ceejayemm
 
Posts: 86
Joined: 29 Oct 2016, 18:13

Re: RuneAudio+R e5

Postby klassikmann » 12 Sep 2020, 10:56

Hi Chris,

perhaps I can help.
My NAS is OMV5.x also but I use CIFS not NFS. What I did:
  1. The CIFS share must not be configured as read-only (obviously).
  2. In the OMV "Access Rights Management"->"Shared Folders"->"Privileges" I configured read-only for "guest" and "read-write" for my OMV account and the corresponding group.
  3. In RA->Sources I mount the share with my OMV credentials ("username=<uid>,password=<passwd>")
IIRC that's all what I did to enable write-access in RA

Regards
klassikmann

ceejayemm wrote:@rern

I have applied today's update (20200912) which although the changelog says only 'Bug Fixes' you have obviously released the change to the Coverarts setup (to merge the Album and Coverarts data) you mentioned earlier in this thread. Has anything else changed and should this have been noted in the changelog too ?

The problem I have now is how to modify my Sources NFS settings in RA to have read/write access to my NAS based share ? The NFS share provided by my NAS (OMV5.x) is definitely configured on that server to have read/write access but when mounted in RA shows the directory setup, for example, as:

drwxrwsr-x+ 5 1001 100 4096 Jul 24 09:15 'Dire Straits'

I can obviously read the music files stored on the NFS share but can't write to it. I presumably need to add some 'options' to the Source NFS settings in RA but what should I add ? I have tried 'uid=0,guid=0' and 'uid=1001,gui=100' to no avail.

Thanks

Chris
RPI 3B + HifiBerry Digi+ Pro + RuneAudio+R e5
klassikmann
 
Posts: 162
Joined: 27 Apr 2016, 18:36

Re: RuneAudio+R e5

Postby R101 » 12 Sep 2020, 11:11

I see from the final lines of the update info that random=on. This is probably why my tracks are played in the wrong order, but how do I turn it off? Are the random and shuffle buttons supposed to toggle?

(Edit: Just to clarify, I am asking how to do this from the GUI. I have cleared it using mpc.)
(Pi 4B, RuneAudio+R e5, JLS I2S over USB)
R101
 
Posts: 305
Joined: 29 Apr 2016, 16:16

support RuneAudio Donate with PayPal

PreviousNext

Return to Raspberry Pi

Who is online

Users browsing this forum: cmh714 and 10 guests