RuneAudio+R e4

Raspberry Pi related support

Re: RuneAudio+R e4

Postby klassikmann » 20 Jul 2020, 12:10

rern wrote:
klassikmann wrote:Please give some insight about the functionality of "Add similar" (last year renamed from "Lastfm playlist"). Every time I try this function I get
Code: Select all
Playlist - Add Similar
Track not found.
btw. I don't use playlists at all.

It gets a list of similar tracks from Last.fm, like similar artists in Bio page, then try to find the tracks in Library. If founded, add them to Playlist.
Get a list:
Code: Select all
# artist and title can be changed
artist='M83'
title='Echoes Of Mine'
key=ba8ad00468a50732a3860832eaed0882
wget -qO - "http://ws.audioscrobbler.com/2.0/?method=track.getsimilar&artist=$artist&track=$title&api_key=$key&format=json" | jq .similartracks | awk -F '"' '/"name"/ {print $4}'
rern

I got it. Thank you.

klassikmann
RPI 3B + HifiBerry Digi+ Pro + RuneAudio+R e6
klassikmann
 
Posts: 181
Joined: 27 Apr 2016, 18:36

Re: RuneAudio+R e4

Postby Sonic » 20 Jul 2020, 17:11

Made a discovery concerning the sometime problem of not being able to access the system page, and possibly the recently reported webradio issue.

Following a recent update (20200717), I discovered I could no longer access the system page again. After trying a full MPD database rebuild and reboot, I still couldn’t open the system page.
So I then remotely accessed the ‘/srv/http/data/webradios’ directory and deleted all the containing files, and then checked that library Webradio icon showed no containing files.
Having not previously empted ‘/mnt/MPD/Webradio’ directory after importing my webradio files for the first time. I simply reimported the files using the import webradio addon, went back to the menu – and lo and behold, up pops the system page.

To make sure this wasn’t a fluke, I tried updating again with the next update (20200718). Same situation – update, no access to the system page, delete all files in the ‘/srv/http/data/webradios’ directory, import the files again via the webradio addon… bingo – up pops the system page.

I don’t know whether deleting and reimporting the webradio files after an update will resolve the reported issues some are having with webradio files. But mine are working.

Hope this helps

Best... Sonic
RPi3B+ > Allo DigiOne Signature > Audiolab M-DAC
RPi3B+ > HiFiBerry Digi+ Pro > Cambridge Audio DACMagic+
Sonic
 
Posts: 9
Joined: 22 Mar 2020, 01:01

Re: RuneAudio+R e4

Postby ceejayemm » 20 Jul 2020, 17:46

Rern

It appears that the Merus-Amp is not being loaded:

root@raamp1+R e4:~ # aplay -l
aplay: device_list:274: no soundcards found...

root@raamp1+R e4:~ # /srv/http/bash/mpd-data.sh | jq .
amixer: Mixer attach default error: No such file or directory
aplay: device_list:274: no soundcards found...
/srv/http/bash/mpd-devices.sh: line 34: ((: == 0 : syntax error: operand expected (error token is "== 0 ")
Invalid card number.
parse error: Expected value before ',' at line 1, column 46

/boot/config.txt

over_voltage=2
hdmi_drive=2
force_turbo=1
gpu_mem=32
initramfs initramfs-linux.img followkernel
max_usb_current=1
disable_splash=1
disable_overscan=1
dtparam=audio=off
dtparam=i2s=on
dtoverlay=merus-amp

I hope this helps.

Chris
ceejayemm
 
Posts: 130
Joined: 29 Oct 2016, 18:13

Re: RuneAudio+R e4

Postby klassikmann » 20 Jul 2020, 18:21

Update Re4 20200720

@rern
Update still not possible.

Code: Select all
wget -qN --no-check-certificate https://github.com/rern/RuneAudio-Re4/raw/master/install.sh
chmod 755 install.sh

./install.sh u "master"

.  Update RuneAudio+R e4 ...

.  Get files ...

.  Install new files ...
bsdtar:
Error opening archive: Failed to open '.zip'
bsdtar: Error opening archive: Failed to open '.zip'

cp: cannot stat '/tmp/install/*'
: No such file or directory

Duration 00:01
.  Done.

How can I help?

klassikmann
RPI 3B + HifiBerry Digi+ Pro + RuneAudio+R e6
klassikmann
 
Posts: 181
Joined: 27 Apr 2016, 18:36

Re: RuneAudio+R e4

Postby klassikmann » 20 Jul 2020, 19:23

Now I started with a fresh installation using the image file from page 1:
Successful update to 20200720!
Issues regarding "Update thumbnails" and "Edit webradio" resolved.

FWIW: This update started with
Code: Select all
./install.sh rre4 Update master
The unsuccessful one with "
Code: Select all
./install.sh u "master"


My guess: I had some days ago an update from the UPDATE channel. Perhaps this update prohibits following master updates.

klassikmann

klassikmann wrote:Update Re4 20200720

@rern
Update still not possible.

Code: Select all
wget -qN --no-check-certificate https://github.com/rern/RuneAudio-Re4/raw/master/install.sh
chmod 755 install.sh

./install.sh u "master"

.  Update RuneAudio+R e4 ...

.  Get files ...

.  Install new files ...
bsdtar:
Error opening archive: Failed to open '.zip'
bsdtar: Error opening archive: Failed to open '.zip'

cp: cannot stat '/tmp/install/*'
: No such file or directory

Duration 00:01
.  Done.

How can I help?

klassikmann
RPI 3B + HifiBerry Digi+ Pro + RuneAudio+R e6
klassikmann
 
Posts: 181
Joined: 27 Apr 2016, 18:36

Re: RuneAudio+R e4

Postby Beelzebassie » 20 Jul 2020, 21:35

Had the same error as Klassikmann, wrote a fresh image, and now I cannot make contact with my NAS via NFS.

When I try to mount, Rune adds quotation marks to the IP-address: 192.168.1.10 becomes "192.168.1.10
Raspberry Pi 3B (rev. 1.2) | Allo DigiOne | RME ADI-2 DAC FS
Beelzebassie
 
Posts: 56
Joined: 09 Nov 2014, 12:16

Re: RuneAudio+R e4

Postby R101 » 20 Jul 2020, 22:43

I also get the same update failure as klassikmann.
(Pi 3B, rAudio-1, JLS I2S over USB)
R101
 
Posts: 342
Joined: 29 Apr 2016, 16:16

Re: RuneAudio+R e4

Postby Garrido33 » 21 Jul 2020, 00:05

rern wrote:
Garrido33 wrote:Update 20200718

Return of an issue previously fixed : when trying to open system settings, the Runeaudio page flashes indefinitely (both on touch screen and web interface).

Please post result of:
Code: Select all
/srv/http/bash/system-data.sh | jq .

rern


Just tried it and I got an error message:
Code: Select all
cat: /srv/http/data/addons/rre4: No such file or directory
parse error: Expected value before ',' at line 1, column 1361


Garrido33
Garrido33
 
Posts: 20
Joined: 07 Mar 2019, 18:49

Re: RuneAudio+R e4

Postby jaygothard » 21 Jul 2020, 02:27

Just installed RuneAudio+R e4 using the DIY method. things went smoothly and I was happy to see that it is running MUCH faster than e3 did. I cannot tell you how many minutes I spent staring at the pulsating "Rune Audio" logo while moving between screens before I gave up, but it was a lot.

The sound quality seems good, at least on my headphones and all of my music was easy to find and update, but I have found two issues. One minor and the other a potential deal breaker.

1. Using the Chrome browser on my PC I don't have the Library and queue tabs unless I enable "bars on small screen". All is well on my PC, but if I use my phone I cannot use swiping. So if "bars on small screen" is selected I get tabs on both my PC and phone and if I de-select it I don't get tabs in either place.

2. I cannot mount a NAS share. I enter all of the pertinent information and then nothing happens. The information that I am using works on other MPDs including earlier version of Rune, but no luck in this version. I searched the forum and someone else had the same issue. He said he was able to mount the NAS manually, but I'm not sure how to do that.
jaygothard
 
Posts: 18
Joined: 06 May 2020, 19:19

Re: RuneAudio+R e4

Postby steffe » 21 Jul 2020, 08:23

I updated from the regular RuneAudio 0.3-beta to this version. The update was very easy and the system works nicely, but I have an issue with Spotify. I edited /etc/spotifyd.conf with my username and password, and I can see that spotifyd is active. The problem is that I cannot find, in the RuneAudio interface, where to select the music from Spotify. In the old system I had a place in the central tab to switch from MDP to Spotify, and also in the Library tab there was an icon I could click to access Spotify playlists. Now I just cannot find any way to access Spotify. Probably it's a silly issue, but I would appreciate if anyone could help.
Thanks.
steffe
 
Posts: 2
Joined: 21 Jul 2020, 08:13

support RuneAudio Donate with PayPal

PreviousNext

Return to Raspberry Pi

Who is online

Users browsing this forum: cmh714 and 2 guests