RuneAudio+R e4

Raspberry Pi related support

Re: RuneAudio+R e4

Postby vaughan » 30 Jun 2020, 10:50

klassikmann wrote:Beforehand I wanted to backup my settings (System menu -> Backup/Restore Settings). But the resulting backup.xz was in fact a HTML
klassikmann


FWIW I get that too - my backup.xz contains '404 Not Found' etc.

Vaughan
vaughan
 
Posts: 20
Joined: 02 May 2020, 16:26

Re: RuneAudio+R e4

Postby R101 » 30 Jun 2020, 12:08

Thanks rern. The interface also seems faster now.

The only problem I have seen is the disabled volume control randomly appearing on the playback page. Refreshing the browser gets rid of it, but I can't work out what makes it appear, or which setting hides it. It is greyed out in the playback page settings, not blank like the other tick-boxes.

Would it be possible to have all the library icons the same colour? The Webradio one looks odd alongside the coloured bookmark icons.
(Pi 4B, RuneAudio+R e6, JLS I2S over USB)
R101
 
Posts: 335
Joined: 29 Apr 2016, 16:16

Re: RuneAudio+R e4

Postby rern » 30 Jun 2020, 15:00

vaughan wrote:
klassikmann wrote:Beforehand I wanted to backup my settings (System menu -> Backup/Restore Settings). But the resulting backup.xz was in fact a HTML
klassikmann


FWIW I get that too - my backup.xz contains '404 Not Found' etc.

Some files in coverarts directory have names with certain characters that cannot be correctly translated for archiving.
For the time being, try moving the coverarts to somewhere else then backup normally.

rern
RuneAudio+R @ github.com/rern
Raspberry Pi 4B
Raspberry Pi 3B > SMSL M8 DAC
Raspberry Pi Zero W
User avatar
rern
 
Posts: 670
Joined: 14 Jul 2016, 08:15

Re: RuneAudio+R e4

Postby Garrido33 » 30 Jun 2020, 15:18

Hi Rern,

The problem with the settings is solved with the new image files.

Thanks,
Garrido33
Garrido33
 
Posts: 20
Joined: 07 Mar 2019, 18:49

Re: RuneAudio+R e4

Postby ceejayemm » 30 Jun 2020, 17:24

Rern

There must be something else causing the backup problem. I emptied the coverarts folder before trying to make a backup and it still failed. I have attached the resulting backup file for you to see.

Chris
Attachments
backup (2).zip
(274 Bytes) Downloaded 58 times
ceejayemm
 
Posts: 125
Joined: 29 Oct 2016, 18:13

Re: RuneAudio+R e4

Postby Reliang268 » 01 Jul 2020, 03:27

Smooth installation good job. I have 2 issue:
1. When playback DSD dsf file, touching the volume will output a sort of white noise and no more music. No more DSD file can be play. At the MPD menu the volume control also cannot touch as it will cause DDS cannot play (no music output only noise)
2. Wifi country is 00 which is why the 5G wifi cannot be found. How to set the default wifi country? Temporary I use "iw reg set SG" to set the wifi country. Thanks KM
Reliang268
 
Posts: 7
Joined: 01 Jul 2020, 03:07

Re: RuneAudio+R e4

Postby rern » 01 Jul 2020, 04:43

vaughan wrote:...
I have one question about adding an album to the playlist - I'm not sure whether it's working as designed or there's a problem. I have a directory containing all the tracks from two albums (CD1 and CD2). If I view, say, CD1 and click the button to add the whole album to the playlist the message says that it is adding CD1 to the playlist, but in fact it addss the contents of the whole directory (both CD1 and CD2) to the playlist. Is this what is intended, or not?
...

NAS, SD and USB are directory based browsings, Your CD1 and CD2 must be placed in separate ones.

vaughan wrote:... on the announcement there is a reference to a simple HTTP Streamer - how is that invoked? I haven't been able to find it.
...

Settings > System > Streamer

klassikmann wrote:Issue in RuneAudio+R e4 20200628

I tried to install the new image file. Beforehand I wanted to backup my settings (System menu -> Backup/Restore Settings). But the resulting backup.xz was in fact a HTML:
Code: Select all
<html>
<head><title>404 Not Found</title></head>
<body>
<center><h1>404 Not Found</h1></center>
<hr><center>nginx/1.19.0</center>
</body>
</html>

I had to generate a manual backup.
...

Fixed. To be released with next update.

R101 wrote:...
Would it be possible to have all the library icons the same colour? The Webradio one looks odd alongside the coloured bookmark icons.

Bookmarks are important enough to be ones in the first place. They're even displayed with coverarts when available. It's odd to try to make them otherwise.
Anyway, yoy can long-press > replace them with any images with colors you like.

rern
RuneAudio+R @ github.com/rern
Raspberry Pi 4B
Raspberry Pi 3B > SMSL M8 DAC
Raspberry Pi Zero W
User avatar
rern
 
Posts: 670
Joined: 14 Jul 2016, 08:15

Re: RuneAudio+R e4

Postby R101 » 01 Jul 2020, 11:59

Bookmarks are important enough to be ones in the first place. They're even displayed with coverarts when available. It's odd to try to make them otherwise.
Anyway, yoy can long-press > replace them with any images with colors you like.


Sorry, but I am not sure what you mean, rern. The first icon in my library is for Webradio, which I cannot edit or change. The other icons are bookmarks for my NAS and a USB stick, which have the default coloured star + text.
(Pi 4B, RuneAudio+R e6, JLS I2S over USB)
R101
 
Posts: 335
Joined: 29 Apr 2016, 16:16

Re: RuneAudio+R e4

Postby rern » 01 Jul 2020, 12:28

Reliang268 wrote:...
1. When playback DSD dsf file, touching the volume will output a sort of white noise and no more music. No more DSD file can be play. At the MPD menu the volume control also cannot touch as it will cause DDS cannot play (no music output only noise)
2. Wifi country is 00 which is why the 5G wifi cannot be found. How to set the default wifi country? Temporary I use "iw reg set SG" to set the wifi country. ...

1. If your DAC is capable of DSD playback, it's very likely that your DAC needs DoP enabled: Settings > MPD > DSD over PCM - enable
(Note: Hardware volume - may need to be set at 100 or set mixer control to none.)
2. Regulatory domain setting - next update.

R101 wrote:
Bookmarks are important enough to be ones in the first place. They're even displayed with coverarts when available. It's odd to try to make them otherwise.
Anyway, yoy can long-press > replace them with any images with colors you like.


Sorry, but I am not sure what you mean, rern. The first icon in my library is for Webradio, which I cannot edit or change. The other icons are bookmarks for my NAS and a USB stick, which have the default coloured star + text.

Long-press any bookmarks to show detete, edit and thumbnail icons then tap the thumbnail.

rern
RuneAudio+R @ github.com/rern
Raspberry Pi 4B
Raspberry Pi 3B > SMSL M8 DAC
Raspberry Pi Zero W
User avatar
rern
 
Posts: 670
Joined: 14 Jul 2016, 08:15

Re: RuneAudio+R e4

Postby R101 » 01 Jul 2020, 12:57

Long-press any bookmarks to show detete, edit and thumbnail icons then tap the thumbnail.


I understand that, rern, but it does not work on the Webradio icon, which is not a bookmark.
(Pi 4B, RuneAudio+R e6, JLS I2S over USB)
R101
 
Posts: 335
Joined: 29 Apr 2016, 16:16

support RuneAudio Donate with PayPal

PreviousNext

Return to Raspberry Pi

Who is online

Users browsing this forum: Bing [Bot], cmh714 and 6 guests