RuneAudio 0.5-beta for most Raspberry Pi models

Raspberry Pi related support

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby jlynton » 18 Sep 2018, 15:17

janui wrote:Hi jlynton,
try: http://runeaudio.local or http://runeaudio. or http://runeaudio
janui

Thanks again Janui, but none of those work.
jlynton
 
Posts: 49
Joined: 20 May 2016, 12:53

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby MidnightExpress » 18 Sep 2018, 16:07

Hi janui,
janui wrote:Great, could you post the output of the following command:
Code: Select all
smartctl /dev/sda -d sat -H -i
I can then work out how to disable the messages when no actual disk is present.

I try to attach a file, however, it keeps saying "The extension xxx is not allowed." no matter what extension is. Even if the file does not have an extension, still no luck. So, here is the output of running the mentioned command:
Code: Select all
smartctl /dev/sda -d sat -H -i

===== output =====

smartctl 6.6 2017-11-05 r4594 [armv7l-linux-4.14.34-1-ARCH] (local build)
Copyright (C) 2002-17, Bruce Allen, Christian Franke, www.smartmontools.org

Read Device Identity failed: scsi error no medium present

A mandatory SMART command failed: exiting. To continue, add one or more '-T permissive' options.


As advised by the previous command
smartctl /dev/sda -d sat -H -i -T permissive

===== output =====

smartctl 6.6 2017-11-05 r4594 [armv7l-linux-4.14.34-1-ARCH] (local build)
Copyright (C) 2002-17, Bruce Allen, Christian Franke, www.smartmontools.org

Read Device Identity failed: scsi error no medium present

=== START OF INFORMATION SECTION ===
Device Model:     [No Information Found]
Serial Number:    [No Information Found]
Firmware Version: [No Information Found]
Device is:        Not in smartctl database [for details use: -P showall]
ATA Version is:   [No Information Found]
Local Time is:    Tue Sep 18 22:33:33 2018 HKT
SMART support is: Ambiguous - ATA IDENTIFY DEVICE words 82-83 don't show if SMART supported.
SMART support is: Ambiguous - ATA IDENTIFY DEVICE words 85-87 don't show if SMART is enabled.
A mandatory SMART command failed: exiting. To continue, add one or more '-T permissive' options.
Hope it helps.

MidnightExpress
Pi3b+, Ver. Experimental Beta 0.5 20180903, ES9018K2M Dac
MidnightExpress
 
Posts: 12
Joined: 04 Aug 2018, 12:19

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby R101 » 18 Sep 2018, 17:29

rlsten wrote:
janui wrote:
rlsten wrote:...I don't know how to change the zoom level on the new image to fit on my tiny screen. With midori I could edit /root/.config/midori/config to change the zoom level. Is there a similar file for Chromium that I can access, or is there some other way to change the zoom level?
I do not have a touchscreen, so cannot test this. There seems to be two routes to do this, via Chromium start-up settings and via XORG settings. The Chromium start-up method looks the most promising.

Chromium start-up settings:
The start-up settings are included in this file: /etc/X11/xinit/start_chromium.sh
Documentation concerning the settings is here: https://peter.sh/experiments/chromium-c ... -switches/
The options which look most interesting are:
    --ash-host-window-bounds
    --force-device-scale-factor
    --content-shell-host-window-size
    --window-size
    --app-shell-host-window-size
    --enable-use-zoom-for-dsf



Hi janui,

As you suggested [Thanks very much!], the Chromium start-up settings in /etc/X11/xinit/start_chromium.sh
are the answer. Specifically, changing

Code: Select all
chromium --app=http://localhost --start-fullscreen --force-device-scale-factor=1.8
to
Code: Select all
chromium --app=http://localhost --start-fullscreen --force-device-scale-factor=.5


worked for the 2.8" Adafruit screen.

I suspect that a scale-factor of .7 would be about right for a 7" screen.

Thanks again,
Rod


At the moment, I still prefer 0.4b with rern's addons for daily use, but I also have 0.5b on a Pi2 with 7" touch screen. The default settings have the top and bottom bars in the right place on the screen, but I do have a problem with the zoom levels of the library/playback/playlist pages, which are too large.

In my installation, changes to the entry in /etc/X11/xinit/start_chromium.sh makes no difference I can see.
(Pi 4B, RuneAudio+R e6, JLS I2S over USB)
R101
 
Posts: 321
Joined: 29 Apr 2016, 16:16

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby janui » 18 Sep 2018, 18:27

Hi MidnightExpress,
MidnightExpress wrote:Hope it helps.
Yes, this is great.
janui
User avatar
janui
 
Posts: 682
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby janui » 18 Sep 2018, 19:56

Hi jlynton,
jlynton wrote:Try: http://runeaudio.local or http://runeaudio. or http://runeaudio
Thanks again Janui, but none of those work.
Could you run this command via SSH and post the output:
Code: Select all
avahi-browse -atrkp
Thanks in advance.
janui
User avatar
janui
 
Posts: 682
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby rainy » 18 Sep 2018, 20:23

Hi janui,

Thank you very much for your tip.....I played about with the permissions and now my FLAC and Ogg Vorbis files play perfectly from the ext4 drive!

Thanks for your help and for taking the time to reply!

Regards,
-rainy


janui wrote:Hi rainy,
rainy wrote:Just like the previous version (0.3 beta) on the Raspberry Pi1, a USB stick or external USB drive formatted with the ext4 format does not seem to work with Rune Audio 0.5 beta.
Since Rune is based on Arch Linux, I would have expected this to work out of the box. Has anyone else had success with ext4?
Rune can see my USB drive and folders but all folders appear empty (I can see all the audio files when I SSH into Rune).
I have a feeling that it is working, but the file protections on the ext4 USB drive are preventing MPD from reading the data. MPD uses the user 'mpd', group 'audio' to access all the storage. User mpd, needs to have read access to filesystem, directories and files to able to use the data. When you log in via SSH you access the files as user 'root', which can read everything. You need to do something like this to fix it:
Code: Select all
find <path to drive> -type f -exec chmod 644 {} \;
find <path to drive> -type d -exec chmod 755 {} \;
Replace <path to drive> with the actual path to the drive. I think Rune will mount it read/write so you can do this after logging in with SSH. Personally I would automatically mount it ‘read only’, you can change this by adding the following line to /etc/udevil/udevil.conf:
Code: Select all
default_options_ext4      = nosuid, noexec, nodev, noatime, ro, noload

janui
rainy
 
Posts: 2
Joined: 16 Sep 2018, 14:38

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby jlynton » 19 Sep 2018, 11:53

janui wrote:Hi jlynton,
jlynton wrote:Try: http://runeaudio.local or http://runeaudio. or http://runeaudio
Thanks again Janui, but none of those work.
Could you run this command via SSH and post the output:
Code: Select all
avahi-browse -atrkp
Thanks in advance.
janui


Here you are, Janui...

Code: Select all
RuneOs: Experimental Beta 0.5 20180903
RuneUI: 0.5b (gearhead)
Hw-env: RaspberryPi 2 / 3


root@runeaudio(rw):~# avahi-browse -atrkp
+;wlan0;IPv4;RuneAudio;_mpd._tcp;local
=;wlan0;IPv4;RuneAudio;_mpd._tcp;local;runeaudio.local;192.168.0.12;6600;
+;wlan0;IPv4;RuneAudio\032\091runeaudio\093\032\091b8\05827\058eb\05867\05861\0585e\093;_http._tcp;local
=;wlan0;IPv4;RuneAudio\032\091runeaudio\093\032\091b8\05827\058eb\05867\05861\0585e\093;_http._tcp;local;runeaudio.local;10.24.57.35;80;"runeos_version=0.5-gearhead-janui" "skin_name=RuneUI"
+;wlan0;IPv4;....(THE REST IS INFO ABOUT MY NAS)


BTW, I have tried runeaudio.local with both http and https, neither work.

Thanks
jlynton
 
Posts: 49
Joined: 20 May 2016, 12:53

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby janui » 19 Sep 2018, 12:20

Hi jlynton,
jlynton wrote:Here you are, Janui...
Code: Select all
RuneOs: Experimental Beta 0.5 20180903
RuneUI: 0.5b (gearhead)
Hw-env: RaspberryPi 2 / 3
root@runeaudio(rw):~# avahi-browse -atrkp
+;wlan0;IPv4;RuneAudio;_mpd._tcp;local
=;wlan0;IPv4;RuneAudio;_mpd._tcp;local;runeaudio.local;192.168.0.12;6600;
+;wlan0;IPv4;RuneAudio\032\091runeaudio\093\032\091b8\05827\058eb\05867\05861\0585e\093;_http._tcp;local
=;wlan0;IPv4;RuneAudio\032\091runeaudio\093\032\091b8\05827\058eb\05867\05861\0585e\093;_http._tcp;local;runeaudio.local;10.24.57.35;80;"runeos_version=0.5-gearhead-janui" "skin_name=RuneUI"
+;wlan0;IPv4;....(THE REST IS INFO ABOUT MY NAS)
BTW, I have tried runeaudio.local with both http and https, neither work.
The output looks fine. So I would expect that the problem is related to your network or your Linux desktop. This version of Rune works exclusivly with IPv4, if this is disabled on your router or desktop by specifing IPv6, that could cause the problem. You should also check that avahi is running on your Linux system, try the 'avahi-browse -atrkp' command. Be sure to open UDP port 5353 if you're using a firewall. See here for some more details: https://wiki.archlinux.org/index.php/avahi
janui
User avatar
janui
 
Posts: 682
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby Stephane » 19 Sep 2018, 12:24

jlynton wrote:
janui wrote:Hi jlynton,
jlynton wrote:Try: http://runeaudio.local or http://runeaudio. or http://runeaudio
Thanks again Janui, but none of those work.
Could you run this command via SSH and post the output:
Code: Select all
avahi-browse -atrkp
Thanks in advance.
janui


Here you are, Janui...

Code: Select all
RuneOs: Experimental Beta 0.5 20180903
RuneUI: 0.5b (gearhead)
Hw-env: RaspberryPi 2 / 3


root@runeaudio(rw):~# avahi-browse -atrkp
+;wlan0;IPv4;RuneAudio;_mpd._tcp;local
=;wlan0;IPv4;RuneAudio;_mpd._tcp;local;runeaudio.local;192.168.0.12;6600;
+;wlan0;IPv4;RuneAudio\032\091runeaudio\093\032\091b8\05827\058eb\05867\05861\0585e\093;_http._tcp;local
=;wlan0;IPv4;RuneAudio\032\091runeaudio\093\032\091b8\05827\058eb\05867\05861\0585e\093;_http._tcp;local;runeaudio.local;10.24.57.35;80;"runeos_version=0.5-gearhead-janui" "skin_name=RuneUI"
+;wlan0;IPv4;....(THE REST IS INFO ABOUT MY NAS)


BTW, I have tried runeaudio.local with both http and https, neither work.

Thanks
Hi,
What browser on which system are you using to access runeaudio.local?

--
Stéphane Acounis
Stephane
 
Posts: 64
Joined: 06 Feb 2017, 10:35

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby nic » 19 Sep 2018, 12:30

janui wrote:Hi nic,
nic wrote:I've been a happy user of 0.5b for the past few weeks and really appreciate janui's help getting my DAC working with the new image . I've run into a slight issue when casting , I get 'twittering noises' type static . I have rebooted the PC used for casting , rebooted the PI and also done a gitpull . This issue happens with MP3 cast from my PC , WAVs now seen fine. Any ideas?
I have searched on the net for this problem, unfortunately found nothing similar with a recent date. So it will be a bit of an experimental approach.
Could you first try a few simple things first. In the /dev UI try setting SoXr for MPD ON or OFF (I don’t know what your normal setting is), then reboot & test. Then try selecting the Allo Piano 2.1 DAC Plus (without Kali) in the Settings UI, reboot, check that the correct output is selected in the MPD UI and retest.
If there is no improvement in sound quality then revert to your normal settings. Upgrading the upmpdcli package could fix it, so let’s try it. Log in with SSH and run the following commands:
Code: Select all
cd /home
wget https://github.com/gearhead/RuneOS/raw/master/packages/upmpdcli-rune/upmpdcli-rune-1.3.0-1-armv7h.pkg.tar.xz
pacman -U upmpdcli-rune-1.3.0-1-armv7h.pkg.tar.xz --force
Then:
Code: Select all
rm upmpdcli-rune-1.3.0-1-armv7h.pkg.tar.xz
cp /var/www/app/config/defaults/upmpdcli.conf /etc/upmpdcli.conf
cp /var/www/app/config/defaults/upmpdcli.service /usr/lib/systemd/system/upmpdcli.service
find /usr/lib/systemd/system -name *.service -exec chmod 644 {} \;
find /etc -name *.conf -exec chmod 644 {} \;
redis-cli hset dlna enable 0
redis-cli hset dlna queueowner 0
redis-cli hset dlna name RuneAudio
Then via the Settings UI switch ‘UPnP / DLNA’ ON, configure it, reboot and retest.
If this changes nothing then it is probably better to revert back to the original version of upmpdcli package, but this is optional and up to you. To revert back, run the following commands:
Code: Select all
cd /home
wget https://github.com/gearhead/RuneOS/raw/master/packages/upmpdcli-rune/upmpdcli-rune-1.2.15-3-armv7h.pkg.tar.xz
pacman -R upmpdcli-rune
Then:
Code: Select all
pacman -U upmpdcli-rune-1.2.15-3-armv7h.pkg.tar.xz
Then:
Code: Select all
rm upmpdcli-rune-1.3.0-1-armv7h.pkg.tar.xz
cp /var/www/app/config/defaults/upmpdcli.conf /etc/upmpdcli.conf
cp /var/www/app/config/defaults/upmpdcli.service /usr/lib/systemd/system/upmpdcli.service
find /usr/lib/systemd/system -name *.service -exec chmod 644 {} \;
find /etc -name *.conf -exec chmod 644 {} \;
redis-cli hset dlna enable 0
redis-cli hset dlna queueowner 0
redis-cli hset dlna name RuneAudio
Then via the Settings UI switch ‘UPnP / DLNA’ ON, configure it, reboot and retest to check that it still works.
janui


Unfortunately all the instructions above were followed but the issue remains . When I tried the upmpdcl upgrade , I was not able to see Rune as a renderer

cheers

Nic
Pi3 , Kali / Piano 2.1 (with dedicated choke input PSU) ----6SN7 beta follower---BUZ900P choke loaded source follower---Beyma 15XT in 230l cabinets/TPL150H AMT .
User avatar
nic
 
Posts: 65
Joined: 16 Dec 2013, 20:52
Location: London UK

support RuneAudio Donate with PayPal

PreviousNext

Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 12 guests