RuneAudio 0.5-beta for most Raspberry Pi models

Raspberry Pi related support

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby rlsten » 18 Sep 2018, 00:10

Thanks very much for your new image--I also have tried the others and always return to Rune--it simply sounds best.

I use rune with an Adafruit 2.8" touch screen, and it works with the new image. However, because of the switch to Chromium from Midori, and I can't access the Addons menu, and specifically, the UI enhancements, I don't know how to change the zoom level on the new image to fit on my tiny screen. With midori I could edit /root/.config/midori/config to change the zoom level. Is there a similar file for Chromium that I can access, or is there some other way to change the zoom level?

Thanks very much,
Rod
rlsten
 
Posts: 114
Joined: 25 May 2015, 18:06

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby MidnightExpress » 18 Sep 2018, 10:51

Hi janui,

janui wrote:If you select the I2S kernel module for the ES90x8 (Sabre) in the Settings UI you will get better performance.
Agree. Although the ES90x8 (Sabre) I2S kernel module is limited to 192kHz, it sounds a lot better than the hifiberry module.

janui wrote:You can also disable the on board WiFi with by adding this line to config.txt:
Code: Select all
dtoverlay=pi3-disable-wifi
I disable wifi by using hondagx35's suggestion for 0.4b, it works for me.

1. modify the file "/etc/modprobe.d/disable_rpi3_wifi_bt.conf" by uncomment the following lines
Code: Select all
blacklist brcmfmac
blacklist brcmutil

2. disable the wifi service:
Code: Select all
systemctl disable netctl-auto@wlan0

Regarding the "Disk Errors, Action Required" message on RuneUI, I think I find the cause. My Pi B+ connects to Suptronics X4000K Kit which has a harddisk expansion board. However, the board does not have a harddisk attached to. RuneOS sees /dev/sda but finds no physical blocks. The warning message maybe triggered by the SMART Health Check service (copied from debug).
Code: Select all
smartctl /dev/sda -d sat -H -i | grep -E 'Model:|Capacity:|-health self-|SMART support is'
This command line would not appear if the harddisk expansion board is disconnected from Pi B+.

The warning message comes out only when MPD is playing. I believe this warning won't harm anyway.

The "CIFS VFS: ioctl error in smb2_get_dfs_refer rc=-2" message from dmesg is another issue. Having search around the Internet, it seems to be related to kernel/smb settings. Here is my NAS network mount settings (copied from debug):

Code: Select all
//192.168.0.11/SSOTS/HiRes_Music /mnt/MPD/NAS/HiRes_Music cifs ro,relatime,vers=2.1,sec=ntlmssp,cache=none,username=cubox,domain=,uid=1000,forceuid,gid=92,forcegid,addr=192.168.0.11,file_mode=0755,dir_mode=0755,soft,nounix,mapposix,rsize=8192,wsize=16384,echo_interval=60,actimeo=1 0 0
My NAS supports up to smb/cifs version 2.1.

Any idea?

MidnightExpress
Pi3b+, Ver. Experimental Beta 0.5 20180903, ES9018K2M Dac
MidnightExpress
 
Posts: 12
Joined: 04 Aug 2018, 12:19

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby janui » 18 Sep 2018, 10:56

Hi rlsten,

rlsten wrote:However, because of the switch to Chromium from Midori, and I can't access the Addons menu, and specifically, the UI enhancements...
See here: runeaudio-0-5-beta-for-all-raspberry-pi-models-t6532-10.html#p25849
rlsten wrote:...I don't know how to change the zoom level on the new image to fit on my tiny screen. With midori I could edit /root/.config/midori/config to change the zoom level. Is there a similar file for Chromium that I can access, or is there some other way to change the zoom level?
I do not have a touchscreen, so cannot test this. There seems to be two routes to do this, via Chromium start-up settings and via XORG settings. The Chromium start-up method looks the most promising.

Chromium start-up settings:
The start-up settings are included in this file: /etc/X11/xinit/start_chromium.sh
Documentation concerning the settings is here: https://peter.sh/experiments/chromium-c ... -switches/
The options which look most interesting are:
    --ash-host-window-bounds
    --force-device-scale-factor
    --content-shell-host-window-size
    --window-size
    --app-shell-host-window-size
    --enable-use-zoom-for-dsf

XORG settings:
A parameter file is placed in the directory: /etc/X11/xorg.conf.d/
Some documentation concerning the settings is here (there is lots more on the web): https://wiki.archlinux.org/index.php/xo ... r_settings

If you can work out a good way of configuring the screen settings, please let me know. I will build it into the UI.

janui
User avatar
janui
 
Posts: 682
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby Stephane » 18 Sep 2018, 11:53

Hi,

I also tested some scale factors to use Rune 0.5b on a 7" touchscreen. I found that the switch "--force-device-scale-factor=0.8" does the job ... more or less.
The round circle of the volume knob is clipped and thus not make a circle anymore. I found also that the fonts are too small but what make Chromium more annoying to use is the way it handles long finger press as it brings a popup menu.
One way to have a nice display on small screens would be to use a custom CSS file but it is disabled in Chromium.
So I switched back to 0.4B as I fond the way Midori works more suited to my needs.
Stephane
 
Posts: 64
Joined: 06 Feb 2017, 10:35

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby jlynton » 18 Sep 2018, 12:37

I have just set up 0.5-beta on my pi3b, and have no problems except that I cannot access the web interface with runeaudio.local - I can access it using the pi's IP. Is this normal? I can access it using the android app.
jlynton
 
Posts: 49
Joined: 20 May 2016, 12:53

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby janui » 18 Sep 2018, 13:20

Hi MidnightExpress,
Thanks for getting back on this one.
MidnightExpress wrote:Regarding the "Disk Errors, Action Required" message on RuneUI, I think I find the cause. My Pi B+ connects to Suptronics X4000K Kit which has a harddisk expansion board. However, the board does not have a harddisk attached to. RuneOS sees /dev/sda but finds no physical blocks. The warning message maybe triggered by the SMART Health Check service (copied from debug).
Great, could you post the output of the following command:
Code: Select all
smartctl /dev/sda -d sat -H -i
I can then work out how to disable the messages when no actual disk is present.
MidnightExpress wrote:The warning message comes out only when MPD is playing.
Yes, it is designed to only to give warnings when something is playing. It’s the only way to know that there is someone to see them.
janui
User avatar
janui
 
Posts: 682
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby janui » 18 Sep 2018, 13:48

Hi jlynton,
jlynton wrote:I have just set up 0.5-beta on my pi3b, and have no problems except that I cannot access the web interface with runeaudio.local - I can access it using the pi's IP. Is this normal? I can access it using the android app.
Please search the forum for 'runeaudio.local android' or 'bonjour android frank', I believe it can be made to work. I think something like this is required (there are probably lots of alternative products): https://play.google.com/store/apps/deta ... icebrowser. I don't have an android device so I cannot test or recommend this specific product.
janui
User avatar
janui
 
Posts: 682
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby rlsten » 18 Sep 2018, 13:59

janui wrote:
rlsten wrote:...I don't know how to change the zoom level on the new image to fit on my tiny screen. With midori I could edit /root/.config/midori/config to change the zoom level. Is there a similar file for Chromium that I can access, or is there some other way to change the zoom level?
I do not have a touchscreen, so cannot test this. There seems to be two routes to do this, via Chromium start-up settings and via XORG settings. The Chromium start-up method looks the most promising.

Chromium start-up settings:
The start-up settings are included in this file: /etc/X11/xinit/start_chromium.sh
Documentation concerning the settings is here: https://peter.sh/experiments/chromium-c ... -switches/
The options which look most interesting are:
    --ash-host-window-bounds
    --force-device-scale-factor
    --content-shell-host-window-size
    --window-size
    --app-shell-host-window-size
    --enable-use-zoom-for-dsf



Hi janui,

As you suggested [Thanks very much!], the Chromium start-up settings in /etc/X11/xinit/start_chromium.sh
are the answer. Specifically, changing

Code: Select all
chromium --app=http://localhost --start-fullscreen --force-device-scale-factor=1.8
to
Code: Select all
chromium --app=http://localhost --start-fullscreen --force-device-scale-factor=.5


worked for the 2.8" Adafruit screen.

I suspect that a scale-factor of .7 would be about right for a 7" screen.

Thanks again,
Rod
rlsten
 
Posts: 114
Joined: 25 May 2015, 18:06

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby jlynton » 18 Sep 2018, 14:38

janui wrote:Hi jlynton,
jlynton wrote:I have just set up 0.5-beta on my pi3b, and have no problems except that I cannot access the web interface with runeaudio.local - I can access it using the pi's IP. Is this normal? I can access it using the android app.
Please search the forum for 'runeaudio.local android' or 'bonjour android frank', I believe it can be made to work. I think something like this is required (there are probably lots of alternative products): https://play.google.com/store/apps/deta ... icebrowser. I don't have an android device so I cannot test or recommend this specific product.
janui

Thanks Janui,

Sorry, I should have been clearer. I can only access the web interface using firefox on my Linux desktop if I type the Pi's IP, if I type runeaudio.local the browser times out (this had worked previously with 0.4-beta and previous versions).

Using the RuneAudio android app on my phone it does connect.
jlynton
 
Posts: 49
Joined: 20 May 2016, 12:53

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby janui » 18 Sep 2018, 14:44

User avatar
janui
 
Posts: 682
Joined: 20 Dec 2014, 12:55
Location: Ollanda

support RuneAudio Donate with PayPal

PreviousNext

Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 8 guests