[solved] Reboot from command line mutes the soundcard

Please report any bug found here

[solved] Reboot from command line mutes the soundcard

Postby Der Vogel » 28 May 2014, 13:26

Hi guys,
I had an issue with my installation and I tested lots of commands from the console, formatted several time SDCard and so on.
Until I realized the following: it seems that using the commands "reboot" or "halt" from the console makes RuneAudio stops completely to work with my external sound card. From the GUI, I can see the song progression but I get no output. However, it seems to continue to work for HDMI output. Rebooting from the GUI did not help.
I solved the problem only with a new installation of RuneAudio, and using only the RuneAudio GUI to halt or reboot.
I am happy to conclude that updating Archlinux or adding a partition on the SDCard with my music was not the problem.

EDIT: the sound card was just muted after restart. See below.
Last edited by Der Vogel on 30 May 2014, 07:52, edited 2 times in total.
Der Vogel
 
Posts: 19
Joined: 09 Apr 2014, 10:49

Re: reboot from command line breaks RuneAudio

Postby Midnight » 28 May 2014, 13:41

Maybe your output is just muted? Check your mixer settings with alsamixer after the reboot. I've never had problems with rebooting from command line.
User avatar
Midnight
Moderator
 
Posts: 141
Joined: 19 Feb 2014, 14:46

Re: reboot from command line breaks RuneAudio

Postby Der Vogel » 28 May 2014, 14:23

Indeed! I just used alsamixer, the gain levels looked to 100% but in fact the symbol at their bottom indicated they were muted. Not so visible...
Thanks for the tip! I will update my posts referring to this problem.
But why this behavior?

EDIT: now I have to activate my sound card with alsamixer every time I start RuneAudio, even after a "normal" shutdown via the GUI. Very annoying! Any clue to solve this?

Code: Select all
###### System info ######
Linux version 3.12.20-4-ARCH (nobody@root-armv6-copy) (gcc version 4.8.2 20131219 (prerelease) (GCC) ) #1 PREEMPT Tue May 27 19:18:36 MDT 2014

system load:   0.05 0.10 0.06 2/87 595

HW platform:   RaspberryPi (01)

playerID:   01999583dcf100eee73167fa4a8e995ae4


###### Audio backend ######
Advanced Linux Sound Architecture Driver Version k3.12.20-4-ARCH.

Card list: (/proc/asound/cards)
--------------------------------------------------
 0 [X20            ]: USB-Audio - XMOS USB Audio 2.0
                      XMOS XMOS USB Audio 2.0 at usb-bcm2708_usb-1.3.4, high speed
 1 [ALSA           ]: bcm2835 - bcm2835 ALSA
                      bcm2835 ALSA

ALSA interface #0: (/proc/asound/card0/pcm0p/info)
--------------------------------------------------
card: 0
device: 0
subdevice: 0
stream: PLAYBACK
id: USB Audio
name: USB Audio
subname: subdevice #0
class: 0
subclass: 0
subdevices_count: 1
subdevices_avail: 0

ALSA interface #1: (/proc/asound/card1/pcm0p/info)
--------------------------------------------------
card: 1
device: 0
subdevice: 0
stream: PLAYBACK
id: bcm2835 ALSA
name: bcm2835 ALSA
subname: subdevice #0
class: 0
subclass: 0
subdevices_count: 8
subdevices_avail: 8

interface #0 stream status: (/proc/asound/card0/stream0)
--------------------------------------------------------
XMOS XMOS USB Audio 2.0 at usb-bcm2708_usb-1.3.4, high speed : USB Audio

Playback:
  Status: Running
    Interface = 1
    Altset = 1
    Packet Size = 63
    Momentary freq = 44099 Hz (0x5.8328)
    Feedback Format = 16.16
  Interface 1
    Altset 1
    Format: S32_LE
    Channels: 2
    Endpoint: 1 OUT (ASYNC)
    Rates: 44100, 48000, 88200, 96000, 176400, 192000, 352800, 384000
    Data packet interval: 125 us

interface #1 stream status: (/proc/asound/card1/stream0)
--------------------------------------------------------
no stream present


###### Kernel module snd_usb_audio settings ######

Module = "snd_usb_audio"

  Attributes:
    coresize            = "117472"
    initsize            = "0"
    initstate           = "live"
    refcnt              = "1"
    srcversion          = "133E7F262EC8EAB8780E417"
    taint               = ""
    uevent              =

  Parameters:
    autoclock           = "Y"
    device_setup        = "0,0,0,0,0,0,0,0"
    enable              = "Y,Y,Y,Y,Y,Y,Y,Y"
    id                  = "(null),(null),(null),(null),(null),(null),(null),(null)"
    ignore_ctl_error    = "N"
    index               = "0,-1,-1,-1,-1,-1,-1,-1"
    nrpacks             = "3"
    pid                 = "-1,-1,-1,-1,-1,-1,-1,-1"
    vid                 = "-1,-1,-1,-1,-1,-1,-1,-1"

  Sections:
    .ARM.exidx.exit.text= "0xbf1ddf04"
    .ARM.exidx.init.text= "0xbf1ddefc"
    .ARM.exidx          = "0xbf1e0648"
    .ARM.extab          = "0xbf1e060c"
    .ARM.extab.init.text= "0xbf1ddef0"
    .bss                = "0xbf1e36e4"
    .data               = "0xbf1e0b8c"
    .exit.text          = "0xbf1db540"
    .gnu.linkonce.this_module= "0xbf1e3570"
    .init.text          = "0xbf1ec000"
    .note.gnu.build-id  = "0xbf1e0b68"
    .rodata             = "0xbf1db550"
    .rodata.str1.4      = "0xbf1ddf0c"
    .strtab             = "0xbf1f1368"
    .symtab             = "0xbf1ec048"
    .text               = "0xbf1ce000"
    __param             = "0xbf1e057c"


###### Kernel optimization parameters ######

hardware platform:   RaspberryPi
current orionprofile:   RuneAudio

kernel scheduler for mmcblk0:      [noop] deadline cfq
/proc/sys/vm/swappiness:      0
/proc/sys/kernel/sched_latency_ns:   1500000


###### Filesystem mounts ######

rootfs / rootfs rw 0 0
/dev/root / ext4 rw,noatime,nouser_xattr,errors=remount-ro,data=ordered 0 0
devtmpfs /dev devtmpfs rw,relatime,size=90488k,nr_inodes=22622,mode=755 0 0
tmpfs /dev/shm tmpfs rw,nosuid,nodev 0 0
devpts /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000 0 0
mqueue /dev/mqueue mqueue rw,relatime 0 0
proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0
systemd-1 /proc/sys/fs/binfmt_misc autofs rw,relatime,fd=21,pgrp=1,timeout=300,minproto=5,maxproto=5,direct 0 0
sysfs /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0
securityfs /sys/kernel/security securityfs rw,nosuid,nodev,noexec,relatime 0 0
tmpfs /sys/fs/cgroup tmpfs ro,nosuid,nodev,noexec,mode=755 0 0
cgroup /sys/fs/cgroup/systemd cgroup rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/usr/lib/systemd/systemd-cgroups-agent,name=systemd 0 0
cgroup /sys/fs/cgroup/cpuset cgroup rw,nosuid,nodev,noexec,relatime,cpuset 0 0
cgroup /sys/fs/cgroup/cpu,cpuacct cgroup rw,nosuid,nodev,noexec,relatime,cpuacct,cpu 0 0
cgroup /sys/fs/cgroup/devices cgroup rw,nosuid,nodev,noexec,relatime,devices 0 0
cgroup /sys/fs/cgroup/freezer cgroup rw,nosuid,nodev,noexec,relatime,freezer 0 0
cgroup /sys/fs/cgroup/blkio cgroup rw,nosuid,nodev,noexec,relatime,blkio 0 0
cgroup /sys/fs/cgroup/perf_event cgroup rw,nosuid,nodev,noexec,relatime,perf_event 0 0
cgroup /sys/fs/cgroup/net_prio cgroup rw,nosuid,nodev,noexec,relatime,net_prio 0 0
debugfs /sys/kernel/debug debugfs rw,relatime 0 0
configfs /sys/kernel/config configfs rw,relatime 0 0
tmpfs /run tmpfs rw,nosuid,nodev,mode=755 0 0
Ramdisk /run/shm tmpfs rw,nosuid,nodev,noexec,relatime,size=262144k 0 0
tmpfs /tmp tmpfs rw 0 0
rpc_pipefs /var/lib/nfs/rpc_pipefs rpc_pipefs rw,relatime 0 0
/dev/mmcblk0p1 /boot vfat rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,utf8,errors=remount-ro 0 0
/dev/mmcblk0p3 /mnt/MPD/Musique ext4 rw,noatime,nouser_xattr,errors=remount-ro,data=ordered 0 0
tmpfs /tmp tmpfs rw 0 0
/dev/root /var/tmp ext4 rw,noatime,nouser_xattr,errors=remount-ro,data=ordered 0 0
/dev/sda1 /mnt/MPD/USB/Holy\040Key fuseblk rw,nosuid,nodev,noexec,noatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096 0 0


###### mpd.conf ######

###################################
# Auto generated mpd.conf file
# please DO NOT edit it manually!
# Use RuneUI MPD config section
###################################

follow_outside_symlinks    "yes"
follow_inside_symlinks    "yes"
db_file    "/var/lib/mpd/mpd.db"
log_file    "/var/log/runeaudio/mpd.log"
pid_file    "/var/run/mpd/pid"
music_directory    "/mnt/MPD"
playlist_directory    "/var/lib/mpd/playlists"
state_file    "/var/lib/mpd/mpdstate"
user    "mpd"
bind_to_address    "any"
port    "6600"
log_level    "default"
zeroconf_enabled    "yes"
zeroconf_name    "runeaudio"
volume_normalization    "no"
audio_buffer_size    "2048"
buffer_before_play    "0%"
filesystem_charset    "UTF-8"
id3v1_encoding    "UTF-8"
gapless_mp3_playback    "yes"
auto_update    "no"
mixer_type    "disabled"
group    "audio"
max_connections "20"

decoder {
      plugin "ffmpeg"
      enabled "no"
}

input {
      plugin "curl"
}

audio_output {
enabled      "yes"
type      "alsa"
name      "USB-Audio"
device      "hw:0,0"
dsd_usb      "yes"
}

audio_output {
enabled      "yes"
type      "null"
name      "Null"
}

audio_output {
enabled      "no"
type      "alsa"
device      "hw:1,0"
name      "AnalogJack/HDMI"
}
Der Vogel
 
Posts: 19
Joined: 09 Apr 2014, 10:49

Re: reboot from command line mutes the soundcard

Postby Der Vogel » 29 May 2014, 06:28

Ok, solved. After using alsamixer, I enter the command "alsactl store" and now my sound card is not muted anymore at startup.
See this thread and the official wiki of Archlinux.
I do not set the title of this issue as "solved" yet because I do not understand why the first time using "reboot" in command line made this issue happen.
Der Vogel
 
Posts: 19
Joined: 09 Apr 2014, 10:49

Re: reboot from command line mutes the soundcard

Postby ACX » 29 May 2014, 11:48

Hi Der Vogel, we already solved the problem in v0.3: sound card settings (volume level and mute/unmute) are stored and not lost after a shutdown/reboot.
User avatar
ACX
RuneAudio co-founder
 
Posts: 1689
Joined: 29 Nov 2013, 02:25
Location: Udine, Italy

Re: reboot from command line mutes the soundcard

Postby Der Vogel » 30 May 2014, 07:52

Ok then. I change the status to "solved".
Der Vogel
 
Posts: 19
Joined: 09 Apr 2014, 10:49

Re: reboot from command line mutes the soundcard

Postby Midnight » 05 Jun 2014, 15:37

ACX wrote:Hi Der Vogel, we already solved the problem in v0.3: sound card settings (volume level and mute/unmute) are stored and not lost after a shutdown/reboot.


Are the levels stored during reboot/shutdown (not power off save) or immediately after changing volume (power off save)?
User avatar
Midnight
Moderator
 
Posts: 141
Joined: 19 Feb 2014, 14:46

Re: reboot from command line mutes the soundcard

Postby ACX » 11 Jun 2014, 13:09

Midnight wrote:Are the levels stored during reboot/shutdown (not power off save) or immediately after changing volume (power off save)?

During reboot/shutdown.
User avatar
ACX
RuneAudio co-founder
 
Posts: 1689
Joined: 29 Nov 2013, 02:25
Location: Udine, Italy

support RuneAudio Donate with PayPal


Return to Bug report

Who is online

Users browsing this forum: No registered users and 0 guests