readline upgrade crash, sqlite3 upgrade attempt

General discussion about RuneAudio. Do not post any support or feature requests here.

readline upgrade crash, sqlite3 upgrade attempt

Postby irishwill2008 » 21 Dec 2017, 11:15

Hi guys,

I have a quick question. Whenever i run pacman -Sy readline. It installs and the system remains working perfectly (To my knowledge that is) BUT as soon as i reboot. The pi no longer lets me SSH in, no longer lets me login locally via hdmi, the player basically dies!

Anyone have a reason why this is? I am trying to upgrade my sqlite3 so i can install the sqlite3 module for php. If i install the module with the current version installed which is version: 3.11.1-1 and the latest is: 3.21.0-1 the module wont work?

My guess is i need my sqlite3 fully updated to work with this module. Thing is, if i try install sqlite3.. It wont work as it says i need readline.

But as soon as i upgrade readline, the player stops working completely!

Any tips, ideas, opinions greatly appreciated!

Thanks guys :mrgreen:

Will.
irishwill2008
 
Posts: 157
Joined: 26 Jul 2016, 14:49
Location: Ireland

Re: readline upgrade crash, sqlite3 upgrade attempt

Postby hondagx35 » 21 Dec 2017, 13:41

Hi Will,

"libreadline" is a library widely used by many programs.
Bash is one that uses readline, so no wonder that login fails.

You have to find out all packages that depend on "libreadline" and update them.
But be worned, this may lead to other issues.

Frank
User avatar
hondagx35
 
Posts: 3038
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: readline upgrade crash, sqlite3 upgrade attempt

Postby janui » 21 Dec 2017, 16:37

Hi irishwill2008,
I have recently had a similar problem. I needed to upgrade readline because of errors relating to libreadline. After fixing libreadline a second problem arose regarding libcursesw, so also needed to upgrade ncurses. After all that some other software needed the previous versions of the libreadline and libcursesw. I eventually found a post somewhere on a Linux forum which stated that the latest changes to these library modules had no effect on their interfaces and suggested the following:
Code: Select all
ln -s /usr/lib/libncursesw.so.6 /usr/lib/libncursesw.so.5
ln -s /usr/lib/libreadline.so.7 /usr/lib/libreadline.so.6
This sets up symbolic links where each library file is accessed via two distinct filenames, it worked in my situation. It may get you a step further, but as Frank points out you may have a long way to go before everything works.
janui
User avatar
janui
 
Posts: 682
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: readline upgrade crash, sqlite3 upgrade attempt

Postby irishwill2008 » 22 Dec 2017, 10:41

Thanks frank for explaining this, i had a feeling there was a lot of dependencies here. Thanks janui, this may/may not work but at least il have that in mind for the future!

Guess i will park this for now, i made my own sqlite function which uses the exec/shell_exec to update the db accordinly which works for now. I had an issue with single quotes yesterday which made me create this but i figured out a fix in my function so all systems go for now!

Until i get more time to try get sqlite3 php module working, il just stick with my home made function XD

Cheers guys!

Will.
irishwill2008
 
Posts: 157
Joined: 26 Jul 2016, 14:49
Location: Ireland

support RuneAudio Donate with PayPal


Return to General discussion

Who is online

Users browsing this forum: No registered users and 7 guests