Pi3 and DAC+ Pro

Raspberry Pi related support

Re: Pi3 and DAC+ Pro

Postby hondagx35 » 12 Apr 2016, 17:12

Hi Tobi,

The channel swap problem still occurs in the same way as with the Dac+ pro

I did some tests with my PI3 and the Hifiberry DAC+ and i'm unable to reproduce your channel swapping issue.
For testing i used your flac file with one tone on the right channel.
It doesn't matter if wifi is enabled or disabled.
The file is stored on a cifs share.

Frank
User avatar
hondagx35
 
Posts: 3034
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: Pi3 and DAC+ Pro

Postby tobvc » 12 Apr 2016, 19:38

Hi Frank,

now that is interesting. Thanks for your testing.

I set up a share on a Windows 10 PC and played the test file (Pi 3 + DAC+, over wifi) multiple times. Every time the channel swap problem occured, although sometimes it took some minutes of playback.
If you want to do further testing without being bothered by the sine tone, you could just play the file on repeat while the balance knob is turned all the way to the left. If a beep appeares, that is a channel swap. If not, last thing I could imagine is that my Pi is defective.

Tobi
tobvc
 
Posts: 14
Joined: 07 Apr 2016, 18:57

Re: Pi3 and DAC+ Pro

Postby tobvc » 13 Apr 2016, 12:28

Ok, today the Pi 2 B and an EW-7811UN wifi dongle arrived. Wifi works very stable out of the box (with both DACs).

With both the DAC+ and the DAC+ pro, Shairport works like a charm, no furious channel swapping anymore.
Playback of 16 bit audio content also does not suffer channel swapping. After ~15 min. of testing for both DACs each, not a single swap occured.

Tobi
tobvc
 
Posts: 14
Joined: 07 Apr 2016, 18:57

Re: Pi3 and DAC+ Pro

Postby hondagx35 » 06 May 2016, 21:35

Hi,

the channel swapping (RP3) seems to be solved see here.

Frank
User avatar
hondagx35
 
Posts: 3034
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: Pi3 and DAC+ Pro

Postby Snerg » 08 Jun 2016, 01:02

Hi guys,

I am another one with WiFi connection dropping while using RPI3 built in WiFi + Hifiberry DAC+Pro + Runeaudio.
- RPI3 WIFI ok tested many times - streaming with kodi,
- Hifiberry DAC+Pro with my RPI3 ok when running Moode connected through built in WiFi,
- Same setup but running Runeaudio no joy. Tried rune 0.3 and 0.4, all tweaks mentioned here and elsewhere, all kind of updates and still same result. No matter how powerful my PSU is btw.

I've noticed weird phenomena tho. When holding USB ports with my fingers (earthing RPI3) for 10-20s while running whole Runeaudio system it seems that WiFi is working fine or re-gaining connection... As soon as I let go connection is dropping again.
But no need for such thing with Moode. It looks like drivers for Hifiberry DAC+ (can't see one for DAC+PRO) that Runeaudio is using are disarming WiFi's module GND 'signal'. Wonder if anybody else noticed such behaviour.
Last edited by Snerg on 26 Jun 2016, 19:22, edited 1 time in total.
Snerg
 
Posts: 3
Joined: 08 Jun 2016, 00:34
Location: UK

Re: Pi3 and DAC+ Pro

Postby ToKa » 14 Jun 2016, 09:20

Snerg wrote:I am another one with WiFi connection dropping while using RPI3 built in WiFi + Hifiberry dac+pro + Runeaudio.


Me too. I have read the thread through and tried every tweak as well - without success. Is there any activities on-going to get this fixed? If there are any needs to take logs etc, please let me know. I can easily reproduce the problem and take logs.
ToKa
 
Posts: 2
Joined: 14 Jun 2016, 09:14

Re: Pi3 and DAC+ Pro

Postby Snerg » 26 Jun 2016, 19:33

ToKa wrote:
Snerg wrote:I am another one with WiFi connection dropping while using RPI3 built in WiFi + Hifiberry dac+pro + Runeaudio.


Me too. I have read the thread through and tried every tweak as well - without success. Is there any activities on-going to get this fixed? If there are any needs to take logs etc, please let me know. I can easily reproduce the problem and take logs.



I think it is something to do with Arch Linux and how it is controlling DAC+PRO. I also do not think Hifiberry folks care much about this Linux distribution hence our unresolved problem. I am using Moode at the moment as it simply does work but will keep an eye on Runeaudio hoping DAC+PRO will get proper support in near future.
Snerg
 
Posts: 3
Joined: 08 Jun 2016, 00:34
Location: UK

Re: Pi3 and DAC+ Pro

Postby hondagx35 » 26 Jun 2016, 21:03

Hi Snerg, hi ToKa,

did you update the kernel as described here?

Frank
User avatar
hondagx35
 
Posts: 3034
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: Pi3 and DAC+ Pro

Postby ToKa » 30 Jun 2016, 07:53

hondagx35 wrote:Hi Snerg, hi ToKa,

did you update the kernel as described here?

Frank


Yes I have updated the kernel as instructed but with no success related to this issue.
ToKa
 
Posts: 2
Joined: 14 Jun 2016, 09:14

Re: Pi3 and DAC+ Pro

Postby Snerg » 19 Jul 2016, 22:57

hondagx35 wrote:Hi Snerg, hi ToKa,

did you update the kernel as described here?

Frank


Hi there, as I've mentioned above tried it all.
Snerg
 
Posts: 3
Joined: 08 Jun 2016, 00:34
Location: UK

support RuneAudio Donate with PayPal

Previous

Return to Raspberry Pi

Who is online

Users browsing this forum: cmh714 and 6 guests