[BugFix] HiFiBerry DAC+ HW Volume (RuneAudio 0.3-beta)

Raspberry Pi related support

Re: [BugFix] HiFiBerry DAC+ HW Volume (RuneAudio 0.3-beta)

Postby hondagx35 » 22 Jan 2016, 11:54

Hi tbahrman,

please see your other thread.

Frank
User avatar
hondagx35
 
Posts: 3039
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: [BugFix] HiFiBerry DAC+ HW Volume (RuneAudio 0.3-beta)

Postby utschu » 30 Jan 2016, 13:55

Not the 100% correct thread for my problem, but quite close.
I have a Pi 2 with 7" Touch which runs like a charm (thanks for the great work).
Now I am trying to add a Phat Dac.
If I am right the settings for hifiberry dac should also work for Phat Dac.
I have downloaded the Pi 2 image with support for Pi Touch.
I updated by use of gitpull button in /dev.
I activated the hifiberry dac by uncommenting "device_tree_overlay=hifiberry-dac" in /boot/config.txt.

As I do net get any sound out of the jack I assume that I have missed something.

Do I need to uncomment also "device_tree_param=i2s=on" in /boot/config.txt and/or something else?

Thanks
Best regards
utschu
utschu
 
Posts: 27
Joined: 17 Mar 2015, 19:45

Re: [BugFix] HiFiBerry DAC+ HW Volume (RuneAudio 0.3-beta)

Postby hondagx35 » 31 Jan 2016, 01:00

Hi utschu,

after a reboot you have to select your DAC:
MENU->MPD->Audio output interface

Edit:

Do I need to uncomment also "device_tree_param=i2s=on" in /boot/config.txt and/or something else?

No, only the line with your DAC has to be uncommented.

Frank
User avatar
hondagx35
 
Posts: 3039
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: [BugFix] HiFiBerry DAC+ HW Volume (RuneAudio 0.3-beta)

Postby utschu » 31 Jan 2016, 08:48

Hi Frank
Thanks for reply.
Correct, after reboot i can choose the DAC from MPD menu, but I don't get any sound.
I did try with a second Raspberry Pi and other Phat DAC with the same result.
Regards
utschu
utschu
 
Posts: 27
Joined: 17 Mar 2015, 19:45

[Solved]Re: [BugFix] HiFiBerry DAC+ HW Vol (RuneAudio 0.3-b

Postby utschu » 31 Jan 2016, 13:54

I found a test image on Hifiberry homepage, to test my hardware and during testing I realised that there must be a Hardware problem.
When double checking my solderings, I realised that there was something wrong.
After correction of the wrong solderings everything works perfect now.
Thanks.
utschu
 
Posts: 27
Joined: 17 Mar 2015, 19:45

Re: [BugFix] HiFiBerry DAC+ HW Volume (RuneAudio 0.3-beta)

Postby PeteB » 08 Feb 2016, 22:48

Thanks to this thread, I managed to enable hardware volume control (RPi2 and HiFiBerry DAC+), but the range seems more than a little off.

The best way to explain it is to compare software and hardware volume control. With software volume control, the sound level goes from off to very loud from 0 to 50 on the dial. With hardware volume control, the sound is inaudible between 0 and 25, and the volume increases the way one would expect between 25 and 75.

What I would consider to be a usable range is 0-50 when using software control, and 25-75 when using hardware volume control.

Is there another setting in MPD I am not seeing or not understanding? (or can this be changed in Alsa/amixer?)

Thanks.

(I did a git pull yesterday, Sunday Feb. 7)
PeteB
 
Posts: 421
Joined: 06 Feb 2016, 05:07

Re: [BugFix] HiFiBerry DAC+ HW Volume (RuneAudio 0.3-beta)

Postby hondagx35 » 09 Feb 2016, 00:52

Hi PeteB,

at the moment there is no solution for this (see here)

I hope this will be solved with the next version.

Frank
User avatar
hondagx35
 
Posts: 3039
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: [BugFix] HiFiBerry DAC+ HW Volume (RuneAudio 0.3-beta)

Postby PeteB » 09 Feb 2016, 04:28

Seen and read it now, thanks!

For what it is worth, my opinion is that I would NOT bypass MPD, because this opens you to being second-guessed by anyone and everyone, and you can't anticipate MPD or hardware development.

I would be happy if I could set the two ends of the range myself, upper and lower, maybe in 3 db steps, or even just MPD integer values. I do not think that linear or logarithmic would matter as much then.

Perhaps as an option after hardware control is selected in setup. Or even editing some config file.

That way I could at least eliminate the part of the range that does nothing, and decide what upper level I can stand b/f hearing damage or speaker damage. I am rather fond of both (my speakers and ears) and as it is, if I touch the volume control in the wrong place, I could blow a speaker, or with some headphones, eardrum... :D
PeteB
 
Posts: 421
Joined: 06 Feb 2016, 05:07

Re: [BugFix] HiFiBerry DAC+ HW Volume (RuneAudio 0.3-beta)

Postby maxchess » 20 Feb 2016, 18:36

Hi,
I have a Rasperry PI B+ (not the 2,) with a HiFiBerry DAC+ RCA card.
I had it all working before I got the DAC+, installed the h/w and then did a clean install of RuneAudio
I have tried the various "fixes" in this forum, but cannot get it to work. Help please. I love Runeaudio and bought the DAC to improve sound quality.
On the MPD config page, it just gives me a choise between Analogue out & HDMI.
I tried both, neither play through the DAC
Which is the current correct fix?
Thanks in advance, Max
User avatar
maxchess
 
Posts: 3
Joined: 20 Feb 2016, 18:28

Re: [BugFix] HiFiBerry DAC+ HW Volume (RuneAudio 0.3-beta)

Postby PeteB » 20 Feb 2016, 19:47

Hi Max,

Did you edit the config.txt file, in the /boot directory after you did a clean install?

example:

edit config.txt
Code: Select all
nano /boot/config.txt


uncomment the line corresponding to your dac
Code: Select all
device_tree_overlay=hifiberry-dacplus


Then reboot.

:)
PeteB
 
Posts: 421
Joined: 06 Feb 2016, 05:07

support RuneAudio Donate with PayPal

PreviousNext

Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 4 guests