[BugFix] HiFiBerry DAC+ HW Volume (RuneAudio 0.3-beta)

Raspberry Pi related support

Re: [BugFix] HiFiBerry DAC+ HW Volume (RuneAudio 0.3-beta)

Postby hondagx35 » 27 Apr 2015, 22:28

Hi leeshep,

it seems that the control name changed an other time from PCM to Digital (Raspberry Pi2 only).
Please try this:
Code: Select all
redis-cli hset acards_details snd_rpi_hifiberry_dacplus "{\"sysname\":\"snd_rpi_hifiberry_dacplus\",\"extlabel\”:\"HiFiBerry DAC+ (I²S)\",\"mixer_numid\":\"1\",\"mixer_control\”:\”Digital\”,\”hwplatformid\":\"01\",\"type\":\"i2s\"}"


Remember that 81% already equals 0.00dB!!

Frank
User avatar
hondagx35
 
Posts: 3039
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: [BugFix] HiFiBerry DAC+ HW Volume (RuneAudio 0.3-beta)

Postby leeshep » 07 May 2015, 13:35

Hi,

Thanks for that, but unfortunately it still doesn't work...
I can adjust the volume level and it sticks but the output volume doesn't change.
I have tried doing a clean install and then running the command again. I run it and it reports (integer) 0
I then run refresh_ao and do a restart but it just wont work :-(

Lee
leeshep
 
Posts: 10
Joined: 27 Apr 2015, 18:45

Re: [BugFix] HiFiBerry DAC+ HW Volume (RuneAudio 0.3-beta)

Postby leeshep » 07 May 2015, 21:15

Any more ideas?
leeshep
 
Posts: 10
Joined: 27 Apr 2015, 18:45

Re: [BugFix] HiFiBerry DAC+ HW Volume (RuneAudio 0.3-beta)

Postby leeshep » 08 May 2015, 15:59

Please help guys... I must be doing something wrong :-(
leeshep
 
Posts: 10
Joined: 27 Apr 2015, 18:45

Re: [BugFix] HiFiBerry DAC+ HW Volume (RuneAudio 0.3-beta)

Postby Orion » 29 May 2015, 15:46

leeshep wrote:Please help guys... I must be doing something wrong :-(


Can you post here your debug informations? (look here for how to collect debug output).

Thanks.

Simone.
RuneAudio - Embedded Hi-Fi music player
SoloStereo - Alla riscoperta dell'alta fedeltà
User avatar
Orion
RuneAudio co-founder
 
Posts: 189
Joined: 29 Nov 2013, 02:03
Location: Udine, Italy

Re: [BugFix] HiFiBerry DAC+ HW Volume (RuneAudio 0.3-beta)

Postby nemus » 07 Jun 2015, 20:48

Hi,

you should disable the in-built PCM device, it is not needed anyway. Put this to your /etc/modprobe.d/blacklist.conf:
Code: Select all
blacklist snd_bcm2835
blacklist snd_soc_hifiberry_dac

Reboot and after that the hw volume should work.
nemus
 
Posts: 1
Joined: 07 Jun 2015, 20:40

Re: [BugFix] HiFiBerry DAC+ HW Volume (RuneAudio 0.3-beta)

Postby mezcal » 17 Jun 2015, 11:58

Thanks it works.

I had to change from "Playback Digital" to "PCM".

Code: Select all
redis-cli hset acards_details snd_rpi_hifiberry_dacplus "{\"sysname\":\"snd_rpi_hifiberry_dacplus\",\"extlabel\":\"HiFiBerry DAC+ (I²S)\",\"mixer_numid\":\"1\",\"mixer_control\":\"PCM\",\"hwplatformid\":\"01\",\"type\":\"i2s\"}"


I had to use full path.
Code: Select all
/srv/http/command/refresh_ao
mezcal
 
Posts: 1
Joined: 17 Jun 2015, 11:53

Re: [BugFix] HiFiBerry DAC+ HW Volume (RuneAudio 0.3-beta)

Postby ChiiFii » 17 Jun 2015, 17:51

It works great for me on my RP2.
But Airplay won't work anymore :(

***edit***
FIX works on RPI2, with hifiberry dac+

nemus wrote:you should disable the in-built PCM device, it is not needed anyway. Put this to your /etc/modprobe.d/blacklist.conf:
Code: Select all
blacklist snd_bcm2835
blacklist snd_soc_hifiberry_dac


run the command:
hondagx35 wrote:it seems that the control name changed an other time from PCM to Digital (Raspberry Pi2 only).
Please try this:
Code: Select all
redis-cli hset acards_details snd_rpi_hifiberry_dacplus "{\"sysname\":\"snd_rpi_hifiberry_dacplus\",\"extlabel\”:\"HiFiBerry DAC+ (I²S)\",\"mixer_numid\":\"1\",\"mixer_control\”:\”Digital\”,\”hwplatformid\":\"01\",\"type\":\"i2s\"}"



refresh your audio output
Code: Select all
/srv/http/command/refresh_ao


reboot

find out your hardwaredevice
Code: Select all
aplay -l


edit the hardwaredevice in /usr/lib/systemd/system/shairport.service on line 11
in my case: hw:1,0 to hw:0,0
Code: Select all
ExecStart=/usr/bin/shairport -w --name=RuneAudio --on-start=$ON --on-stop=$OFF --meta-dir=/var/run/shairport -o alsa -- -d hw:0,0


reload your daemons
Code: Select all
systemctl daemon-reload


and restart shairport service
Code: Select all
systemctl restart shairport


AirPlay will work again with hardware volume control.
:)
ChiiFii
 
Posts: 2
Joined: 17 Jun 2015, 17:50
Location: Germany

Re: [BugFix] HiFiBerry DAC+ HW Volume (RuneAudio 0.3-beta)

Postby gswg » 18 Jun 2015, 16:47

These changes are PCM5122 driver related, and not Pi2 specific.

100% volume should also now be 0db and not +4db as I previously set.

Gordon@iqaudio.com
gswg
 
Posts: 55
Joined: 21 Jan 2014, 21:04
Location: Glasgow

Re: [BugFix] HiFiBerry DAC+ HW Volume (RuneAudio 0.3-beta)

Postby coloscott » 09 Jul 2015, 20:14

So I've been following the various recommendations in this thread but I still can't get Hardware Volume control to work, even after starting over from scratch twice. The closest I've come is to be able to change the volume without it just bouncing back to 100 but even then the actual volume did not change. As of my last re-start with a new image and making these suggested changes it is back to where when I change the volume it bounces back to 100. This is most frustrating as a few days ago I decided to go with a couple of mono block amps instead of an integrated amp so it's a big issue for me. Software volume control does work but I've invested in some high end speakers and amps and would REALLY like to have the hardware control. Can someone suggest my next steps?

Thanks in advance.

Overall this is an awesome release!

Scott

Debug follows:
###### System info ######
Linux version 3.18.7-3-ARCH (builduser@leming) (gcc version 4.9.2 20141224 (prerelease) (GCC) ) #1 SMP PREEMPT Fri Feb 13 06:23:21 MST 2015

system time: Thu Jul 9 20:54:03 CEST 2015

system load: 0.79 0.19 0.06 1/131 833

HW platform: RaspberryPi2 (08)

playerID: 08b26fff2ac4ddac6fee7fbbc1890504ae


###### System load statistics (procinfo -H) ######
sh: procinfo: command not found


###### Active processes (pstree) ######
systemd-+-2*[agetty]
|-avahi-daemon---avahi-daemon
|-cmd_async---sh---debug_collector---sh---pstree
|-dbus-daemon
|-devmon---udevil
|-dhcpcd
|-ifplugd
|-mpd-+-{decoder}
| |-{io}
| |-{output:snd_rpi_}
| `-{player}
|-nginx---nginx
|-nmbd
|-ntpd---{ntpd}
|-php-fpm---3*[php-fpm]
|-redis-server---2*[{redis-server}]
|-rpc.statd
|-rpcbind
|-rune_PL_wrk
|-rune_SY_wrk
|-shairport---{shairport}
|-smbd---smbd
|-sshd
|-systemd-network
|-systemd-resolve
|-systemd-udevd
|-upmpdcli---7*[{upmpdcli}]
|-wpa_actiond
`-wpa_supplicant


###### Audio backend ######
Advanced Linux Sound Architecture Driver Version k3.18.7-3-ARCH.

Card list: (/proc/asound/cards)
--------------------------------------------------
0 [sndrpihifiberry]: snd_rpi_hifiber - snd_rpi_hifiberry_dacplus
snd_rpi_hifiberry_dacplus


PLAYBACK devices: (aplay -l)
--------------------------------------------------
**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_dacplus], device 0: HiFiBerry DAC+ HiFi pcm512x-hifi-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0


PCM devices: (aplay -L)
--------------------------------------------------
null
Discard all samples (playback) or generate zero samples (capture)
default:CARD=sndrpihifiberry
snd_rpi_hifiberry_dacplus,
Default Audio Device
sysdefault:CARD=sndrpihifiberry
snd_rpi_hifiberry_dacplus,
Default Audio Device


Simple mixer controls: (amixer scontrols)
--------------------------------------------------
card 0:
Simple mixer control 'PCM',0
Simple mixer control 'DSP Program',0
Simple mixer control 'Playback',0
Simple mixer control 'Playback Boost',0
Simple mixer control 'Auto Mute',0
Simple mixer control 'Auto Mute Mono',0
Simple mixer control 'Auto Mute Time Left',0
Simple mixer control 'Auto Mute Time Right',0
Simple mixer control 'Clock Missing Period',0
Simple mixer control 'Deemphasis',0
Simple mixer control 'Digital',0
Simple mixer control 'Volume Ramp Down Emergency Rate',0
Simple mixer control 'Volume Ramp Down Emergency Step',0
Simple mixer control 'Volume Ramp Down Rate',0
Simple mixer control 'Volume Ramp Down Step',0
Simple mixer control 'Volume Ramp Up Rate',0
Simple mixer control 'Volume Ramp Up Step',0


Mixer controls: (amixer controls)
--------------------------------------------------
card 0:
numid=1,iface=MIXER,name='PCM'
numid=6,iface=MIXER,name='DSP Program'
numid=3,iface=MIXER,name='Playback Boost Volume'
numid=2,iface=MIXER,name='Playback Volume'
numid=10,iface=MIXER,name='Auto Mute Mono Switch'
numid=11,iface=MIXER,name='Auto Mute Switch'
numid=8,iface=MIXER,name='Auto Mute Time Left'
numid=9,iface=MIXER,name='Auto Mute Time Right'
numid=7,iface=MIXER,name='Clock Missing Period'
numid=5,iface=MIXER,name='Deemphasis Switch'
numid=4,iface=MIXER,name='Digital Playback Switch'
numid=16,iface=MIXER,name='Volume Ramp Down Emergency Rate'
numid=17,iface=MIXER,name='Volume Ramp Down Emergency Step'
numid=12,iface=MIXER,name='Volume Ramp Down Rate'
numid=13,iface=MIXER,name='Volume Ramp Down Step'
numid=14,iface=MIXER,name='Volume Ramp Up Rate'
numid=15,iface=MIXER,name='Volume Ramp Up Step'


MPD audio outputs status: (mpc outputs)
--------------------------------------------------
Output 1 (snd_rpi_hifiberry_dacplus) is enabled


###### mpd.conf ######
###################################
# Auto generated mpd.conf file
# please DO NOT edit it manually!
# Use RuneUI MPD config section
###################################

state_file "/var/lib/mpd/mpdstate"
zeroconf_enabled "yes"
zeroconf_name "RuneAudio"
bind_to_address "/run/mpd.sock"
bind_to_address "any"
port "6600"
max_connections "20"
user "mpd"
group "audio"
db_file "/var/lib/mpd/mpd.db"
sticker_file "/var/lib/mpd/sticker.sql"
pid_file "/var/run/mpd/pid"
music_directory "/mnt/MPD"
playlist_directory "/var/lib/mpd/playlists"
follow_outside_symlinks "yes"
follow_inside_symlinks "yes"
auto_update "no"
filesystem_charset "UTF-8"
id3v1_encoding "UTF-8"
volume_normalization "no"
audio_buffer_size "3072"
buffer_before_play "20%"
gapless_mp3_playback "yes"
mixer_type "software"

input {
plugin "curl"
}

decoder {
plugin "ffmpeg"
enabled "yes"
}

audio_output {
name "snd_rpi_hifiberry_dacplus"
type "alsa"
device "hw:0,0"
auto_resample "no"
auto_format "no"
enabled "yes"
}


###### Network netctl profiles (netctl list) ######
Ranch
eth0

Ranch netctl status
--------------------------------------------------------
netctl@Ranch.service - Networking for netctl profile Ranch
Loaded: loaded (/usr/lib/systemd/system/netctl@.service; static; vendor preset: disabled)
Active: inactive (dead)
Docs: man:netctl.profile(5)

Ranch netctl profile
--------------------------------------------------------
Description='wlan0 connection'
Interface=wlan0
Connection=wireless
Security=wpa-configsection
AutoWired=yes
IP=static
Address=('192.168.150.14/24')
Gateway='192.168.150.1'
DNS=('192.168.150.1')
WPAConfigSection=(
'ssid="Ranch"'
'psk="Letmeinnow56"'
'key_mgmt=WPA-PSK'
'proto=RSN'
'group=TKIP'
'pairwise=CCMP'
'priority=3'
)

eth0 netctl status
--------------------------------------------------------
netctl@eth0.service - Networking for netctl profile eth0
Loaded: loaded (/usr/lib/systemd/system/netctl@.service; static; vendor preset: disabled)
Active: inactive (dead)
Docs: man:netctl.profile(5)

eth0 netctl profile
--------------------------------------------------------
Description='eth0 connection'
Interface=eth0
ForceConnect=yes
SkipNoCarrier=yes
Connection=ethernet
IP=dhcp


[ 7.642784] snd-rpi-hifiberry-dacplus sound: ASoC: CPU DAI (null) not registered
[ 7.642833] snd-rpi-hifiberry-dacplus sound: snd_soc_register_card() failed: -517
[ 7.642868] platform sound: Driver snd-rpi-hifiberry-dacplus requests probe deferral
[ 7.643245] snd-rpi-hifiberry-dacplus sound: ASoC: CPU DAI (null) not registered
[ 7.643290] snd-rpi-hifiberry-dacplus sound: snd_soc_register_card() failed: -517
[ 7.643321] platform sound: Driver snd-rpi-hifiberry-dacplus requests probe deferral
[ 7.650300] snd-rpi-hifiberry-dacplus sound: pcm512x-hifi <-> 3f203000.i2s mapping ok
[ 7.696013] cfg80211: Calling CRDA to update world regulatory domain
[ 7.879619] usb 1-1.5: reset high-speed USB device number 4 using dwc_otg
[ 7.885095] systemd[1]: Found device /dev/mmcblk0p1.
[ 7.885394] systemd[1]: Mounting /boot...
[ 7.898948] systemd[1]: boot.mount: Directory /boot to mount over is not empty, mounting anyway.
[ 7.989002] ieee80211 phy0: rt2x00_set_rt: Info - RT chipset 5392, rev 0223 detected
[ 8.006478] ieee80211 phy0: rt2x00_set_rf: Info - RF chipset 5372 detected
[ 8.006856] cfg80211: Updating information on frequency 2412 MHz with regulatory rule:
[ 8.006869] cfg80211: 2402000 KHz - 2472000 KHz @ 40000 KHz), (600 mBi, 2000 mBm)
[ 8.006880] cfg80211: Updating information on frequency 2417 MHz with regulatory rule:
[ 8.006890] cfg80211: 2402000 KHz - 2472000 KHz @ 40000 KHz), (600 mBi, 2000 mBm)
[ 8.006899] cfg80211: Updating information on frequency 2422 MHz with regulatory rule:
[ 8.006908] cfg80211: 2402000 KHz - 2472000 KHz @ 40000 KHz), (600 mBi, 2000 mBm)
[ 8.006917] cfg80211: Updating information on frequency 2427 MHz with regulatory rule:
[ 8.006926] cfg80211: 2402000 KHz - 2472000 KHz @ 40000 KHz), (600 mBi, 2000 mBm)
[ 8.006935] cfg80211: Updating information on frequency 2432 MHz with regulatory rule:
[ 8.006944] cfg80211: 2402000 KHz - 2472000 KHz @ 40000 KHz), (600 mBi, 2000 mBm)
[ 8.006953] cfg80211: Updating information on frequency 2437 MHz with regulatory rule:
[ 8.006962] cfg80211: 2402000 KHz - 2472000 KHz @ 40000 KHz), (600 mBi, 2000 mBm)
[ 8.006971] cfg80211: Updating information on frequency 2442 MHz with regulatory rule:
[ 8.006980] cfg80211: 2402000 KHz - 2472000 KHz @ 40000 KHz), (600 mBi, 2000 mBm)
[ 8.006988] cfg80211: Updating information on frequency 2447 MHz with regulatory rule:
[ 8.006997] cfg80211: 2402000 KHz - 2472000 KHz @ 40000 KHz), (600 mBi, 2000 mBm)
[ 8.007006] cfg80211: Updating information on frequency 2452 MHz with regulatory rule:
[ 8.007015] cfg80211: 2402000 KHz - 2472000 KHz @ 40000 KHz), (600 mBi, 2000 mBm)
[ 8.007024] cfg80211: Updating information on frequency 2457 MHz with regulatory rule:
[ 8.007033] cfg80211: 2402000 KHz - 2472000 KHz @ 40000 KHz), (600 mBi, 2000 mBm)
[ 8.007042] cfg80211: Updating information on frequency 2462 MHz with regulatory rule:
[ 8.007051] cfg80211: 2402000 KHz - 2472000 KHz @ 40000 KHz), (600 mBi, 2000 mBm)
[ 8.007059] cfg80211: Updating information on frequency 2467 MHz with regulatory rule:
[ 8.007068] cfg80211: 2457000 KHz - 2482000 KHz @ 40000 KHz), (600 mBi, 2000 mBm)
[ 8.007077] cfg80211: Updating information on frequency 2472 MHz with regulatory rule:
[ 8.007086] cfg80211: 2457000 KHz - 2482000 KHz @ 40000 KHz), (600 mBi, 2000 mBm)
[ 8.007095] cfg80211: Updating information on frequency 2484 MHz with regulatory rule:
[ 8.007104] cfg80211: 2474000 KHz - 2494000 KHz @ 20000 KHz), (600 mBi, 2000 mBm)
[ 8.045916] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[ 8.047454] usbcore: registered new interface driver rt2800usb

###### PHP backend ######
php version: 5.5.19
debug level: 1


Debug data collected in 1.596 seconds.
coloscott
 
Posts: 3
Joined: 09 Jul 2015, 19:42

support RuneAudio Donate with PayPal

PreviousNext

Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 15 guests