HifiBerry Amp+ Volume

Everything about Hi-Fi equipment

HifiBerry Amp+ Volume

Postby tschinz » 16 Apr 2015, 06:34

Hallo Guys,

thanks for this great tool. I managed to use the Hifiberry Amp+ by changing the /boot/config.txt and add the following line.

Code: Select all
dtoverlay=hifiberry-amp


Now I have two/three problems
1. Hardware enabled Volume control doesn't work. Even though Hifiberry Amp+ has this feature. (In "a similar" distro it works)
2. Volume is too loud. I use it for listening in my bedroom and Volume 1 (software enabled) is still too loud. Is there a way to change the range of the volume control knob?
3. In Airplay the Volume knob can't be used (controlled by IPhone) but in this case it's even louder?

Thanks for any response

tschinz
User avatar
tschinz
 
Posts: 16
Joined: 15 Apr 2015, 21:36

Re: HifiBerry Amp+ Volume

Postby tschinz » 16 Apr 2015, 17:47

ok, i found a solution to enable hardware Volume on HiFiBerry Amp+

here my solution
1. Enable devicetree overlay for HifiBerry Amp+. Add the following line to /boot/config.txt
Code: Select all
device_tree_overlay=hifiberry-amp


2. Find the Sound card
Code: Select all
 
[root@runeaudio ~]# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
  Subdevices: 8/8
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
  Subdevice #7: subdevice #7
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: sndrpihifiberry [snd_rpi_hifiberry_amp], device 0: HifiBerry AMP HiFi tas5713-hifi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Choose your device, in my case it was => card 1 Subdivice #0 => hw:1,0 and hw:1
3. Change the following part in /etc/mpd.conf
Code: Select all
audio_output {
        name            "snd_rpi_hifiberry_amp"
        type            "alsa"
        device          "hw:1,0"
        mixer_type      "hardware"
        mixer_control   "Master"
        mixer_device    "hw:1"
        mixer_index     "0"
        auto_resample   "no"
        auto_format     "no"
        enabled         "yes"
}


4. Restart and the Volume should work

It even solved my second problem. The volume works from 0 - 100 but it is very quite the first 20%. That way I can use it in my bedroom

For the third problem that Airplay was too loud, this has changed drastically, Airplay is now too quite @ 100% Volume it's not 100% power more like 30%.

Any solution for Airplay being to quite?

Cheers tschinz
User avatar
tschinz
 
Posts: 16
Joined: 15 Apr 2015, 21:36

Re: HifiBerry Amp+ Volume

Postby pmoorhead » 16 Apr 2015, 19:23

should this work with the Pi 2?
i made the changed, rebooted and was then able to select hardware volume control in the MPD settings (previously doing this would cause a horrible noise and kill the output). Now I get audio but it's stuck at full volume - i.e. doesn't respond to the control
pmoorhead
 
Posts: 12
Joined: 11 Nov 2014, 21:58

Re: HifiBerry Amp+ Volume

Postby tschinz » 16 Apr 2015, 20:42

in my case it works with the Pi2 yes.

when its stuck at full volume that means the Master channel does not respond. I had the same issue but with the above mods it works for me now.

Did you also enter mixer_control "Master" ? Is it the right hw:x,y for you? Are you on the latest version of Runeaudio?

Cheers
User avatar
tschinz
 
Posts: 16
Joined: 15 Apr 2015, 21:36

Re: HifiBerry Amp+ Volume

Postby pmoorhead » 18 Apr 2015, 13:53

I was originally using the custom Pi 2, Hifiberry AMP build posted on another thread but I switched to the latest runeaudio build and your method above. But the same result - volume on maximum and not controllable.
and here's a weird thing. I edit the mpd.conf file as you describe above but after a reboot it has reverted to the previous file without the mixer settings. tried it three times. same thing every time. Am I hallucinating?
pmoorhead
 
Posts: 12
Joined: 11 Nov 2014, 21:58

Re: HifiBerry Amp+ Volume

Postby pmoorhead » 18 Apr 2015, 14:38

should have asked this in the first place. having edited the conf file directly, what should I change the runeaudio mpd settings for audio output and volume control to? or should i be leaving them untouched?
pmoorhead
 
Posts: 12
Joined: 11 Nov 2014, 21:58

Re: HifiBerry Amp+ Volume

Postby tschinz » 19 Apr 2015, 09:59

In my case, once I'm manually editing the mpd.conf file. In RuneAudio MPD Settings page I can't change anything it just displays that the config file was manually changed.
There are no drop boxes etc.

Well when the settings aren't stored then it's clear for me that it doesn't work. Who and why overrides the file?

I'lll investigate a bit.
User avatar
tschinz
 
Posts: 16
Joined: 15 Apr 2015, 21:36

Re: HifiBerry Amp+ Volume

Postby pmoorhead » 19 Apr 2015, 13:36

arch linux is a mystery to me - I can find my way around Debian and it's children but not arch.
the brute force solution in this case is to edit the file then make it immutable chattr +i /etc/mpd.conf

solves the problem but makes me feel slightly guilty. it's like using a goto.
as observed by others on this post, the volume range isn't linear and the first 30% or so of the range is very quiet but that's not a big deal.
pmoorhead
 
Posts: 12
Joined: 11 Nov 2014, 21:58

Re: HifiBerry Amp+ Volume

Postby BorGreiner » 02 Oct 2015, 19:54

Running into the same problem... Erm... Why is Hifiberry amp+ not in drop down menus anyway? Too new?
If I change mpd file using VI command it resets to output for amp+ that has no mixer_control "Master" line anymore. Help? :)
BorGreiner
 
Posts: 36
Joined: 30 Oct 2014, 06:37

Re: HifiBerry Amp+ Volume

Postby hondagx35 » 02 Oct 2015, 21:26

Hi BorGreiner,

a bit more info would make it lot easier to help:
- device (RP or RP2)
- updates installed?


@all
If you are on a PI2 then do this:
- get a fresh image
- get access to the console
- enable Hifiberry AMP+ in /boot/config.txt
Code: Select all
nano /boot/config.txt

Code: Select all
# Uncomment one of these lines to enable an audio interface
#device_tree_overlay=hifiberry-dac
#device_tree_overlay=hifiberry-dacplus
#device_tree_overlay=hifiberry-digi
device_tree_overlay=hifiberry-amp
#device_tree_overlay=iqaudio-dac
#device_tree_overlay=iqaudio-dacplus

- enter these commands
Code: Select all
cd /srv/http
git stash
git pull

- reboot your device
- select "HifiBerry AMP+" from MENU->MPD
- select "enabled-hardware"
Now your HifiBerry AMP+ should work with hardware volume control.
No need to edit mpd.conf or other tweaks.

If you are on an older PI then do this:
Sorry, but you have to wait for 0.4.
I have a version running that supports HifiBerry AMP, but it's not easy to update.

- Get access to the console::
There are two ways to get access to the console:
    1.) plug in a monitor and a keyboard
    2.) use SSH from your PC
      If you are not familiar with SSH read this for Windows or this for Linux/MacOS
      The default login for RuneAudio is "root" with the password "rune" (without quotes).

Frank
User avatar
hondagx35
 
Posts: 3039
Joined: 11 Sep 2014, 22:06
Location: Germany

support RuneAudio Donate with PayPal

Next

Return to Hi-Fi systems

Who is online

Users browsing this forum: No registered users and 0 guests