Getting Audiophonics i2s DAC working

Raspberry Pi related support

Getting Audiophonics i2s DAC working

Postby hoverdonkey » 01 Apr 2016, 19:04

Basic kit;
AUDIOPHONICS I-Sabre i2s DAC ES9023 V2 TCXO
Raspberry Pi 2.0
Rune Audio release version: 0.4 (build: beta-20160313)


I cannot get the DAC to show, let alone work in Rune. I am noob.

RuneAudio runs fine - I can play with it in my browser and ssh into it. The hardware all works as I have had Moode working.


So, as directed from settings I went into /boot/config.txt. I removed the # from dtparam=i2s=on. I rebooted. Still nothing is differnet in Settings/I²S kernel modules or MPD configuration/Audio output interface


Googling shows some refrence to kernel modules for specific DACs, but I see nothing like that in config.txt. I see some references to editing /boot/boot.ini but I cannot find this.


Any guidance or pointers to other threads/tutorials would be most welcome as I am now stuck!

Thanks
hoverdonkey
 
Posts: 3
Joined: 01 Apr 2016, 19:01

Re: Getting Audiophonics i2s DAC working

Postby hondagx35 » 01 Apr 2016, 20:19

Hi,

Caractéristiques :

Horloge haute précision TCXO 0.5ppm ultra faible jitter
Entrée I2S sur connecteur XHP 5 broches
Entrée 5 V sur connecteur XHP 2 broches (non nécessaire si le PI est alimenté par le port Micro USB)
Entrée : Raspberry PI B+ A+ 2.0 GPIO et I2S
Sortie : RCA haute qualité plaqué Or
Taux d'échantillonnage supportés : 24bit 192kHz
Aucune soudure nécessaire
Livré avec 4 écrous, 4 vis et 4 entretoises M2.5 servant à le fixer sur le PI B+, A+ ou 2.0 (Format HAT)
Entraxes : 50mm, 58mm
Dimensions PCB : 85x56x33mm
I2S driver : Hifiberry
Volume fixe sous Volumio en bitperfect


Do not enable I2S!
Try the Hifiberry DAC, or DAC+ as stated on Audiophonics website.

Frank
User avatar
hondagx35
 
Posts: 3038
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: Getting Audiophonics i2s DAC working

Postby Baldgreene » 01 Apr 2016, 20:39

Hello,

As suggested by Frank:
keep the I2S disabled (#dtparam=i2s=on )
enable the hifiberry-dac (device_tree_overlay=hifiberry-dac)

My audiophonics I-Sabre V3 is working fine with these settings.

Regards,

Lionel
Last edited by Baldgreene on 01 Apr 2016, 23:05, edited 1 time in total.
User avatar
Baldgreene
 
Posts: 6
Joined: 26 Mar 2016, 21:26
Location: France

Re: Getting Audiophonics i2s DAC working

Postby hoverdonkey » 01 Apr 2016, 20:52

Eureka!

Thank you both.
hoverdonkey
 
Posts: 3
Joined: 01 Apr 2016, 19:01

Re: Getting Audiophonics i2s DAC working

Postby remkovdz » 05 Jul 2016, 18:32

hondagx35 wrote:Hi,
Do not enable I2S!
Try the Hifiberry DAC, or DAC+ as stated on Audiophonics website.
Frank


I'm curious: why not to enable the I2S param? This is what I was trying and I'm seeing is does nothing for me either, but I can't figure out WHY not? Isn't it supposed to?
remkovdz
 
Posts: 1
Joined: 05 Jul 2016, 18:28

support RuneAudio Donate with PayPal


Return to Raspberry Pi

Who is online

Users browsing this forum: cmh714 and 3 guests
cron