Getting a DAC+ setup

Raspberry Pi related support

Re: Getting a DAC+ setup

Postby audio007 » 27 Sep 2016, 18:34

I have chhecked the debug file and still has the DAC error:

5.732671] snd-rpi-hifiberry-dacplus sound: ASoC: CPU DAI (null) not registered
[ 5.732700] snd-rpi-hifiberry-dacplus sound: snd_soc_register_card() failed: -517
[ 5.745326] snd-rpi-hifiberry-dacplus sound: ASoC: CODEC DAI pcm512x-hifi not registered
[ 5.745352] snd-rpi-hifiberry-dacplus sound: snd_soc_register_card() failed: -517
[ 5.915127] pcm512x 1-004d: Failed to reset device: -5
[ 5.915252] pcm512x: probe of 1-004d failed with error -5

I will investigate more and post again later.
audio007
 
Posts: 14
Joined: 26 Sep 2016, 17:18

Re: Getting a DAC+ setup

Postby audio007 » 27 Sep 2016, 19:10

Reimaged the SD card, nano altered the config.txt file to 'enable' dacplus.
Still no DAC available in the UI
the debug lines are now:

5.830791] snd-rpi-hifiberry-dacplus sound: ASoC: CODEC DAI pcm512x-hifi not registered
[ 5.830814] snd-rpi-hifiberry-dacplus sound: snd_soc_register_card() failed: -517
[ 6.021065] pcm512x 1-004d: Failed to reset device: -5
[ 6.021300] pcm512x: probe of 1-004d failed with error -5

I will try my Volumio SD card and see if that sees the DAC
audio007
 
Posts: 14
Joined: 26 Sep 2016, 17:18

Re: Getting a DAC+ setup

Postby audio007 » 27 Sep 2016, 19:36

Replaced Rune SD card with Volumio SD and the DAC was available and played.

Not sure what to do now?
audio007
 
Posts: 14
Joined: 26 Sep 2016, 17:18

Re: Getting a DAC+ setup

Postby audio007 » 28 Sep 2016, 08:47

Found the problem and it due to my stupidity!
I had uncommented the wrong line, the 'dacplus' one and not the 'digi' one.
Thanks to all who tried to help.
audio007
 
Posts: 14
Joined: 26 Sep 2016, 17:18

support RuneAudio Donate with PayPal

Previous

Return to Raspberry Pi

Who is online

Users browsing this forum: cmh714 and 11 guests
cron