Webradio Delete station issue (Solved)

General discussion about RuneAudio. Do not post any support or feature requests here.

Webradio Delete station issue (Solved)

Postby irishwill2008 » 10 Nov 2016, 11:08

I created a webradio and deleted it and it deleted the file in webradio folder .. GREAT! As its meant to, but it did not remove the index within the webradio section UI so i went to Sources and rebuilt the library and it removed it from the showing but when i reload the pi it comes back? But no file is there so i am guessing its in the encrypted db file? Indexed there some how?

When i go to edit to see if the link is there, comes back false?

Any idea how to fix this? Thanks!

Also, how do i decrypt that DB file to view the contents and re - encrypt?
Thanks.
Last edited by irishwill2008 on 11 Nov 2016, 13:37, edited 1 time in total.
irishwill2008
 
Posts: 157
Joined: 26 Jul 2016, 14:49
Location: Ireland

Re: Deleting webradio deletes file but keeps it listed after

Postby hondagx35 » 10 Nov 2016, 16:25

Hi,

works for me without any issues.
I'm using latest RP2/3 image here.

Seems like you have disabled auto update in mpd settings.


Frank
User avatar
hondagx35
 
Posts: 3039
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: Deleting webradio deletes file but keeps it listed after

Postby irishwill2008 » 10 Nov 2016, 18:06

Hi Frank,

That was indeed disabled, i enabled it there now but didnt fix the issue.

The station appears there but when i click edit it says false? With that said, when i press delete it just kicks me back to the tiles screen (no updating appearing on the tab) and once i go back into webradio its still there!

If i edit and put lets say Facebook.com and save, if i hit delete it deletes it and doesnt display in webradio (Yay moment!!) but again.. Once i reboot it comes back?? But before i reboot.. there is no .pls related to it :/ So it should NOT come back.. When i reboot and check the folder again, STILL no .pls? But yet it is showing in webradio panel but this time if i press edit, it comes back false again?

I guess the false is showing because it did INDEED delete the .pls and because of that it cant pull the url from a file that doesnt exist? So its coming back false.

What i dont get is, why is the station appearing still when there is no .pls?
Is it logged somewhere? Indexed somewhere?

Let me know thanks!
irishwill2008
 
Posts: 157
Joined: 26 Jul 2016, 14:49
Location: Ireland

Re: Deleting webradio deletes file but keeps it listed after

Postby hondagx35 » 10 Nov 2016, 18:41

Hi,

it is stored in the database.

Code: Select all
root@runeaudio(rw):~# redis-cli hgetall webradios
1) "Bayern 3"
2) "http://br_mp3-bayern3_m.akacast.akamaistream.net/7/442/142692/v1/gnl.akacast.akamaistream.net/br_mp3_bayern3_m"
3) "Antenne Bayern Classic Rock Live"
4) "http://mp3channels.webradio.antenne.de/classic-rock-live\n"
5) "Delicious Agony"
6) "http://HearMe.fm:8271/stream"


You can delete it like this:
Code: Select all
redis-cli hdel webradios "Bayern 3"


Frank
User avatar
hondagx35
 
Posts: 3039
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: Deleting webradio deletes file but keeps it listed after

Postby irishwill2008 » 11 Nov 2016, 13:37

Worked!
When i did the command:
Code: Select all
redis-cli hgetall webradios
it listed the station that wouldnt delete and did the command and bam! Gone.
Perfect, thanks a million Frank!

Still not sure what caused the issue as i can delete others perfectly, that was the only issue i had with that.
Anywho, solved now so im happy.
Cheers!

Regards,
Will.
irishwill2008
 
Posts: 157
Joined: 26 Jul 2016, 14:49
Location: Ireland

Re: Webradio Delete station issue (Solved)

Postby irishwill2008 » 08 Jan 2018, 16:40

I seem to be having the same issue again. Strange thing is, in "redis-cli hgetall webradios" i dont see a record for my track not deleting!

I have an entry i made for testing called "ffff" and whenever i try delete it just reappears! No listing in redis under webradio nor is there a listening for a .pls in /mnt/MPD/Webradio. My question now is.. Is there somewere else or something that stores these values other than the two listed? Somethings storing this and not allowing it to delete!

Any help appreciated.
irishwill2008
 
Posts: 157
Joined: 26 Jul 2016, 14:49
Location: Ireland

Re: Webradio Delete station issue (Solved)

Postby hondagx35 » 08 Jan 2018, 17:20

Hi Will,

Is there somewere else or something that stores these values other than the two listed?

No, see here https://github.com/hondagx35/RuneUI/blob/master/app/libs/runeaudio.php#L2881

Frank
User avatar
hondagx35
 
Posts: 3039
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: Webradio Delete station issue (Solved)

Postby irishwill2008 » 09 Jan 2018, 12:55

Hi Frank,

Thanks for the reply! Yeah i had a feeling thats all but im not sure why i am seeing this record when its not stored anywhere? Matter of fact, its gone now! But thats the weird thing, it comes and goes! Not sure if its a strange cache issue?
irishwill2008
 
Posts: 157
Joined: 26 Jul 2016, 14:49
Location: Ireland

Re: Webradio Delete station issue (Solved)

Postby rern » 09 Jan 2018, 14:51

Hi Will,

It could be MPD was not yet refreshed for new data.
If it happened again, try:
Code: Select all
mpc update Webradio


Webradio Import addon does:
- delete webradio database
- get data from *.pls files
- write data to database
- update MPD data
Raspberry Pi 3B > SMSL M8 DAC
Raspberry Pi Zero W
Raspberry Pi 4B
GitHub
User avatar
rern
 
Posts: 603
Joined: 14 Jul 2016, 08:15

Re: Webradio Delete station issue (Solved)

Postby hondagx35 » 09 Jan 2018, 17:54

Hi ,

Rune executes a "mpd update Webradios" after each add, edit or delete.

Frank
User avatar
hondagx35
 
Posts: 3039
Joined: 11 Sep 2014, 22:06
Location: Germany

support RuneAudio Donate with PayPal


Return to General discussion

Who is online

Users browsing this forum: No registered users and 3 guests