[SOLVED] crackles and glitches

Please report any bug found here

[SOLVED] crackles and glitches

Postby kyuzzo » 30 Dec 2013, 21:43

Hi,

scenario: rPi, diynhk xmos usb, dac sellarz 9018
external DIYNHK power supply +5 to GPIO pins 6 of rPI and+15 to dac
xmos feeded by usb, maybe tomorrw I'll connect external +5
NAS music collection mounted with NFS

symptoms: random glitch,crackles (I called farts) during play

never had this problem with alix board connected to exactly same xmos and dac

this evening I've found this kernel messages

[270402.735305] smsc95xx 1-1.1:1.0: eth0: kevent 2 may have been dropped
[270402.742730] smsc95xx 1-1.1:1.0: eth0: kevent 2 may have been dropped
[270404.108208] SLAB: Unable to allocate memory on node 0 (gfp=0x20)
[270404.108242] cache: size-32, object size: 32, order: 0
[270404.108355] node 0: slabs: 457/457, objs: 51641/51641, free: 0
[270404.108380] ERROR::_complete:357: dwc_otg_hcd: complete: cannot allocate URB TQ entry

I suspect the cause was eth usb sharing bus

cheers
kyuzzo
 
Posts: 3
Joined: 30 Dec 2013, 21:32
Location: Asti, Italy

Re: crackles and glitches

Postby ACX » 31 Dec 2013, 16:29

Hello kyuzzo, getting the best quality from the Raspberry Pi is an interesting challenge, and we count on users feedbacks to continue improving the performance. Unfortunately the Raspberry Pi has some known limitations (shared USB/ethernet bus with a not perfectly working driver and power source issues) that we can only overcome with workarounds. There isn't an universal fix yet, but we managed to get very good results (read: at least 24/96 playback from NAS without pops) on a consistent number of different setups. I'm sorry it does not work properly in yours.

We are going to receive a XMOS based DAC in days, so we can test a similiar setup and see if same problems appear.
In the meanwhile can you try a workaround and tell me how it performs?
1) if you can, delete the NFS mount and add it again, using CIFS protocol this time, with this advanced settings: rsize=8192, wsize=16384
2) select "OrionV2" kernel profile under MENU > Settings
Let me know if crackles and glitches disappear.
User avatar
ACX
RuneAudio co-founder
 
Posts: 1689
Joined: 29 Nov 2013, 02:25
Location: Udine, Italy

Re: crackles and glitches

Postby kyuzzo » 05 Jan 2014, 11:30

solved editing rsize wsize in fstab

default parameters in nfs mount was very high

keep up the good work

happy new year !
kyuzzo
 
Posts: 3
Joined: 30 Dec 2013, 21:32
Location: Asti, Italy

Re: crackles and glitches

Postby ACX » 07 Jan 2014, 17:13

I'm happy it worked :) Did you use the suggested values?
How does it sound? Any feedback about sound quality?

Stay tuned because 0.2 beta it's on the way with some good improvements.

Ciao!
User avatar
ACX
RuneAudio co-founder
 
Posts: 1689
Joined: 29 Nov 2013, 02:25
Location: Udine, Italy

Re: crackles and glitches

Postby kyuzzo » 08 Jan 2014, 11:27

flawless sounding with a gigabit eth

this is the mtab output

192.168.9.1:/volume1/music /mnt/NAS/Music nfs4 rw,relatime,vers=4.0,rsize=8192,wsize=8192,namlen=255,hard,proto=tcp,port=0,timeo=600,retrans=2,sec=sys,clientaddr=192.168.9.131,local_lock=none,addr=192.168.9.1 0 0
kyuzzo
 
Posts: 3
Joined: 30 Dec 2013, 21:32
Location: Asti, Italy

support RuneAudio Donate with PayPal


Return to Bug report

Who is online

Users browsing this forum: No registered users and 0 guests