connecting to samba share

Raspberry Pi related support

connecting to samba share

Postby tsawyer » 13 Apr 2021, 19:01

running 20210403 on pi3 b, rev 1.2. I'm still banging my head trying to connect rune to samba share. so thought I'd change it up and connect from my window desktop to rune. if I have samba running on rune, I should be able to mount the library as a drive. normally it would just be net use x: \\<ip address>\<share>, my question becomes what is the share name? I see I can set perms on  /mnt/MPD/SD and  /mnt/MPD/USB but what is considered the share name? I did not pull up smb.conf, normally I add and define the share information at the bottom of the file. am I approaching this correctly? I know I can ftp to my usb drive but I wanted to see if this worked. ultimately, I'd like to have all the rune boxes connect to a pi running samba to control an attached drive where all the files are centrally managed. so far I have not been able to get rune to connect to the nas I created. I know some people have gotten rune to connect to something like synology nas but it should be the same process on a samba nas. so far, not so much
tsawyer
 
Posts: 68
Joined: 05 Jul 2017, 03:02

Re: connecting to samba share

Postby Ears of Tin » 13 Apr 2021, 22:21

I think I'm doing what you are trying to do. A have a RPi3 running RaspberryOS with an attached HDD connected by ethernet cable to my router. I then access the HDD files with rAudio, volumio, VLC on other devices via wifi. I created a smb server on the Pi and that is where the samba share name was created. Then I enter that IP address/share name/password into the respective dialog boxes in rAudio, volumio, etc. The only coding/commands were done on the RPi3. If it matters my HDD is formatted ntfs.
Ears of Tin
 
Posts: 61
Joined: 17 Dec 2018, 00:42

Re: connecting to samba share

Postby tsawyer » 13 Apr 2021, 23:48

yeah, that's pretty much where I'd like to go. so when I select sources, add, select cifs, populate name, ip, etc it never actually connects. I see network mount flashing, the icon flashing but that's it. the nas is raspberry lite with a drive attached to it. from multiple windows machines I can connect to the nas, do whatever with the share. it's trying to get rune to read to it I'm having the problems. but even trying to reverse things where I connect to the thumb drive on a rune box via a samba share I'm not sure.

the only thing I can see where you config may be different is from windows the share says it's formatted ntfs. I'm 99% sure I did NOT format it ntfs when I created the samba share. I'd have to look at fstab on it to see what I'm declaring the format as but ntfs doesn't sound correct. since I have the samba share matted to my windows machine, I can use vlc to open a file on the share but it's just from rune that does not happen for me.
tsawyer
 
Posts: 68
Joined: 05 Jul 2017, 03:02

Re: connecting to samba share

Postby rern » 14 Apr 2021, 12:44

@tsawyer,

Today's update should fix mounting network share bugs.

rern
rAudio @ https://github.com/rern/rAudio-1
Raspberry Pi 4B
Raspberry Pi 3B > SMSL M8 DAC
Raspberry Pi Zero W
User avatar
rern
 
Posts: 715
Joined: 14 Jul 2016, 08:15

Re: connecting to samba share

Postby tsawyer » 14 Apr 2021, 15:47

rern

thanks for all the work. I did update one of the boxes to the last update, I can see a difference now when I select nas from the source menu. when I do attempt to add my nas I do get the same blinking. I have a different question on this. I am attempting to mount 150 gb of music (the only thing on that nas is mp3s. this is the same format, structure I have on local usb minus some new cds I ripped from my library I haven't had a chance to update to the local usb). at the time of mounting, is the blinking saying it's in progress and parsing the data? if that is the case, is there a timeout value? since pi3 are limited to 100 mb for the nic, I'm wondering if network speeds/hw limitiations are my problems now. if posting debugging information is more relevent, I can take that route (after scrubbing)
tsawyer
 
Posts: 68
Joined: 05 Jul 2017, 03:02

Re: connecting to samba share

Postby rastus » 16 Apr 2021, 06:04

tsawyer wrote:....is the blinking saying it's in progress and parsing the data?

Yes, it is in my case (1TB of music) and it takes hours of 'blinking' to get done.
User avatar
rastus
 
Posts: 352
Joined: 21 Aug 2015, 10:29

Re: connecting to samba share

Postby Ears of Tin » 16 Apr 2021, 12:37

Yep several hours for me too. That's the nature of all library building including Plex. One advantage of VLC is you can play files from directories without building a tag-based library so you can play a new acquisition without updating anything.

When I'm setting up or changing things I test with a small by sub directory of a few albums first. Indexing that should take moments. When that works add your full collection and go for a walk.
Ears of Tin
 
Posts: 61
Joined: 17 Dec 2018, 00:42

Re: connecting to samba share

Postby tsawyer » 16 Apr 2021, 14:06

very good point on testing a small sample. when I get some time maybe I'll setup another pi (I have a build book so all the steps would be the same) and test it that way. I still see the problems as timing out/something else going on. I actually will get a message saying done if I watch but of course nothing is mounted. I just confirmed these steps, I'm attempting to use the rune in basement since I can let that run without touching anything by accident. I want to see if allowing it to run for hours. the process should be to successfully mount the share then parse. I'm failing at step 1 so it's not waiting for items to show up in the library. the only thing I did was switch away from the window.

and yes, vlc does work directly on the mount. I was going with rune to play thru stereos. my workstation is used for other things, I never really set it up to be a real music source. I can hear things but I'm using stock sound card so there's a difference between the basement setup (back when fire was a new invention I dumped some serious coins into it) and basic workstation.
tsawyer
 
Posts: 68
Joined: 05 Jul 2017, 03:02

Re: connecting to samba share

Postby tsawyer » 16 Apr 2021, 19:23

@ear

dude, owe you a drink. had a few mins between calls and meetings and realized I had another samba share running on the network. I had pi3d running so I moved a folder there to see if I could connect. 1 folder was able to be seen by rune and played a few secs of a song. so that does prove rune and a nas can play together. now why the main one is a problem child, I'll have to play with more with things to see if the particular drive or the board is an issue.
tsawyer
 
Posts: 68
Joined: 05 Jul 2017, 03:02

Re: connecting to samba share

Postby tsawyer » 16 Apr 2021, 20:27

and the problem? my pw for root and smb had a space!!!! $^%&$%*$#&^$$#$%@#*^%&!

I've ssh'd into the box, setup other stuff, no issues with the space but rune does not like it. fair enough. I thought I would try that last piece before attaching another device for the share and since my pi3d box worked on the share seemed like a good idea. did save me a lot of work copying 150 gb but I want to kick myself for not trying that how many hours ago.


just wanted everyone to know in case anyone goes down this path how not to screw themselves
tsawyer
 
Posts: 68
Joined: 05 Jul 2017, 03:02

support RuneAudio Donate with PayPal


Return to Raspberry Pi

Who is online

Users browsing this forum: cmh714, Google [Bot] and 6 guests
cron