Cant boot RPi3B+ (0.5beta)

Raspberry Pi related support

Cant boot RPi3B+ (0.5beta)

Postby GlennS » 24 Apr 2020, 10:22

Hi,
I'm experienced linux user, but fairly new to RPi. I have a Pi3B+ that I'm playing with and a PCM5122 DAC HAT.
I started out by loading the Voluxxx image (sorry) and everything works fine. But I want to include other features to control some in-house electronics via I2C so the rather protected environment of V-o doesn't suit me.
So I found and loaded the 0.5Beta image for RuneAudio - (20180903_10_runeaudio_rpiB2.img) - but I can't get it to start properly. It starts to boot, gets to the point of reporting (on HDMI screen) "/dev/mmcbk0p2: clean..." and then nothing else (no prompt). At the same time, after some activity on the network, there is no network connection - no IP Addr allocation. I only use ethernet, no WiFi.
I've spent hours going round in circles modifying the dhcpcd.config and other things, but to no avail. Even with the DAC HAT removed the symptoms are the same. I've also gone back to the clean 0.5beta image - always the same symptoms. As soon as I go back to Raspian or Volxxio, everything works just fine.
Any ideas, please?
P.S. My network addresses are 192.168.5.xxx/24 : could that be a problem (I saw something about an internal WiFi address or something) ?
Screenshot_network-config.png
Screenshot_network-config.png (51.93 KiB) Viewed 483 times

To answer my own question, "Yes - I think it does !" :P
I borrowed a router using a more normal 192.168.0.xxx/24 range, AND IT WORKS! The above screenshot shows 1) that I have an connection and I can connect; 2) the WiFi AP is using *MY* network adress range.
So my question becomes : how can I connect RuneAudio to a 192.168.5.xxx/24 IP4 network ?
GlennS
 
Posts: 6
Joined: 24 Apr 2020, 10:09

Re: Cant boot RPi3B+ (0.5beta)

Postby GlennS » 24 Apr 2020, 17:42

What I've found, that works :
    Turn off WiFi in config.txt
    Modify the WiFi WAP dns file, /etc/dnsmasq.conf :
Code: Select all
<pre># DHCP-Server for WIFI-Interface
interface=wlan0
bind-dynamic
no-hosts

# exclude DHCP-Server for ethernet
no-dhcp-interface=eth0

# IPv4 address-range and lease-time
dhcp-range=192.168.6.2,192.168.6.254,24h

# DNS
dhcp-option-force=option:router,192.168.6.1
dhcp-option-force=option:dns-server,192.168.6.1
</pre>

... to change .5. to .6.
Now all is fine!
GlennS
 
Posts: 6
Joined: 24 Apr 2020, 10:09

support RuneAudio Donate with PayPal


Return to Raspberry Pi

Who is online

Users browsing this forum: cmh714 and 11 guests