Audio Device changes after reboot (XMOS WaveIO Board)

Cubietruck related support

Audio Device changes after reboot (XMOS WaveIO Board)

Postby Guitarfreak » 23 Jan 2016, 17:17

Hello,
finally my WaveIO Board arrived and i tried to get it working with Rune and the Cubietruck.
I can change the Audio Output Interface to "Luckit USB Audio 2.0" which is the WaveIO Board.
I can save and apply, but after rebooting Rune changes back to the default output "sunxi-sndi2s"

Why does it do that?
How can i set the output interface so that it does not change anymore?

Thank you and best regards

Daniel
Guitarfreak
 
Posts: 14
Joined: 13 Dec 2015, 16:34

Re: Audio Device changes after reboot (XMOS WaveIO Board)

Postby hondagx35 » 23 Jan 2016, 18:21

Hi Daniel,

It seems, that your usb dac (Luckit USB Audio 2.0) is not yet recognized then RuneAudio starts.
I have to find a solution for this.

You can try to delay the start by adding this line:
Code: Select all
sleep ( 5 );

at top of this file /srv/http/command/rune_SY_wrk.

Also to have your debug data would be helpfull.

Frank
User avatar
hondagx35
 
Posts: 3039
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: Audio Device changes after reboot (XMOS WaveIO Board)

Postby Guitarfreak » 23 Jan 2016, 18:57

Hello Frank,

the WaveIO ist powerd by a different power supply and dont need the 5V from USB.
When i reboot the Cubietruck, the WaveIO/Xmos is still powered and working.
So i think delaying the startup would not work.

By the way, when i look in the Settings of mPad The output is still set to "Luckit USB 2.0"

Which part of the Debug do you need?
Its to long to post it here (too much charatcters)

Best regards
Daniel
Guitarfreak
 
Posts: 14
Joined: 13 Dec 2015, 16:34

Re: Audio Device changes after reboot (XMOS WaveIO Board)

Postby hondagx35 » 23 Jan 2016, 21:27

Hi Daniel,

So i think delaying the startup would not work.

And i know that it is the problem.

It seems, that your usb dac (Luckit USB Audio 2.0) is not yet recognized then RuneAudio starts.

To be powered does not mean recognized by the kernel.

The dmesg part at the end of your debug is the interesting part.
Search for your DAC.

Frank
User avatar
hondagx35
 
Posts: 3039
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: Audio Device changes after reboot (XMOS WaveIO Board)

Postby Guitarfreak » 23 Jan 2016, 23:21

Hello Frank,

i added the delay, but still the same effect.
When i reboot, the Audio Output changes 3-times on startup.

Here ist the Debug:


Code: Select all
###### Kernel status (dmesg) ######
[    0.000000] Booting Linux on physical CPU 0
[    0.000000] Initializing cgroup subsys cpuset
[    0.000000] Initializing cgroup subsys cpu
[    0.000000] Linux version 3.4.106-sun7i+ (daniel@danand.de) (gcc version 4.9.1 (Ubuntu/Linaro 4.9.1-16ubuntu6) ) #5 SMP PREEMPT Mon Feb 2 23:47:31 CET 2015
[    0.000000] CPU: ARMv7 Processor [410fc074] revision 4 (ARMv7), cr=10c5387d
[    0.000000] CPU: PIPT / VIPT nonaliasing data cache, VIPT aliasing instruction cache
[    0.000000] Machine: sun7i
[    0.000000] Memory Reserved:
[    0.000000]    SYS  : 0x43000000 - 0x4300ffff  (  64 kB)
[    0.000000]    LCD  : 0x44000000 - 0x45ffffff  (  32 MB)
[    0.000000] Memory policy: ECC disabled, Data cache writealloc
[    0.000000] sunxi: Allwinner A20 (AW1651/sun7i) detected.
[    0.000000] On node 0 totalpages: 524288
[    0.000000] free_area_init_node: node 0, pgdat c091bc40, node_mem_map d0000000
[    0.000000]   DMA zone: 512 pages used for memmap
[    0.000000]   DMA zone: 0 pages reserved
[    0.000000]   DMA zone: 65024 pages, LIFO batch:15
[    0.000000]   Normal zone: 1008 pages used for memmap
[    0.000000]   Normal zone: 128016 pages, LIFO batch:31
[    0.000000]   HighMem zone: 2576 pages used for memmap
[    0.000000]   HighMem zone: 327152 pages, LIFO batch:31
[    0.000000] PERCPU: Embedded 7 pages/cpu @d100e000 s8064 r8192 d12416 u32768
[    0.000000] pcpu-alloc: s8064 r8192 d12416 u32768 alloc=8*4096
[    0.000000] pcpu-alloc: [0] 0 [0] 1
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 520192
[    0.000000] Kernel command line: console=tty0
 root=/dev/nand2
 loglevel=1
 sunxi_no_mali_mem_reserve sunxi_g2d_mem_reserve=0 sunxi_ve_mem_reserve=0 hdmi.audio=EDID:0 disp.screen0_output_mode=1280x730 rootwait panic=10 rootfstype=ext4 rootflags=discard consoleblank=0
[    0.000000] PID hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
[    0.000000] Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
[    0.000000] allocated 4194304 bytes of page_cgroup
[    0.000000] please try 'cgroup_disable=memory' option if you don't want memory cgroups
[    0.000000] Memory: 2048MB = 2048MB total
[    0.000000] Memory: 2031664k/2031664k available, 65488k reserved, 1318912K highmem
[    0.000000] Virtual kernel memory layout:
[    0.000000]     vector  : 0xffff0000 - 0xffff1000   (   4 kB)
[    0.000000]     fixmap  : 0xfff00000 - 0xfffe0000   ( 896 kB)
[    0.000000]     vmalloc : 0xf0000000 - 0xff000000   ( 240 MB)
[    0.000000]     lowmem  : 0xc0000000 - 0xef800000   ( 760 MB)
[    0.000000]     pkmap   : 0xbfe00000 - 0xc0000000   (   2 MB)
[    0.000000]     modules : 0xbf000000 - 0xbfe00000   (  14 MB)
[    0.000000]       .text : 0xc0008000 - 0xc0875058   (8629 kB)
[    0.000000]       .init : 0xc0876000 - 0xc08acf80   ( 220 kB)
[    0.000000]       .data : 0xc08ae000 - 0xc092a618   ( 498 kB)
[    0.000000]        .bss : 0xc092a63c - 0xc0afef80   (1875 kB)
[    0.000000] SLUB: Genslabs=11, HWalign=64, Order=0-3, MinObjects=0, CPUs=2, Nodes=1
[    0.000000] Preemptible hierarchical RCU implementation.
[    0.000000]    RCU dyntick-idle grace-period acceleration is enabled.
[    0.000000]    Additional per-CPU info printed with stalls.
[    0.000000] NR_IRQS:192
[    0.000000] Architected local timer running at 24.00MHz.
[    0.000000] sched_clock: 32 bits at 24MHz, resolution 41ns, wraps every 178956ms
[    0.000000] start_kernel(): bug: interrupts were enabled early
[    0.000000] Console: colour dummy device 80x30
[    0.000000] console [tty0] enabled
[    0.013339] Calibrating delay loop... 1819.40 BogoMIPS (lpj=3031040)
[    0.035983] pid_max: default: 32768 minimum: 301
[    0.039695] Mount-cache hash table entries: 512
[    0.044020] Initializing cgroup subsys cpuacct
[    0.047377] Initializing cgroup subsys memory
[    0.050818] Initializing cgroup subsys devices
[    0.054232] Initializing cgroup subsys freezer
[    0.057470] Initializing cgroup subsys blkio
[    0.061154] Initializing cgroup subsys perf_event
[    0.064731] CPU: Testing write buffer coherency: ok
[    0.069952] CPU0: thread -1, cpu 0, socket 0, mpidr 80000000
[    0.077051] hw perfevents: enabled with ARMv7 Cortex-A7 PMU driver, 5 counters available
[    0.082606] Setting up static identity map for 0x405e0058 - 0x405e00b0
[    0.113270] CPU1: Booted secondary processor
[    0.134164] CPU1: thread -1, cpu 1, socket 0, mpidr 80000001
[    0.136173] Brought up 2 CPUs
[    0.141507] SMP: Total of 2 processors activated (3397.92 BogoMIPS).
[    0.144738] devtmpfs: initialized
[    0.151067] dummy:
[    0.154800] NET: Registered protocol family 16
[    0.161223] DMA: preallocated 256 KiB pool for atomic coherent allocations
[    0.169106] hw-breakpoint: found 5 (+1 reserved) breakpoint and 4 watchpoint registers.
[    0.173924] hw-breakpoint: maximum watchpoint size is 8 bytes.
[    0.177088] [ccu-inf] aw clock manager init
[    0.179372] [ccu-inf] aw_ccu_init
[    0.183493] [ccu-inf] script config pll3 to 297MHz
[    0.187261] [ccu-inf] script config pll4 to 300MHz
[    0.191023] [ccu-inf] script config pll6 to 600MHz
[    0.194785] [ccu-inf] script config pll7 to 297MHz
[    0.198542] [ccu-inf] script config pll8 to 336MHz
[    0.201308] Init eGon pin module V2.0
[    0.211146] bio: create slab  at 0
[    0.214705] sunxi_gpio driver init ver 1.3
[    0.220359] gpiochip_add: registered GPIOs 1 to 2 on device: A1X_GPIO
[    0.223531] SCSI subsystem initialized
[    0.226405] libata version 3.00 loaded.
[    0.231069] usbcore: registered new interface driver usbfs
[    0.235416] usbcore: registered new interface driver hub
[    0.239582] usbcore: registered new device driver usb
[    0.242698] Linux media interface: v0.10
[    0.246327] Linux video capture interface: v2.00
[    0.251922] Advanced Linux Sound Architecture Driver Version 1.0.25.
[    0.258132] cfg80211: Calling CRDA to update world regulatory domain
[    0.262890] Switching to clocksource arch_sys_counter
[    0.265017] FS-Cache: Loaded
[    0.267215] CacheFiles: Loaded
[    0.279395] [usb_manager]: CONFIG_USB_SW_SUNXI_USB0_OTG
[    0.283235] [sw_hcd0]: usb host driver initialize........
[    0.287419] [sw_hcd0]: open_usb_clock
[    0.309010] [sw_hcd0]: host_init_state = 1
[    0.309997] [sw_hcd0]: platform is usb host
[    0.312907] [sw_hcd0]: sw_hcd_host0: ConfigData=0xde (UTMI-8, dyn FIFOs, bulk combine, bulk split, HB-ISO Rx (X), HB-ISO Tx (X), SoftConn)
[    0.324107] [sw_hcd0]: sw_hcd_init_controller: sw_hcd_host0: USB Host mode controller at f1c13000 using PIO, IRQ 70
[    0.336647] sw_hcd_host0 sw_hcd_host0: sw_hcd host driver
[    0.343360] sw_hcd_host0 sw_hcd_host0: new USB bus registered, assigned bus number 1
[    0.346842] hub 1-0:1.0: USB hub found
[    0.349778] hub 1-0:1.0: 1 port detected
[    0.353656] wrn: hcd is not enable, need not start hcd
[    0.355048] [sw_hcd0]: sw_usb_host0_disable start
[    0.361082] -------sw_hcd0_soft_disconnect---------
[    0.364067] is_on = 0, hcd0_set_vbus_cnt = 0
[    0.367119] [sw_hcd_host0]: Set USB Power Off
[    0.370864] wrn: hcd is not enable, need not stop hcd
[    0.371905] [sw_hcd0]: close_usb_clock
[    0.374381] [sw_hcd0]: sw_usb_host0_disable end
[    0.377571] [sw_udc]: udc_init: version 20080411
[    0.383981] NET: Registered protocol family 2
[    0.402707] IP route cache hash table entries: 32768 (order: 5, 131072 bytes)
[    0.409712] TCP established hash table entries: 131072 (order: 8, 1048576 bytes)
[    0.417261] TCP bind hash table entries: 65536 (order: 7, 786432 bytes)
[    0.423949] TCP: Hash tables configured (established 131072 bind 65536)
[    0.426152] TCP: reno registered
[    0.431043] UDP hash table entries: 512 (order: 2, 16384 bytes)
[    0.436395] UDP-Lite hash table entries: 512 (order: 2, 16384 bytes)
[    0.440046] NET: Registered protocol family 1
[    0.445403] RPC: Registered named UNIX socket transport module.
[    0.449107] RPC: Registered udp transport module.
[    0.452777] RPC: Registered tcp transport module.
[    0.458241] RPC: Registered tcp NFSv4.1 backchannel transport module.
[    0.464091] audit: initializing netlink socket (disabled)
[    0.467837] type=2000 audit(0.437:1): initialized
[    0.472368] highmem bounce pool size: 64 pages
[    0.484690] VFS: Disk quotas dquot_6.5.2
[    0.490245] Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
[    0.498176] NFS: Registering the id_resolver key type
[    0.502843] NTFS driver 2.1.30 [Flags: R/W].
[    0.506186] fuse init (API version 7.18)
[    0.514549] SGI XFS with ACLs, security attributes, large block/inode numbers, no debug enabled
[    0.518853] msgmni has been set to 1392
[    0.527113] alg: No test for stdrng (krng)
[    0.533890] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 252)
[    0.536821] io scheduler noop registered
[    0.540065] io scheduler deadline registered
[    0.543776] io scheduler cfq registered (default)
[    0.548708] sunxi disp driver loaded (/dev/disp api 1.0)
[    0.554358] Serial: 8250/16550 driver, 8 ports, IRQ sharing disabled
[    0.559321] [uart]: used uart info.: 0x05
[    0.564058] [uart]: serial probe 0 irq 33 mapbase 0x01c28000
[    0.587649] sunxi-uart.0: ttyS0 at MMIO 0x1c28000 (irq = 33) is a U6_16550A
[    0.592549] [uart]: serial probe 2 irq 35 mapbase 0x01c28800
[    0.616086] sunxi-uart.2: ttyS1 at MMIO 0x1c28800 (irq = 35) is a U6_16550A
[    0.618711] G2D: drv_g2d_init
[    0.622065] G2D: Module initialized.major:250
[    0.625201] brd: module loaded
[    0.631412] loop: module loaded
[    0.634764] [NAND] nand driver version: 0x2 0x9
[    0.693713] Dev Sunxi softw311 nand magic does not match for MBR 1: softw411
[    0.699757] Dev Sunxi softw311 nand magic does not match for MBR 2:
[    0.705775] Dev Sunxi softw311 nand magic does not match for MBR 3:
[    0.711790] Dev Sunxi softw311 nand magic does not match for MBR 4:
[    0.719536] Dev Sunxi softw311 nand header bad for all MBR copies, MBR corrupted or not present.
[    0.729148] Dev Sunxi softw411 nand: part 1, start 32768, size 32768
[    0.734763] Dev Sunxi softw411 nand: part 2, start 65536, size 14974976
[    0.736792]  nand: nand1 nand2
[    0.739762] [NAND]nand driver, ok.
[    0.746174] sw_ahci sw_ahci.0: controller can't do PMP, turning off CAP_PMP
[    0.750484] sw_ahci sw_ahci.0: forcing PORTS_IMPL to 0x1
[    0.757944] sw_ahci sw_ahci.0: AHCI 0001.0100 32 slots 1 ports 3 Gbps 0x1 impl platform mode
[    0.764433] sw_ahci sw_ahci.0: flags: ncq sntf pm led clo only pio slum part ccc
[    0.767872] scsi0 : sw_ahci_platform
[    0.775126] ata1: SATA max UDMA/133 mmio [mem 0x01c18000-0x01c18fff] port 0x100 irq 88
[    0.780032] emac_init fetch emac using configuration failed
[    0.782492] emac driver is disabled
[    0.786062] gmac: use mac address from chipid
[    0.790185] gmac: device MAC address 02:c8:08:c0:b3:a7
[    0.795912] [gmac]: sun6i_gmac platform driver registration completed
[    0.799213] PPP generic driver version 2.4.2
[    0.803164] PPP BSD Compression module registered
[    0.807198] PPP Deflate Compression module registered
[    0.812183] PPP MPPE Compression module registered
[    0.815634] NET: Registered protocol family 24
[    0.821678] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    0.826914] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    0.829372] [sw-ehci1]: open clock
[    0.849418] [sw-ehci1]: Set USB Power ON
[    0.855870] sw-ehci sw-ehci.1: SW USB2.0 'Enhanced' Host Controller (EHCI) Driver
[    0.862136] sw-ehci sw-ehci.1: new USB bus registered, assigned bus number 2
[    0.866540] sw-ehci sw-ehci.1: irq 71, io mem 0x01c14000
[    0.879829] sw-ehci sw-ehci.1: USB 2.0 started, EHCI 1.00
[    0.882467] ehci_irq: port change detect
[    0.885897] hub 2-0:1.0: USB hub found
[    0.888837] hub 2-0:1.0: 1 port detected
[    0.891500] [sw-ohci1]: open clock
[    0.914994] sw-ohci sw-ohci.1: SW USB2.0 'Open' Host Controller (OHCI) Driver
[    0.921272] sw-ohci sw-ohci.1: new USB bus registered, assigned bus number 3
[    0.925599] sw-ohci sw-ohci.1: irq 96, io mem 0x01c14400
[    0.985657] hub 3-0:1.0: USB hub found
[    0.988586] hub 3-0:1.0: 1 port detected
[    0.991307] [sw-ehci2]: open clock
[    1.011325] [sw-ehci2]: Set USB Power ON
[    1.017772] sw-ehci sw-ehci.2: SW USB2.0 'Enhanced' Host Controller (EHCI) Driver
[    1.024032] sw-ehci sw-ehci.2: new USB bus registered, assigned bus number 4
[    1.028441] sw-ehci sw-ehci.2: irq 72, io mem 0x01c1c000
[    1.039818] sw-ehci sw-ehci.2: USB 2.0 started, EHCI 1.00
[    1.043257] hub 4-0:1.0: USB hub found
[    1.046171] hub 4-0:1.0: 1 port detected
[    1.048834] [sw-ohci2]: open clock
[    1.072330] sw-ohci sw-ohci.2: SW USB2.0 'Open' Host Controller (OHCI) Driver
[    1.078547] sw-ohci sw-ohci.2: new USB bus registered, assigned bus number 5
[    1.082879] sw-ohci sw-ohci.2: irq 97, io mem 0x01c1c400
[    1.097287] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[    1.122815] ata1.00: ATA-8: ADATA SP900, 6.0.3b, max UDMA/133
[    1.128491] ata1.00: 250069680 sectors, multi 1: LBA48 NCQ (depth 31/32)
[    1.137134] ata1.00: configured for UDMA/133
[    1.146418] scsi 0:0:0:0: Direct-Access     ATA      ADATA SP900      6.0. PQ: 0 ANSI: 5
[    1.149126] hub 5-0:1.0: USB hub found
[    1.152121] hub 5-0:1.0: 1 port detected
[    1.158556] sd 0:0:0:0: [sda] 250069680 512-byte logical blocks: (128 GB/119 GiB)
[    1.162981] Initializing USB Mass Storage driver...
[    1.166731] sd 0:0:0:0: [sda] Write Protect is off
[    1.170774] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
[    1.175731] usbcore: registered new interface driver usb-storage
[    1.179323] USB Mass Storage support registered.
[    1.187319] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    1.192296] usbcore: registered new interface driver ums-alauda
[    1.197415] usbcore: registered new interface driver ums-cypress
[    1.202521] usbcore: registered new interface driver ums-datafab
[    1.203840]  sda: sda1
[    1.209043] usbcore: registered new interface driver ums_eneub6250
[    1.214442] usb 2-1: new high-speed USB device number 2 using sw-ehci
[    1.219472] usbcore: registered new interface driver ums-freecom
[    1.224490] usbcore: registered new interface driver ums-isd200
[    1.228069] sd 0:0:0:0: [sda] Attached SCSI disk
[    1.233213] usbcore: registered new interface driver ums-jumpshot
[    1.238077] usbcore: registered new interface driver ums-karma
[    1.243216] usbcore: registered new interface driver ums-onetouch
[    1.248259] usbcore: registered new interface driver ums-realtek
[    1.253205] usbcore: registered new interface driver ums-sddr09
[    1.258151] usbcore: registered new interface driver ums-sddr55
[    1.263061] usbcore: registered new interface driver ums-usbat
[    1.267872] mousedev: PS/2 mouse device common for all mice
[    1.273464] ===========================hv_keypad_init=====================
[    1.276879] ========HV Inital ===================
[    1.280818] tkey_fetch_sysconfig_para: tkey_unused.
[    1.288040] hv_keypad_init: after fetch_sysconfig_para:  normal_i2c: 0x0. normal_i2c[1]: 0x0
[    1.293095] sunxi-rtc sunxi-rtc: Warning: RTC time is wrong!
[    1.298410] sunxi-rtc sunxi-rtc: rtc core: registered rtc as rtc0
[    1.300949] i2c /dev entries driver
[    1.304641] config i2c gpio with gpio_config api
[    1.310345] axp_mfd 0-0034: AXP (CHIP ID: 0x41) detected
[    1.316159] axp_mfd 0-0034: AXP internal temperature monitoring enabled
[    1.321524] [AXP]axp driver uning configuration failed(342)
[    1.323476] [AXP]power_start = 0
[    1.327164] i2c i2c-0: Invalid probe address 0x00
[    1.330230] I2C: i2c-0: AW16XX I2C adapter
[    1.334282] [cedar dev]: not installed! ve_mem_reserve=0
[    1.337724] [tt]----- avs_dev driver load... ----
[    1.341322] [tt]-----      register iomem      ----
[    1.344131] Cannot reserve region for ccmu
[    1.347856] [tt]--- avs_dev driver load ok!! -----
[    1.349632] [ace_drv] start!!!
[    1.352200] [ace_drv] init end!!!
[    1.353916] [pa_drv] start!!!
[    1.356276] [pa_drv] init end!!!
[    1.358722] axp20_ldo1: 1300 mV
[    1.364317] axp20_ldo2: 1800 <--> 3300 mV at 3000 mV
[    1.369406] axp20_ldo3: 700 <--> 3500 mV at 2800 mV
[    1.374557] axp20_ldo4: 1250 <--> 3300 mV at 2800 mV
[    1.379731] axp20_buck2: 700 <--> 2275 mV at 1450 mV
[    1.384900] axp20_buck3: 700 <--> 3500 mV at 1300 mV
[    1.389778] axp20_ldoio0: 1800 <--> 3300 mV at 2800 mV
[    1.399365] input: axp20-supplyer as /devices/platform/sunxi-i2c.0/i2c-0/0-0034/axp20-supplyer.28/input/input0
[    1.417142] axp20_ldo2: Failed to create debugfs directory
[    1.422231] sunxi_wdt: sunxi WatchDog Timer Driver v1.0
[    1.427316] sunxi_wdt: initialized (timeout=23s, nowayout=0)
[    1.431365] device-mapper: uevent: version 1.0.3
[    1.439187] device-mapper: ioctl: 4.22.0-ioctl (2011-10-19) initialised: dm-devel@redhat.com
[    1.444184] device-mapper: multipath: version 1.3.2 loaded
[    1.449696] device-mapper: multipath round-robin: version 1.0.0 loaded
[    1.455278] device-mapper: multipath queue-length: version 0.1.0 loaded
[    1.460866] device-mapper: multipath service-time: version 0.2.0 loaded
[    1.464335] cpuidle: using governor ladder
[    1.467241] cpuidle: using governor menu
[    1.469576] [mmc-msg] sw_mci_init
[    1.475370] [mmc-msg] MMC host used card: 0x9, boot card: 0x0, io_card 8
[    1.480749] [mmc-msg] sdc0 set round clock 400000, src 24000000
[    1.489022] [mmc-msg] sdc0 set ios: clk 0Hz bm OD pm OFF vdd 3.3V width 1 timing LEGACY(SDR12) dt B
[    1.497083] [mmc-msg] sdc0 Probe: base:0xf014c000 irq:64 sg_cpu:f014e000(4fc00000) ret 0.
[    1.502089] [mmc-msg] sdc3 set round clock 400000, src 24000000
[    1.510323] [mmc-msg] sdc3 set ios: clk 0Hz bm OD pm OFF vdd 3.3V width 1 timing LEGACY(SDR12) dt B
[    1.518370] [mmc-msg] sdc3 Probe: base:0xf0150000 irq:67 sg_cpu:f0152000(4fc01000) ret 0.
[    1.522960] [mmc_pm]: failed to fetch sdio card configuration!
[    1.525335] sunxi_leds driver init
[    1.529416] Registered led device: blue:ph21:led1
[    1.533362] Registered led device: orange:ph20:led2
[    1.537219] Registered led device: white:ph11:led3
[    1.541084] Registered led device: green:ph07:led4
[    1.546158] ledtrig-cpu: registered to indicate activity on CPUs
[    1.552744] sunxi-ss sunxi-ss: CLOCK parent 600000000 (600 MHz) need >= 24000000
[    1.558433] sunxi-ss sunxi-ss: CLOCK bus 1 (0 MHz) (must be >= 24000000)
[    1.564971] sunxi-ss sunxi-ss: CLOCK ss 150000000 (150 MHz) (must be <= 150000000)
[    1.568932] alg: No test for stdrng (sunxi-ss-rng)
[    1.572361] sunxi-ss sunxi-ss: Registred PRNG
[    1.575926] sunxi-ss sunxi-ss: Registred MD5
[    1.579485] sunxi-ss sunxi-ss: Registred SHA1
[    1.582879] sunxi-ss sunxi-ss: Registred AES
[    1.586559] sunxi-ss sunxi-ss: Options: poll mode
[    1.591834] usbcore: registered new interface driver usbhid
[    1.594660] usbhid: USB HID core driver
[    1.597427] ashmem: initialized
[    1.601086] logger: created 256K log 'log_main'
[    1.604915] logger: created 256K log 'log_events'
[    1.608659] logger: created 256K log 'log_radio'
[    1.612521] logger: created 256K log 'log_system'
[    1.620287] asoc: sndspdif <-> sunxi-spdif.0 mapping ok
[    1.623684] [IIS]Entered sunxi_i2s_init
[    1.627903] [I2S-0] sunxi_i2s_init I2S used in master mode
[    1.631121] [IIS]Entered sunxi_i2s_dev_probe
[    1.635902] [I2S-0] sndi2s_codec_init I2S used in master mode
[    1.640645] [I2S-0] sndi2s_codec_probe I2S used in master mode
[    1.643499] [IIS]Entered sunxi_sndi2s_init
[    1.647960] [I2S-0] sunxi_sndi2s_init I2S used in master mode
[    1.652540] asoc: sndi2s <-> sunxi-i2s.0 mapping ok
[    1.656883] IPv4 over IPv4 tunneling driver
[    1.659749] TCP: bic registered
[    1.662057] TCP: cubic registered
[    1.664588] TCP: westwood registered
[    1.667218] TCP: highspeed registered
[    1.669500] TCP: hybla registered
[    1.671692] TCP: htcp registered
[    1.673962] TCP: vegas registered
[    1.676157] TCP: veno registered
[    1.678695] TCP: scalable registered
[    1.680706] TCP: lp registered
[    1.682900] TCP: yeah registered
[    1.685439] TCP: illinois registered
[    1.688688] Initializing XFRM netlink socket
[    1.692843] NET: Registered protocol family 10
[    1.697391] NET: Registered protocol family 17
[    1.700873] NET: Registered protocol family 15
[    1.705550] [mmc_pm]: No sdio card, please check your config !!
[    1.709239] Registering the dns_resolver key type
[    1.711504] VFP support v0.3: implementor 41 architecture 2 part 30 variant 7 rev 4
[    1.720083] Registering SWP/SWPB emulation handler
[    1.724720] axp20_buck2: Failed to create debugfs directory
[    1.730899] [cpu_freq] INF:-------------------V-F Table-------------------
[    1.735971] [cpu_freq] INF:   voltage = 1450mv    frequency = 1008MHz
[    1.741031] [cpu_freq] INF:   voltage = 1425mv    frequency =  912MHz
[    1.746088] [cpu_freq] INF:   voltage = 1350mv    frequency =  864MHz
[    1.751145] [cpu_freq] INF:   voltage = 1250mv    frequency =  720MHz
[    1.756202] [cpu_freq] INF:   voltage = 1150mv    frequency =  528MHz
[    1.761259] [cpu_freq] INF:   voltage = 1100mv    frequency =  312MHz
[    1.766314] [cpu_freq] INF:   voltage = 1050mv    frequency =  144MHz
[    1.771371] [cpu_freq] INF:   voltage = 1000mv    frequency =    0MHz
[    1.777206] [cpu_freq] INF:-----------------------------------------------
[    1.786955] [cpu_freq] INF:sunxi_cpufreq_initcall, get cpu frequency from sysconfig, max freq: 912MHz, min freq: 720MHz
[    1.790890] registered taskstats version 1
[    1.796944] [DISP] Invalid tv-mode string: 1280x730, ignoring
[    1.800513] I2C: i2c-1: HDMI I2C adapter
[    1.835321] disp clks: lcd 74250000 pre_scale 1 hdmi 74250000 pll 297000000 2x 0
[    2.433795] Console: switching to colour frame buffer device 160x45
[    2.500344] axp20_buck3: incomplete constraints, leaving on
[    2.505122] axp20_buck2: incomplete constraints, leaving on
[    2.509806] axp20_ldo4: incomplete constraints, leaving on
[    2.514487] axp20_ldo3: incomplete constraints, leaving on
[    2.519167] axp20_ldo2: incomplete constraints, leaving on
[    2.523850] axp20_ldo1: incomplete constraints, leaving on
[    2.528292] console [netcon0] enabled
[    2.531778] netconsole: network logging started
[    2.539658] otg_wakelock_init: No USB transceiver found
[    2.547196] sunxi-rtc sunxi-rtc: setting system clock to 2010-01-01 00:00:00 UTC (1262304000)
[    2.549253] ALSA device list:
[    2.552321]   #0: sunxi-CODEC  Audio Codec
[    2.554517]   #1: sunxi-sndspdif
[    2.556527]   #2: sunxi-sndi2s
[    2.580879] EXT4-fs (nand2): warning: mounting unchecked fs, running e2fsck is recommended
[    2.589728] EXT4-fs (nand2): mounted filesystem without journal. Opts: discard
[    2.594693] VFS: Mounted root (ext4 filesystem) on device 93:2.
[    2.609999] devtmpfs: mounted
[    2.613151] Freeing init memory: 216K
[    3.045935] systemd[1]: systemd 216 running in system mode. (+PAM -AUDIT -SELINUX -IMA -APPARMOR +SMACK -SYSVINIT +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ -LZ4 +SECCOMP +BLKID -ELFUTILS +KMOD -IDN )
[    3.050507] systemd[1]: Detected architecture 'arm'.
[    3.059141] systemd[1]: Set hostname to .
[    3.783168] systemd[1]: Starting Forward Password Requests to Wall Directory Watch.
[    3.790428] systemd[1]: Started Forward Password Requests to Wall Directory Watch.
[    3.794767] systemd[1]: Starting Remote File Systems.
[    3.800189] systemd[1]: Reached target Remote File Systems.
[    3.806906] systemd[1]: Expecting device sys-subsystem-net-devices-eth0.device...
[    3.814142] systemd[1]: Expecting device sys-subsystem-net-devices-wlan0.device...
[    3.818652] systemd[1]: Starting Encrypted Volumes.
[    3.823695] systemd[1]: Reached target Encrypted Volumes.
[    3.831750] systemd[1]: Starting Arbitrary Executable File Formats File System Automount Point.
[    3.841590] systemd[1]: Set up automount Arbitrary Executable File Formats File System Automount Point.
[    3.848927] systemd[1]: Starting Dispatch Password Requests to Console Directory Watch.
[    3.856309] systemd[1]: Started Dispatch Password Requests to Console Directory Watch.
[    3.859361] systemd[1]: Starting Paths.
[    3.863337] systemd[1]: Reached target Paths.
[    3.868062] systemd[1]: Starting System Time Synchronized.
[    3.873694] systemd[1]: Reached target System Time Synchronized.
[    3.876639] systemd[1]: Starting Swap.
[    3.880468] systemd[1]: Reached target Swap.
[    3.883937] systemd[1]: Starting Root Slice.
[    3.925770] systemd[1]: Created slice Root Slice.
[    3.930457] systemd[1]: Starting Delayed Shutdown Socket.
[    3.936409] systemd[1]: Listening on Delayed Shutdown Socket.
[    3.942289] systemd[1]: Starting /dev/initctl Compatibility Named Pipe.
[    3.949268] systemd[1]: Listening on /dev/initctl Compatibility Named Pipe.
[    3.954674] systemd[1]: Starting Device-mapper event daemon FIFOs.
[    3.961078] systemd[1]: Listening on Device-mapper event daemon FIFOs.
[    3.966036] systemd[1]: Starting LVM2 metadata daemon socket.
[    3.972000] systemd[1]: Listening on LVM2 metadata daemon socket.
[    3.976352] systemd[1]: Starting udev Control Socket.
[    3.981571] systemd[1]: Listening on udev Control Socket.
[    3.985788] systemd[1]: Starting udev Kernel Socket.
[    3.990887] systemd[1]: Listening on udev Kernel Socket.
[    3.994774] systemd[1]: Starting Journal Socket.
[    3.999763] systemd[1]: Listening on Journal Socket.
[    4.007965] systemd[1]: Starting System Slice.
[    4.014435] systemd[1]: Created slice System Slice.
[    4.019131] systemd[1]: Mounting Temporary Directory...
[    4.041002] systemd[1]: Starting system-netctl\x2dauto.slice.
[    4.207712] systemd[1]: Created slice system-netctl\x2dauto.slice.
[    4.213135] systemd[1]: Starting system-netctl\x2difplugd.slice.
[    4.222701] systemd[1]: Created slice system-netctl\x2difplugd.slice.
[    4.269251] systemd[1]: Starting RuneAudio shutdown script...
[    4.483900] systemd[1]: Starting system-getty.slice.
[    4.502817] systemd[1]: Created slice system-getty.slice.
[    4.539693] systemd[1]: Starting Create list of required static device nodes for the current kernel...
[    4.768624] systemd[1]: Mounting POSIX Message Queue File System...
[    4.800380] systemd[1]: Starting Load Kernel Modules...
[    4.841345] systemd[1]: Starting udev Coldplug all Devices...
[    4.857922] systemd[1]: Starting Setup Virtual Console...
[    4.878528] systemd[1]: Mounting Debug File System...
[    4.897359] systemd[1]: Mounted Huge Pages File System.
[    4.927608] systemd[1]: Started Set Up Additional Binary Formats.
[    4.931909] systemd[1]: Starting Journal Service...
[    4.945319] systemd[1]: Started Journal Service.
[    5.177412] input: sunxi-ir as /devices/virtual/input/input1
[    5.179487] IR Initial OK
[    5.526677] systemd-udevd[99]: starting version 216
[    6.783670] usbcore: registered new interface driver snd-usb-audio
[    7.987171] sunxi_gmac: probed
[    7.992717] eth0: PHY ID 001cc915 at 0 IRQ 0 (sunxi_gmac-0:00) active
[    7.998408] eth0: PHY ID 001cc915 at 1 IRQ 0 (sunxi_gmac-0:01)
[   10.008809] PHY: sunxi_gmac-0:00 - Link is Up - 100/Full
[   15.306311] EXT4-fs error (device nand2): ext4_mb_generate_buddy:741: group 3, 12568 clusters in bitmap, 12566 in gd
[   18.431762] eth0: no IPv6 routers present
[  102.556612] eth0: must be stopped to change its MTU
[  102.906270] usbcore: deregistering interface driver snd-usb-audio
[  103.604876] usbcore: registered new interface driver snd-usb-audio

###### PHP backend ######
php version:   5.5.17
debug level:   1


Debug data collected in 3.938 seconds.
Guitarfreak
 
Posts: 14
Joined: 13 Dec 2015, 16:34

Re: Audio Device changes after reboot (XMOS WaveIO Board)

Postby hondagx35 » 24 Jan 2016, 01:17

Hi Daniel,

your DAC gets recognized here
Code: Select all
[ 6.783670] usbcore: registered new interface driver snd-usb-audio

So please try a longer delay.

Frank
User avatar
hondagx35
 
Posts: 3039
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: Audio Device changes after reboot (XMOS WaveIO Board)

Postby Guitarfreak » 24 Jan 2016, 12:36

Hello Frank i delayed the start to 15, but it still changes the Interface in the RuneUI - but i stays right on the mPad app?

I also got these error message after startup:
"Warning: socket_write() expects parameter 1 to be resource, boolean given in /srv/http/app/libs/runeaudio.php on line 99 Warning: socket_last_error() expects parameter 1 to be resource, boolean given "

Dont know what that means?

Thank you
Best regards
Daniel
Guitarfreak
 
Posts: 14
Joined: 13 Dec 2015, 16:34

Re: Audio Device changes after reboot (XMOS WaveIO Board)

Postby Guitarfreak » 25 Jan 2016, 21:39

so no solution in sight?


Best regards
Daniel
Guitarfreak
 
Posts: 14
Joined: 13 Dec 2015, 16:34

Re: Audio Device changes after reboot (XMOS WaveIO Board)

Postby hondagx35 » 25 Jan 2016, 23:25

Hi Daniel,

at the moment i have no access to my cubietruck, so no chance to debug.
As soon as possible i'll take a look at this issue.

I know i had this issue once (or someone on the forum) and the delay helped.

"Warning: socket_write() expects parameter 1 to be resource, boolean given in /srv/http/app/libs/runeaudio.php on line 99 Warning: socket_last_error() expects parameter 1 to be resource, boolean given "

These warnings can be ignored.

Frank
User avatar
hondagx35
 
Posts: 3039
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: Audio Device changes after reboot (XMOS WaveIO Board)

Postby Guitarfreak » 27 Jan 2016, 21:47

Hello Frank,

would it maybe be possible to just disable the two other outpust of the cubietruck (the i2s and the digital out) would it not be forced to use the Xmos/usb only?

Best regards
Daniel
Guitarfreak
 
Posts: 14
Joined: 13 Dec 2015, 16:34

support RuneAudio Donate with PayPal

Next

Return to Cubietruck

Who is online

Users browsing this forum: No registered users and 0 guests